在线检测未来函数

通达信多线趋势主图指标公式

来源:Internet,编辑:股旁网,2016-12-28

M9:EMA(C,9);
M6:EMA(C,55),COLORRED;
MA23:EMA(C,23),COLORYELLOW;
M43:=EMA(C,43),COLORRED;
M47:EMA(C,47),COLORGREEN;
M48:EMA(M47,3),COLORGREEN;
M49:EMA(M48,3),COLORFF00FF;
M50:EMA(M49,3),COLORFF00FF;
MA60:EMA(CLOSE,60),COLORFFCC66;
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3));
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
DRAWTEXT(JDU2,M9*0.95,'空转多'),COLORYELLOW;
DRAWTEXT(CROSS(M6,M9),M9*0.93,'空转多'),COLORWHITE;

通达信多线趋势主图指标公式

 

相关文章