在线检测未来函数

通达信KDJ角度指标公式

来源:Internet,编辑:股旁网,2016-12-28

M1:=3;
M2:=3;
N:=9;
多头:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20)AND MA(C,30)>MA(C,60) AND KDJ.J>REF(KDJ.J,1) AND KDJ.J<80;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
MA10:=MA(C,5);
角度:=ATAN((J/REF(J,1)-1)*100)*180/3.1416;
IF(角度>45,J,DRAWNULL),LINETHICK2,COLORRED;
IF(角度<-10,J,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWTEXT(角度>88 AND多头,90,'I'),COLORYELLOW;

通达信KDJ角度指标公式

 

相关文章