在线检测未来函数

前三天震荡幅度小于1.5%公式

来源:Internet,编辑:股旁网,2016-12-21

编写要求:

前三天震荡幅度小于1.5%,不仅每天小于1.5%,整个三天也都在这个震荡幅度的箱体内。

股旁网解答:

TD:=3;{天数,可以设定}
ZFZ:=1.5;{振幅值,可以设定}
C2:=REF(C,2);
H1:=REF(H,1);
L1:=REF(L,1);
ZF:=100*(H1-L1)/C2;{昨天开始计算}
TZF:=200*(HHV(H1,TD)-LLV(L1,TD))/(HHV(H1,TD)+LLV(L1,TD));{昨天开始计算的三天}
XG:EVERY(ZF<ZFZ,TD) AND TZF<2*ZFZ;

相关文章