在线检测未来函数

通达信无影DMI指标公式

来源:Internet,编辑:股旁网,2017-01-03

N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR,,LINETHICK3,COLORYELLOW;
MDI: DMM*100/MTR,LINETHICK3,COLORCYAN;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM),COLORRED;
ADXR:EXPMEMA(ADX,MM),COLORGREEN;

通达信无影DMI指标公式

 

相关文章