在线检测未来函数

通达信大浪淘沙指标公式

来源:Internet,编辑:股旁网,2017-01-04

VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
波:BB,POINTDOT,COLOR0000A8;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
浪:EMA(D1,3),POINTDOT,COLORYELLOW;
STICKLINE((BB-VARC>0),BB,VARC,5,0),COLOR0000C0;
STICKLINE((BB-VARC>0),BB,VARC,4,0),COLOR0000E0;
STICKLINE((BB-VARC>0),BB,VARC,3,0),COLOR0000F0;
STICKLINE((BB-VARC>0),BB,VARC,2,0),COLOR0000D0;
STICKLINE((BB-VARC>0),BB,VARC,1,0),COLOR0000FF;
STICKLINE((BB-VARC<0),BB,VARC,5,0),COLOR00B500;
STICKLINE((BB-VARC<0),BB,VARC,4,0),COLOR00C600;
STICKLINE((BB-VARC<0),BB,VARC,3,0),COLOR00D500;
STICKLINE((BB-VARC<0),BB,VARC,1,0),COLOR00E600;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFF5D00;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFF5D10;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFF7710;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFF8810;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFF9910;天界:80,POINTDOT,COLORF00FF0;
中界:50,POINTDOT,COLORWHITE;
地界:20,COLOR00FF00,POINTDOT;
VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR28:=IF(DATE<=1120930,1,0);
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0);
VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4);
VAR16:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR7:=100-ABS(VAR16);
VAR18:=IF(VAR7<90,VAR7,100);
PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
短期强弱:=PJX*VAR28,LINETHICK2,COLORFFFFFF;

通达信大浪淘沙指标公式

 

相关文章