在线检测未来函数

通达信精准趋势跟踪指标公式

来源:Internet,编辑:股旁网,2017-01-05

AA:=VOL/((H-L)*2-ABS(C-O));
买量:=AA*(H-L);
卖量:=0-AA*((H-C)+(O-L));
进出量:=(买量+卖量)>0;
AA1:=FILTER(L=LLV(L,13),8);
AA2:=IF(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0);
AA3:=EMA(AA2,3)*10;
AA4:=SUMBARS(AA3>0,21);
AA5:=SUM(AA3,AA4)/21;
AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 AND LLV(L,3)/HHV(H,18)<0.88;
均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ; {增加这个条件过滤掉那些股票价格继续下行,而出现信号}
反转:=FILTER(AA6 AND 进出量 AND 均线条件,3); {增加了过滤信号语句,减少重复信号}
STICKLINE(CLOSE,0,AA3,3,0),COLORRED;
STICKLINE(反转,0,AA3,3,0),COLORYELLOW;
VAR1:=-1;
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*10);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
主力趋向: (10-VARA)*VAR1,COLOR0000FF;
VARD:=主力趋向>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR11:=EMA(VARF,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*10;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*10;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*10;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*10;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*10;
VAR1D:=SMA(VAR1C,5,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*10;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VARD,VAR4,主力趋向,1,0),COLOR0099FF;
顶部预警线:88,COLOR86FF86 ,LINETHICK2 ;
高危线:100,COLOR376F00 ,LINETHICK3 ;
转折线:0,COLOR00CACA ,LINETHICK2 ;
底部线: 20,COLORWHITE ,LINETHICK2 ;
中轴:50,COLORRED,POINTDOT,LINETHICK4;
DIF:(EMA(C,5)-EMA(C,60))/EMA(C,60)*300,COLOR0063C6;
DEA:(EMA(C,10)-EMA(C,60))/EMA(C,60)*300;
MACD:(DIF-DEA)*2,COLORSTICK;

通达信精准趋势跟踪指标公式

 

相关文章