在线检测未来函数

同花顺筹码带宽指标公式

来源:Internet,编辑:股旁网,2017-01-11

N:=2;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1A:=BARSLAST(REF(CROSS(diff,dea),1));
B1A:=REF(C,A1A+1)>C AND REF(diff,A1A+1)<diff AND CROSS(diff,dea);
DRAWTEXT(IF(B1A>0,1,0),L,'↖MACD底背'),colorgreen;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
k:=SMA(RSV,3,1);
d:=SMA(k,3,1);
A2:=BARSLAST(REF(CROSS(k,d),1));
B2:=REF(C,A2+1)>C AND REF(k,A2+1)<k AND CROSS(k,d);
DRAWTEXT(IF(B2>0,1,0),L,'↖KDJ底背'),coloryellow;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B3>0,1,0),L,'↖RSI底背'),colorcyan;
C1:=BARSLAST(REF(CROSS(dea,diff),1));
D1:=REF(C,C1+1)<C AND REF(diff,C1+1)>diff AND CROSS(dea,diff);
DRAWTEXT(IF(D1>0,1,0),H,'↖MACD顶背'),colorwhite;
C2:=BARSLAST(REF(CROSS(d,K),1));
D2:=REF(C,C2+1)<C AND REF(k,C2+1)>k AND CROSS(d,K);
DRAWTEXT(IF(D2>0,1,0),H,'↖KDJ顶背'),colorwhite;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H,'↖RSI顶背'),colormagenta;
VAR0:=(CLOSE*2+HIGH+LOW)/4*VOL;
var1:=SUM(VAR0,89)/SUM(VOL,89);
var2:=IF(COUNT(VAR0>0,2)>=2,MA(CLOSE,89)*(1+(MA(VAR0,89)/REF(MA(VAR0,89),1)-1)/21),MA(CLOSE,89));
var3:=IF(COUNT(ABS(CLOSE-var1)>21,8)>=1 AND COUNT(CLOSE/REF(CLOSE,1)<0.8,8)<1 AND COUNT(VAR0>0,2)>=2,10,0);
var4:=IF(CLOSE>=var1 AND COUNT(VAR0>0,2)>=2,var1*1.001,IF(VAR0<0.1 AND COUNT(VAR0>0,2)<1.5,MA(CLOSE,89),var1*0.999));
var5:=IF(var3>0,var2,var4);
var6:=MA(CLOSE,89);
搏杀生命线:IF(var5/REF(var5,1)>1.1 OR var5/REF(var5,1)<0.9,VAR6,VAR5);
FS:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),color00ffff,linethick1;
MPC:=MA((OPEN+CLOSE+HIGH+LOW)/4,46);
aa:=(CLOSE>MPC AND CLOSE>MA(CLOSE, 5)) OR (C<MPC AND C>MA(C,5) AND C>FS);
bb:=(CLOSE<MPC AND C<MA(C,5)) OR (C>MPC AND C<MA(C,5));
cc:=IF(aa AND bb,0,1);
STICKLINE(cc,CLOSE,OPEN,10,1),coloryellow;
STICKLINE(cc,HIGH,MAX(C,O),1,1),coloryellow;
STICKLINE(cc,MIN(C,O),LOW,1,1),coloryellow;
STICKLINE(aa,CLOSE,OPEN,10,1),colorred;
STICKLINE(aa,HIGH,C,1,1),colorred;
STICKLINE(aa,L,O,1,1),colorred;
STICKLINE(bb,CLOSE,OPEN,10,1),colorgreen;
STICKLINE(bb,L,C,1,1),colorgreen;
STICKLINE(bb,OPEN,H,1,1),colorgreen;
STICKLINE(aa AND C<O,HIGH,C,2,0),colorgreen;
STICKLINE(aa AND C<O,HIGH,L,2,0),colorgreen;
STICKLINE(bb AND C>O AND BB>=REF(BB,1),L,C,2,0),colorred;
STICKLINE(bb AND C>O AND BB>REF(BB,1),L,H,2,0),colorred;
MAV:=(3*CLOSE+HIGH+LOW+OPEN)/6;
MA$1:(EMA(MAV,5)+EMA(MAV,13)+EMA(MAV,21)+EMA(MAV,34)+EMA(MAV,55)+EMA(MAV,89)+EMA(MAV,144)+EMA(MAV,233))/8,color440022;
MA$2:EMA(MA$1,N),color990099;
MA$3:EMA(MA$2,N),color990099;
MA$4:EMA(MA$3,N),color990099;
MA$5:EMA(MA$4,N),color990099;
MA$6:EMA(MA$5,N),color009900;
MA$7:EMA(MA$6,N),color009900;
MA$8:EMA(MA$7,N),color009900;
MA$9:EMA(MA$8,N),color009900;
MA$10:EMA(MA$9,N),color009900;
B1:IF(MA$1>REF(MA$1,1),MA$1,DRAWNULL),colorwhite;
B2:IF(MA$2>REF(MA$2,1),MA$2,DRAWNULL),colorwhite;
B3:IF(MA$3>REF(MA$3,1),MA$3,DRAWNULL),colorwhite;
B4:IF(MA$4>REF(MA$4,1),MA$4,DRAWNULL),colorwhite;
B5:IF(MA$5>REF(MA$5,1),MA$5,DRAWNULL),colorwhite;
B6:IF(MA$6>REF(MA$6,1),MA$6,DRAWNULL),colorred;
B7:IF(MA$7>REF(MA$7,1),MA$7,DRAWNULL),colorred;
B8:IF(MA$8>REF(MA$8,1),MA$8,DRAWNULL),colorred;
B9:IF(MA$9>REF(MA$9,1),MA$9,DRAWNULL),colorred;
B10:IF(MA$10>REF(MA$10,1),MA$9,DRAWNULL),colorred;

同花顺筹码带宽指标公式

 

相关文章