在线检测未来函数

通达信多种买入卖出信号提示主图指标公式

来源:Internet,编辑:股旁网,2017-01-11

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
MA120:=MA(CLOSE,120);
MA250:=MA(CLOSE,250);
中期临界点: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),LINETHICK2,COLORRED;
{涨跌家数}
涨:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌:INDEXDEC,NODRAW,COLORGREEN;
▼天顶:=HHV(HIGH,35),COLORGREEN, LINETHICK1.8;
▲地底:=LLV(LOW,55),COLORRED,LINETHICK1.8;
无间道:=(▼天顶+▲地底)/2,COLORRED,CIRCLEDOT,LINETHICK;
DRAWICON(CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ,LOW*0.98,1);
{DRAWTEXT(CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ,LOW*0.96,'波段低吸');}
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) ,HIGH*1.02,2);
{DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) ,HIGH*1.02,'波段高抛');}
{财务数据}
DRAWTEXT_FIX(ISLASTBAR,0.18,0.01,1,'上市日期:'),COLOR00FF00;
DRAWNUMBER_FIX(ISLASTBAR,0.18,0.01,0,FINANCE(42)),COLOR00FF00;
DRAWTEXT_FIX(1,0.01,0.13,0,EXTERNSTR(0,1)),COLORRED;
DRAWTEXT_FIX(1,0.26,0.01,0,EXTERNSTR(0,2)),COLORDD00DD;
DRAWTEXT_FIX(1,0.01,0.066,0,EXTERNSTR(0,3)),COLOR00DD00;
DRAWTEXT_FIX(ISLASTBAR ,0.06,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.065,0.01,0,HYBLOCK),COLORYELLOW;
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);
FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
{DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLOR00FF00;}
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
{STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;}
{DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;}
{DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;}
{STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;};
{涨停标注}
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
{涨停天数}
VARZT:=BARSLAST(C/REF(C,1)>1.094);
DRAWTEXT(VARZT=2,L*0.95,'3T'),COLORYELLOW;
DRAWTEXT(VARZT=4,H*1.06,'5T'),COLORYELLOW;
DRAWTEXT(VARZT=7,L*0.95,'8T'),COLORYELLOW;
DRAWTEXT(VARZT=12,H*1.06,'13T'),COLORYELLOW;
DRAWTEXT(VARZT=20,L*0.95,'21T'),COLORYELLOW;
DRAWTEXT(VARZT=33,H*1.06,'34T'),COLORYELLOW;
DRAWTEXT(VARZT=54,L*0.95,'55T'),COLORYELLOW;
DRAWTEXT(VARZT=88,H*1.06,'89T'),COLORYELLOW;
DRAWTEXT(VARZT=143,L*0.95,'144T'),COLORYELLOW;
DRAWTEXT(VARZT=232,H*1.06,'233T'),COLORYELLOW;
DRAWTEXT(VARZT=376,L*0.95,'377T'),COLORYELLOW;
Z:=ISLASTBAR;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)>REF(O,1)&&C>O&&Z,0.98,0.2,1,'①乾:阳极,防变'),COLORFF00FF;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)>REF(O,1)&&C<=O&&Z,0.98,0.2,1,'②兑:阳减,调整'),COLORFFFF00;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)<=REF(O,1)&&C>O&&Z,0.98,0.2,1,'③离:阳光,关注'),COLOR00FFFF;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)<=REF(O,1)&&C<=O&&Z,0.98,0.2,1,'④震:继阴,空仓'),COLORFF0000;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)>REF(O,1)&&C>O&&Z,0.98,0.2,1,'⑤巽:继阳,持股'),COLORFF00FF;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)>REF(O,1)&&C<=O&&Z,0.98,0.2,1,'⑥坎:阴风,看跌'),COLORFF0000;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)<=REF(O,1)&&C>O&&Z,0.98,0.2,1,'⑦艮:阴减,反弹'),COLOR00FFFF;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)<=REF(O,1)&&C<=O&&Z,0.98,0.2,1,'⑧坤:阴极,待转'),COLORFF0000;
{暴跌买入}
TJ1:=EMA((C-L),20)/EMA((H-L),20)*100;
TJ2:=(L-ABS(MIN(C,O)))/L<=1;
TJ3:=ABS((L-MA(C,5)))/L*100>10;
TJ4:=TJ1 AND TJ2 AND TJ3;
DRAWTEXT(TJ4 AND TJ1>REF(TJ1,1),LOW*0.95,'BD'),COLORRED;
DRAWICON(TJ4 AND TJ1>REF(TJ1,1),L*0.95,1);
{暴涨}
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2;

通达信多种买入卖出信号提示主图指标公式

 

相关文章