在线检测未来函数

通达信短线比较好用的主图指标公式

来源:Internet,编辑:股旁网,2017-01-12

C,COLORMAGENTA,LINETHICK2;
K:=2;
ZIG(2,K),COLORYELLOW,LINETHICK2;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
EXP3:EXPMA(C,3),COLORRED;
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWICON(选股,L*0.975,1);
DIF:=EMA(DCLOSE,3)-EMA(DCLOSE,5);
DEA:=EMA(DIF,5);
AAA:=(DIF-DEA)*2*20;
爆:=CROSS(AAA-REF(AAA,1),2),COLORRED,LINETHICK2;
DRAWTEXT(爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2;
VAR1:=1;
VAR2:=(CLOSE-MA(CLOSE,2))/MA(CLOSE,2)*100;
VAR3:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VAR4:=REF(VAR2,1)<-10 AND VAR3;
VAR5:=REF(VAR2,1)<-10 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>10;
VAR6:=FILTER(VAR4 OR VAR5,2);
VAR7:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
VAR8:=REF(VAR2,1)>ABS(-10) AND VAR7;
VAR9:=REF(VAR2,1)>ABS(-10) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>10;
VARA:=FILTER(VAR8 OR VAR9,2);
VARB:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VARC:=REF(VAR2,1)<-10 AND VAR3;
VARD:=REF(VAR2,1)<-10 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>10;
VARE:=FILTER(VARC OR VARD,2);
VARF:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
VAR10:=REF(VAR2,1)>ABS(-5) AND VAR7;
VAR11:=REF(VAR2,1)>ABS(-5) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>10;
VAR12:=FILTER(VAR10 OR VAR11,2);
DRAWICON(VAR6*VAR1>0,LOW,1);
DRAWICON(VARA*VAR1>0,HIGH,2);
DRAWTEXT(VAR12*VAR1>0,0.99*REF(CLOSE,1),'险'),COLORYELLOW ;
PT:= REF(HIGH,1)-REF(LOW,1);
CDP1 := (HIGH + LOW +2* CLOSE)/4;
AH1:= (HIGH + LOW +CLOSE)/3 + PT;
AL1:= (HIGH + LOW +CLOSE)/3 - PT;
NH1:= 2*(HIGH + LOW +CLOSE)/3-LOW;
NL1:= 2*(HIGH + LOW +CLOSE)/3-HIGH;
CDP :=REF(CDP1,1),COLORBLUE;
AH:=REF(AH1,1),COLORGRAY;
AL:=REF(AL1,1),COLORGRAY;
NH:=REF(NH1,1),COLORYELLOW;
NL:=REF(NL1,1),COLORYELLOW;
DRAWICON(CROSS(C,AH),H,1);
DRAWICON(CROSS(AL,C),L,2);
DRAWICON(CROSS(C,NH),L,11);
DRAWICON(CROSS(NL,C),H,12);
STICKLINE(ZXNH.ZXNH,C,O,3,0)COLORFF00FF;
STICKLINE(ZXNH.ZXNH,L,H,0,0)COLORFF00FF;
DRAWTEXT(ZXNH.ZXNH,C*1.02,'钱');
CBFB:=MA(C,2);
JL:=IF(C>CBFB,V,0);
CL:=IF(C<CBFB,V,0);
JLH:=SUM(JL,4);
CLH:=SUM(CL,4);
LHB:=CLH/JLH;
TJ1:=IF(HHV(LHB,2)>3 AND CROSS(2,LHB) AND C>=O,1,0);
DRAWICON(TJ1,L*0.96,9);

通达信短线比较好用的主图指标公式

 

相关文章