在线检测未来函数

通达信寒山量线指标公式

来源:Internet,编辑:股旁网,2017-01-16

VOLUME:VOL,VOLSTICK;
|:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
STICKLINE(|,0,V,1,0),COLORGREEN;
DRAWTEXT(|,VOL+3000,'降'),COLORGREEN;
T:=DYNAINFO(8)>0;
VO:VOL=LLV(VOL,100) AND T;
地量柱:T AND VO,COLORBLUE;
STICKLINE(地量柱,0,V,1,0),COLORBLUE;
DRAWTEXT(地量柱,VOL+3000,'地'),COLORBLUE;
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(BLZ,0,V,1,0),COLORYELLOW;
倍量柱:BLZ,COLORYELLOW;
DRAWTEXT(倍量柱,VOL+3000,'倍'),COLORYELLOW;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,COLORRED,LINETHICK4;
STICKLINE(黄金柱,0,V,1,0),COLORRED;
DRAWTEXT(黄金柱,VOL+10000,'黄'),COLORRED;
价涨量缩:|,COLORGREEN;
FLZ:=V>REF(V,1)*0.98 AND V<REF(V,1)*1.02,LINETHICK0;
STICKLINE(FLZ,0,V,1,0),COLORMAGENTA;
DRAWTEXT(FLZ,VOL+3000,'平'),COLORMAGENTA;
平量柱:FLZ,COLORMAGENTA;
上斜线:DRAWLINE(V<= LLV(V,20),VOL,VOL>=HHV(V,20) ,HHV(V,20),0),,COLOR00FFFF,LINETHICK1;
下斜线:DRAWLINE(V>=HHV(V,20),V,V<=LLV(V,10),HHV(V,6),0),COLORFFCCCC,LINETHICK1;
DRAWLINE(V>=HHV(V,30),V,V<=LLV(V,30),HHV(V,30),1),COLORYELLOW;
历史最高成交量:HHV(V,BARSCOUNT(V)),NODRAW;
历史新高:=FILTERX(V=HHV(V,BARSCOUNT(V)),BARSCOUNT(V)),COLORYELLOW;
DRAWTEXT(历史新高,V,'←历史新高'),COLORYELLOW;
STICKLINE(历史新高,0,V,2,1);
DRAWLINE(历史新高>0,历史最高成交量,历史最高成交量,V,1),LINETHICK1,COLORRED;
乾坤卖点:DRAWLINE(VOL<=LLV(VOL,8) ,LLV(VOL,3),VOL>=HHV(VOL,35),VOL,0),
COLORFFCCCC,LINETHICK1;
乾坤买点:DRAWLINE(VOL>=HHV(VOL,35),VOL,VOL<=LLV(VOL,8) ,HHV(VOL,3),0),
COLORFFCCCC,LINETHICK1;
梯量柱:=V>REF(V,1)*1.05 AND REF(V,1)>REF(V,2)*1.05 AND C>O AND REF(C>O,1);
缩倍量:=VOL<=REF(V,1)*0.55;
STICKLINE(梯量柱,0,V,1,0),COLORRED;
STICKLINE(缩倍量,0,V*0.75,1,0),COLOR0099FF;
DRAWTEXT(梯量柱,V*1.0,'梯'),COLORYELLOW;
DRAWTEXT(缩倍量,V*1.0,'缩'),COLORRED;

通达信寒山量线指标公式

 

相关文章