在线检测未来函数

通达信综合531指标公式

来源:Internet,编辑:股旁网,2017-01-16

日线锁定:=(PERIOD==4);
CMN:=20;
TRENDA:=WINNER(C)*100;
CMQS1:=WMA(TRENDA,8);
CMQS2:=WMA(TRENDA,13);
CMQS3:=WMA(TRENDA,21);
CMQS4:=WMA(TRENDA,34);
CMQS5:=WMA(TRENDA,55);
CM01:=CMQS1>REF(CMQS1,1);
CM02:=CMQS2>REF(CMQS2,1);
CM03:=CMQS3>REF(CMQS3,1);
CM04:=CMQS4>REF(CMQS4,1);
CM05:=CMQS5>REF(CMQS5,1);
CM06:=TRENDA>CMQS1;
CM07:=TRENDA>CMQS2;
CM08:=TRENDA>CMQS3;
CM09:=TRENDA>CMQS4;
CM10:=TRENDA>CMQS5;
CM11:=CMQS1>CMQS2;
CM12:=CMQS1>CMQS3;
CM13:=CMQS1>CMQS4;
CM14:=CMQS1>CMQS5;
CM15:=CMQS2>CMQS3;
CM16:=CMQS2>CMQS4;
CM17:=CMQS2>CMQS5;
CM18:=CMQS3>CMQS4;
CM19:=CMQS3>CMQS5;
CM20:=CMQS4>CMQS5;
筹码:EMA(((CM01+CM02+CM03+CM04+CM05+CM06+CM07+CM08+CM09+CM10+
CM11+CM12+CM13+CM14+CM15+CM16+CM17+CM18+CM19+CM20)*(100/CMN)),2),NODRAW,COLORRED;
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,3,0),COLOR000088;{红柱}
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,2.5,0),COLOR000099;
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,2,0),COLOR0000AA;
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,1.5,0),COLOR0000BB;
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,1,0),COLOR0000DD;
STICKLINE(筹码>=REF(筹码,1),60,60+筹码*0.18,0.5,0),COLOR0000FF;
STICKLINE(筹码<REF(筹码,1),60,60+筹码*0.18,3,0),COLOR008800;{绿柱}
STICKLINE(筹码<REF(筹码,1),60,60+筹码*0.18,2.5,0),COLOR00AA00;
STICKLINE(筹码<REF(筹码,1),60,60+筹码*0.18,2,0),COLOR00BB00;
STICKLINE(筹码<REF(筹码,1),60,60+筹码*0.18,1.5,0),COLOR00DD00;
STICKLINE(筹码<REF(筹码,1),60,60+筹码*0.18,1,0),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1,IF(筹码>=0,65,65),STRCAT(' 筹= ',STRCAT(CON2STR(筹码,2),' '))),COLORRED;
{量能部分:}
方向成交量:=IFF(CLOSE>=OPEN,VOL,VOL*(-1));
LHLNMID:=(3*CLOSE+OPEN+HIGH+LOW)/6;
LHLN短线:=WMA(LHLNMID,5);
LHLN中线:=WMA(LHLNMID,10);
LHLN多头:=LHLN短线>LHLN中线;
P01:=SUM(方向成交量,1)>0;
P02:=SUM(方向成交量,2)>0;
P03:=SUM(方向成交量,3)>0;
P04:=SUM(方向成交量,4)>0;
P05:=SUM(方向成交量,5)>0;
SUM11:=SUM(方向成交量,11);
SUM12:=SUM(方向成交量,12);
SUM13:=SUM(方向成交量,13);
SUM14:=SUM(方向成交量,14);
SUM15:=SUM(方向成交量,15);
SUM16:=SUM(方向成交量,16);
SUM17:=SUM(方向成交量,17);
SUM18:=SUM(方向成交量,18);
SUM19:=SUM(方向成交量,19);
SUM20:=SUM(方向成交量,20);
P11:=SUM11>0 AND SUM11>REF(SUM11,1);
P12:=SUM12>0 AND SUM12>REF(SUM12,1);
P13:=SUM13>0 AND SUM13>REF(SUM13,1);
P14:=SUM14>0 AND SUM14>REF(SUM14,1);
P15:=SUM15>0 AND SUM15>REF(SUM15,1);
P16:=SUM16>0 AND SUM16>REF(SUM16,1);
P17:=SUM17>0 AND SUM17>REF(SUM17,1);
P18:=SUM18>0 AND SUM18>REF(SUM18,1);
P19:=SUM19>0 AND SUM19>REF(SUM19,1);
P20:=SUM20>0 AND SUM20>REF(SUM20,1);
MAZJ05:=MA(方向成交量,5);
MAZJ10:=MA(方向成交量,10);
MAZJ15:=MA(方向成交量,15);
MAZJ20:=MA(方向成交量,20);
MA01:=MAZJ05>MAZJ10;
MA02:=MAZJ05>MAZJ15;
MA03:=MAZJ05>MAZJ20;
MA04:=MAZJ10>MAZJ15;
MA05:=MAZJ10>MAZJ20;
MA06:=MAZJ15>MAZJ20;
基准线1:=EMA(EMA(EMA(EMA(IFF(方向成交量>=0,方向成交量,0),20),2),2),2);
基准线6:=基准线1*6;
ZJDL10:=IFF(方向成交量>基准线6,10,IFF(方向成交量<=基准线6 AND 方向成交量>0,10*方向成交量/基准线6,0));
短线总量:=SUM(方向成交量,3);
短线总量10:=EMA(短线总量,10);
短线总量60:=EMA(短线总量,60);
短线总量20:=EMA(短线总量,20);
短线总量30:=EMA(短线总量,30);
CZD01:=短线总量>短线总量10;
CZD02:=短线总量20>短线总量30;
CZD03:=短线总量10>短线总量60;
总权:=53;
量能X:=EMA(EMA(100*(P01*2+P02*2+P03*5+P04*2+P05*2+P11*1+P12*1+P13*1+P14*1+P15*1+P16*1+P17*1+P18*1+P19*1+P20*1+
MA01*2+MA02*2+MA03*1+MA04*1+MA05*1+MA06*1+ZJDL10+CZD01*5+CZD02*4+CZD03*3)/总权,2),2),NODRAW,COLORYELLOW;
量能XX:=IFF(LHLN多头,量能X*1.2,量能X);
量能:WMA(IFF(量能XX>=100,100,量能XX),3),NODRAW,COLORYELLOW;
STICKLINE(量能>=REF(量能,1),40,40+量能*0.18,3,0),COLOR000088;
STICKLINE(量能>=REF(量能,1),40,40+量能*0.18,2.5,0),COLOR000099;
STICKLINE(量能>=REF(量能,1),40,40+量能*0.18,1.5,0),COLOR0000BB;
STICKLINE(量能>=REF(量能,1),40,40+量能*0.18,1,0),COLOR0000DD;
STICKLINE(量能>=REF(量能,1),40,40+量能*0.18,0.5,0),COLOR0000FF;
STICKLINE(量能<REF(量能,1),40,40+量能*0.18,3,0),COLOR008800;
STICKLINE(量能<REF(量能,1),40,40+量能*0.18,2.5,0),COLOR00AA00;
STICKLINE(量能<REF(量能,1),40,40+量能*0.18,1.5,0),COLOR00BB00;
STICKLINE(量能<REF(量能,1),40,40+量能*0.18,1,0),COLOR00DD00;
STICKLINE(量能<REF(量能,1),40,40+量能*0.18,0.5,0),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1,IF(量能>=0,45,45),STRCAT(' 量= ',STRCAT(CON2STR(量能,2),' '))),COLORYELLOW;
{趋势部分:}
数量:=23;
DMADIF:=MA(C,10)-MA(C,50);
DMAAMA:=MA(DMADIF,10);
DMAX:=DMADIF>DMAAMA;
P301:=DMAX;
DMITR:=EXPMEMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),14);
DMIHD:=H-REF(H,1);
DMILD:=REF(L,1)-L;
DMIDMP:=EXPMEMA(IFF(DMIHD>0 AND DMIHD>DMILD,DMIHD,0),14);
DMIDMM:=EXPMEMA(IFF(DMILD>0 AND DMILD>DMIHD,DMILD,0),14);
DMIPDI:=DMIDMP*100/DMITR;
DMIMDI:=DMIDMM*100/DMITR;
DMIX:=DMIPDI>DMIMDI;
P302:=DMIX;
DPODPO:=C-REF(MA(C,20),20/2+1);
DPOMADPO:=MA(DPODPO,6);
DPOX:=DPODPO>DPOMADPO;
P303:=DPOX;
EMVVOLUME:=MA(V,14)/V;
EMVMID:=100*(H+L-REF(H+L,1))/(H+L);
EMVEMV:=MA(EMVMID*EMVVOLUME*(H-L)/MA(H-L,14),14);
EMVMAEMV:=MA(EMVEMV,9);
EMVX:=EMVEMV>EMVMAEMV;
P304:=EMVX;
MACDDIF:=EMA(C,12)-EMA(C,26);
MACDDEA:=EMA(MACDDIF,9);
MACDX:=MACDDIF>MACDDEA;
P305:=MACDX;
TRIXTR:=EMA(EMA(EMA(C,12),12),12);
TRIXTRIX:=(TRIXTR-REF(TRIXTR,1))/REF(TRIXTR,1)*100;
TRIXMATRIX:=MA(TRIXTRIX,9);
TRIXX:=TRIXTRIX>TRIXMATRIX;
P306:=TRIXX;
WVADWVAD:=SUM((C-O)/(H-L)*V,24)/10000;
WVADMAWVAD:=MA(WVADWVAD,6);
WVADX:=WVADWVAD>WVADMAWVAD;
P308:=WVADX;
JSJS:=100*(C-REF(C,5))/(5*REF(C,5));
JSMAJS1:=MA(JSJS,5);
JSX:=JSJS>JSMAJS1;
P309:=JSX;
CYEMAL:=MA(C,5);
CYEMAS:=MA(MA(C,20),5);
CYECYEL:=(CYEMAL-REF(CYEMAL,1))/REF(CYEMAL,1)*100;
CYECYES:=(CYEMAS-REF(CYEMAS,1))/REF(CYEMAS,1)*100;
CYEX:=CYECYEL>CYECYES;
P310:=CYEX;
JLHBVAR1:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*80;
JLHBB:=SMA(JLHBVAR1,7,1);
JLHBVAR2:=SMA(JLHBB,5,1);
JLHBX:=JLHBB>JLHBVAR2;
P311:=JLHBX;
CYCJJJ:=IFF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
CYCDDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
CYCJJJT:=IFF(CYCDDD,1,(CYCJJJ<(DYNAINFO(5)+0.01) && CYCJJJ>(DYNAINFO(6)-0.01)));
CYCCYC1:=IFF(CYCJJJT,0.01*EXPMA(AMOUNT,5)/EXPMA(VOL,5),EMA((HIGH+LOW+CLOSE)/3,5));
CYCCYC2:=IFF(CYCJJJT,0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13),EMA((HIGH+LOW+CLOSE)/3,13));
CYCX:=CYCCYC1>CYCCYC2;
P312:=CYCX;
BBIBBI:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
BBIX:=C>BBIBBI;
P313:=BBIX;
DDITR:=MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1)));
DDIDMZ:=IFF((H+L)<=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DDIDMF:=IFF((H+L)>=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DDIDIZ:=SUM(DDIDMZ,13)/(SUM(DDIDMZ,13)+SUM(DDIDMF,13));
DDIDIF:=SUM(DDIDMF,13)/(SUM(DDIDMF,13)+SUM(DDIDMZ,13));
DDIDDI:=DDIDIZ-DDIDIF;
DDIADDI:=SMA(DDIDDI,30,10);
DDIAD:=MA(DDIADDI,5);
DDIX:=DDIADDI>DDIAD;
P314:=DDIX;
FSLSWL:=(EXPMA(C,5)*7+EXPMA(C,10)*3)/10;
FSLSWS:=DMA(EMA(C,12),MAX(1,100*(SUM(V,5)/(3*CAPITAL))));
FSLX:=FSLSWL>FSLSWS;
P315:=FSLX;
MAMA1:=MA(C,5);
MAMA2:=MA(C,10);
MAXX:=MAMA1>MAMA2;
P316:=MAXX;
EXPEMA1:=EXPMA(C,12);
EXPEMA2:=EXPMA(C,17);
EXPMAX:=EXPEMA1>EXPEMA2 AND EXPEMA1>REF(EXPEMA1,1) AND EXPEMA2>REF(EXPEMA2,1);
P317:=EXPMAX;
PBX1:=(EXPMA(C,4)+MA(C,4*2)+MA(C,4*4))/3;
PBX2:=(EXPMA(C,6)+MA(C,6*2)+MA(C,6*4))/3;
PBXX:=PBX1>PBX2 AND PBX1>REF(PBX1,1) AND PBX2>REF(PBX2,1);
P318:=PBXX;
SARX:=C>SAR(4,2,20);
P319:=SARX;
QLTB:=IFF(H>REF(C,1),H-REF(C,1)+C-L,C-L);
QLTS:=IFF(REF(C,1)>LOW,REF(C,1)-L+H-C,H-C);
QLVOL_:=(QLTB-QLTS)*V/(QLTB+QLTS)/100;
QLVOL_0:=DMA(QLVOL_,0.1);
QLVOL_1:=DMA(QLVOL_,0.05);
QLRES1:=QLVOL_0-QLVOL_1;
QLLON:=SUM(QLRES1,0);
QLLONG:=QLLON;
QLMA1:=MA(QLLON,10);
LONQLX:=QLLONG>REF(QLLONG,1) AND QLMA1>REF(QLMA1,1) AND QLLONG>QLMA1,NODRAW,COLORFFFFFF;
P320:=LONQLX;
QLSTB:=IFF(H>REF(C,1),H-REF(C,1)+C-L,C-L);
QLSTS:=IFF(REF(C,1)>L,REF(C,1)-L+H-C,H-C);
QLSVOL_:=(QLSTB-QLSTS)*V/(QLSTB+QLSTS)/100;
QLSVOL_0:=DMA(QLSVOL_,0.1);
QLSVOL_1:=DMA(QLSVOL_,0.05);
QLSSHORT:=QLSVOL_0-QLSVOL_1;
QLSMA1:=MA(QLSSHORT,10);
SHORTQLX:=QLSSHORT>QLSMA1;
P321:=SHORTQLX;
AMVAMV0:=V*(O+C)/2;
AMVAMV1:=SUM(AMVAMV0,5)/SUM(V,5);
AMVAMV2:=SUM(AMVAMV0,13)/SUM(V,13);
AMVX:=AMVAMV1>AMVAMV2;
P322:=AMVX;
MTMMTM:=C-REF(C,12);
MTMMAMTM:=MA(MTMMTM,6);
MTMX:=MTMMTM>MTMMAMTM;
P323:=MTMX;
ZJTJVAR1:=EMA(EMA(C,9),9);
ZJTJ控盘:=(ZJTJVAR1-REF(ZJTJVAR1,1))/REF(ZJTJVAR1,1)*1000;
YZKPX:=ZJTJ控盘>REF(ZJTJ控盘,1) AND ZJTJ控盘>0;
P324:=YZKPX;
趋势:(P301+P302+P303+P304+P305+P306+P308+P309+P310+P311+P312+P313+P314+P315+P316+P317+P318+P319+P320+P321+P322+P323+P324)*(100/数量),NODRAW,COLORGREEN;
STICKLINE(趋势>=REF(趋势,1),20,20+趋势*0.18,3,0),COLOR000088;
STICKLINE(趋势>=REF(趋势,1),20,20+趋势*0.18,2.5,0),COLOR000099;
STICKLINE(趋势>=REF(趋势,1),20,20+趋势*0.18,1.5,0),COLOR0000BB;
STICKLINE(趋势>=REF(趋势,1),20,20+趋势*0.18,1,0),COLOR0000DD;
STICKLINE(趋势>=REF(趋势,1),20,20+趋势*0.18,0.5,0),COLOR0000FF;
STICKLINE(趋势<REF(趋势,1),20,20+趋势*0.18,3,0),COLOR008800;
STICKLINE(趋势<REF(趋势,1),20,20+趋势*0.18,2.5,0),COLOR00AA00;
STICKLINE(趋势<REF(趋势,1),20,20+趋势*0.18,1.5,0),COLOR00BB00;
STICKLINE(趋势<REF(趋势,1),20,20+趋势*0.18,1,0),COLOR00DD00;
STICKLINE(趋势<REF(趋势,1),20,20+趋势*0.18,0.5,0),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1,IF(趋势>=0,25,25),STRCAT(' 势= ',STRCAT(CON2STR(趋势,2),' '))),COLORGREEN;
{指标部分:}
ZBSLPG:=22;
LTSHPG:=100-100*(HHV(H,40)-C)/(HHV(H,40)-LLV(L,40));
ZB01:=LTSHPG>=50;
DIFPG:=EMA(C,12)-EMA(C,26);
DEAPG:=EMA(DIFPG,9);
ZB02:=DIFPG>DEAPG;
APG:=MA((-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),19);
BPG:=(-100)*(HHV(H,14)-C)/(HHV(H,14)-LLV(L,14));
DPG:=EMA((-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),4);
QSDDLONG:=APG+100;
QSDDSHORT:=BPG+100;
QSDDMID:=DPG+100;
ZB03:=QSDDSHORT>QSDDMID;
ZB04:=QSDDSHORT>QSDDLONG;
ZB05:=QSDDMID>QSDDLONG;
RSVPG:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
KPG:=SMA(RSVPG,3,1);
DPG2:=SMA(KPG,3,1);
ZB06:=KPG>DPG2;
LCPG:=REF(CLOSE,1);
RPG1:=SMA(MAX(C-LCPG,0),6,1)/SMA(ABS(C-LCPG),6,1)*100;
RPG2:=SMA(MAX(C-LCPG,0),12,1)/SMA(ABS(C-LCPG),12,1)*100;
RPG3:=SMA(MAX(C-LCPG,0),24,1)/SMA(ABS(C-LCPG),24,1)*100;
ZB07:=RPG1>RPG2;
ZB08:=RPG1>RPG3;
ZB09:=RPG2>RPG3;
ZB10:=MA(C,5)>MA(C,10);
ZB11:=MA(C,5)>MA(C,20);
ZB12:=MA(C,10)>MA(C,20);
MAVPG:=(C*2+H+L)/4;
SKPG:=EMA(MAVPG,13)-EMA(MAVPG,34);
SDPG:=EMA(SKPG,5);
ZB13:=(2*(SKPG-SDPG))>((-2)*(SKPG-SDPG));
MIDPGX:=(3*C+O+L+H)/6;
DKXPG1:=WMA(MIDPGX,5);
DKXPG2:=WMA(MIDPGX,10);
DKXPG3:=WMA(MIDPGX,20);
ZB14:=DKXPG1>REF(DKXPG1,1);
ZB15:=DKXPG2>REF(DKXPG2,1);
ZB16:=DKXPG3>REF(DKXPG3,1);
G08PG:=EMA(C,34);
ZB17:=G08PG>REF(G08PG,1);
B08PG:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*80;
BPG1:=SMA(B08PG,7,1);
BPG2:=SMA(BPG1,3,1);
ZB18:=BPG1>BPG2;
BBIPG:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
ZB19:=C>BBIPG;
MIDSLB:=(3*C+L+O+H)/6;
E1:=EMA(10000*(WMA(MIDSLB,30)-REF(WMA(MIDSLB,30),1))/REF(WMA(MIDSLB,30),1),10);
E2:=EMA(E1,2);
E3:=EMA(E2,2);
E4:=EMA(E3,2);
E5:=EMA(E4,2);
E6:=EMA(E5,2);
E7:=EMA(E6,2);
ZB20:=E2>E3 AND E3>E4 AND E4>E5 AND E5>E6 AND E6>E7;
ZB21:=E2>REF(E2,1) AND E3>REF(E3,1) AND E4>REF(E4,1) AND E5>REF(E5,1) AND E6>REF(E6,1) AND E7>REF(E7,1);
TRPG1:=MAX(MAX((H-L),ABS(H-REF(C,1))),ABS(REF(C,1)-L));
ATRPG1:=EMA(TRPG1,14);
HDPG:=H-REF(H,1);
LDPG:=REF(L,1)-L;
PDMPG:=EMA(IFF(HDPG>0 AND HDPG>LDPG,HDPG,0),14);
MDMPG:=EMA(IFF(LDPG>0 AND LDPG>HDPG,LDPG,0),14);
PDIPG:=PDMPG/ATRPG1;
MDIPG:=MDMPG/ATRPG1;
XLPG:=(PDIPG-MDIPG)/(PDIPG+MDIPG);
ZB22:=XLPG>0;
指标:(ZB01+ZB02+ZB03+ZB04+ZB05+ZB06+ZB07+ZB08+ZB09+ZB10+
ZB11+ZB12+ZB13+ZB14+ZB15+ZB16+ZB17+ZB18+ZB19+ZB20+ZB21+ZB22)*(100/ZBSLPG)NODRAW,COLORAAAAAA;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,3,0),COLOR000088;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,2.5,0),COLOR000099;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,2,0),COLOR0000AA;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,1.5,0),COLOR0000BB;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,1,0),COLOR0000DD;
STICKLINE(指标>=REF(指标,1),0,指标*0.18,0.5,0),COLOR0000FF;
STICKLINE(指标<REF(指标,1),0,指标*0.18,3,0),COLOR008800;
STICKLINE(指标<REF(指标,1),0,指标*0.18,2.5,0),COLOR00AA00;
STICKLINE(指标<REF(指标,1),0,指标*0.18,2,0),COLOR00BB00;
STICKLINE(指标<REF(指标,1),0,指标*0.18,1.5,0),COLOR00DD00;
STICKLINE(指标<REF(指标,1),0,指标*0.18,1,0),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1,IF(指标>=0,5,5),STRCAT(' 指= ',STRCAT(CON2STR(指标,2),' '))),COLORAAAAAA;
{资金部分:}
日期锁定:=DATE>=1100104;
JE:=VOL;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
主力流入:=(QJ0*(JJ-MIN(CLOSE,OPEN)));
主力流出:=(QJ0*(MIN(OPEN,CLOSE)-LOW));
主力净买:=(主力流入-主力流出)/10000;
P201:=SUM(主力净买,1)>0;
P202:=SUM(主力净买,2)>0;
P203:=SUM(主力净买,3)>0;
P204:=SUM(主力净买,4)>0;
P205:=SUM(主力净买,5)>0;
SUM211:=SUM(主力净买,11);
SUM212:=SUM(主力净买,12);
SUM213:=SUM(主力净买,13);
SUM214:=SUM(主力净买,14);
SUM215:=SUM(主力净买,15);
SUM216:=SUM(主力净买,16);
SUM217:=SUM(主力净买,17);
SUM218:=SUM(主力净买,18);
SUM219:=SUM(主力净买,19);
SUM220:=SUM(主力净买,20);
P211:=SUM211>0 AND SUM211>REF(SUM211,1);
P212:=SUM212>0 AND SUM212>REF(SUM212,1);
P213:=SUM213>0 AND SUM213>REF(SUM213,1);
P214:=SUM214>0 AND SUM214>REF(SUM214,1);
P215:=SUM215>0 AND SUM215>REF(SUM215,1);
P216:=SUM216>0 AND SUM216>REF(SUM216,1);
P217:=SUM217>0 AND SUM217>REF(SUM217,1);
P218:=SUM218>0 AND SUM218>REF(SUM218,1);
P219:=SUM219>0 AND SUM219>REF(SUM219,1);
P220:=SUM220>0 AND SUM220>REF(SUM220,1);
MAZJ205:=MA(主力净买,5);
MAZJ210:=MA(主力净买,10);
MAZJ215:=MA(主力净买,15);
MAZJ220:=MA(主力净买,20);
MA201:=MAZJ205>MAZJ210;
MA202:=MAZJ205>MAZJ215;
MA203:=MAZJ205>MAZJ220;
MA204:=MAZJ210>MAZJ215;
MA205:=MAZJ210>MAZJ220;
MA206:=MAZJ215>MAZJ220;
基准线21:=EMA(EMA(EMA(EMA(IFF(主力净买>=0,主力净买,0),20),2),2),2);
基准线26:=基准线1*6;
ZJDL210:=IFF(主力净买>基准线26,10,IFF(主力净买<=基准线26 AND 主力净买>0,10*主力净买/基准线26,0));
短线资金:=SUM(主力净买,3);
短线资金10:=EMA(短线资金,10);
短线资金60:=EMA(短线资金,60);
短线资金20:=EMA(短线资金,20);
短线资金30:=EMA(短线资金,30);
CZD201:=短线资金>短线资金10;
CZD202:=短线资金20>短线资金30;
CZD203:=短线资金10>短线资金60;
总权2:=53;
资金:EMA(EMA(100*(P201*2+P202*2+P203*5+P204*2+P205*2+P211*1+P212*1+P213*1+P214*1+P215*1+P216*1+P217*1+P218*1+P219*1+P220*1+
MA01*2+MA02*2+MA03*1+MA04*1+MA05*1+MA06*1+ZJDL10+CZD01*5+CZD02*4+CZD03*3)/总权2,2),2),NODRAW,COLORFF008F;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,3,0),COLOR000088;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,2.5,0),COLOR000099;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,2,0),COLOR0000AA;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,1.5,0),COLOR0000BB;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,1,0),COLOR0000DD;
STICKLINE(资金>=REF(资金,1),-20,-20+资金*0.18,0.5,0),COLOR0000FF;
STICKLINE(资金<REF(资金,1),-20,-20+资金*0.18,3,0),COLOR008800;
STICKLINE(资金<REF(资金,1),-20,-20+资金*0.18,2.5,0),COLOR00AA00;
STICKLINE(资金<REF(资金,1),-20,-20+资金*0.18,2,0),COLOR00BB00;
STICKLINE(资金<REF(资金,1),-20,-20+资金*0.18,1.5,0),COLOR00DD00;
STICKLINE(资金<REF(资金,1),-20,-20+资金*0.18,1,0),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1,IF(资金>=0,-15,-15),STRCAT(' 金= ',STRCAT(CON2STR(资金,2),' '))),COLORFF008F;
{画五指标分隔线:}
NOTEXT480:60,COLORRED,LINETHICK1;
NOTEXT380:40,COLORYELLOW,LINETHICK1;
NOTEXT280:20,COLORGREEN,LINETHICK1;
NOTEXT180:0,COLORAAAAAA,LINETHICK1;
NOTEXT80:-20,COLORFF008F,LINETHICK1;
{标题栏显示KDJ参数:}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),NODRAW,COLORYELLOW,LINETHICK2;
D:SMA(K,3,1),NODRAW,COLORFF66CC,LINETHICK2;
J:3*K-2*D,NODRAW,COLORFFDDAA,LINETHICK2;
{第一条块线:}
吸:=XLPL.NOTEXT吸;
拉:=XLPL.NOTEXT拉;
派:=XLPL.NOTEXT派;
落:=XLPL.NOTEXT落;
STICKLINE(吸,106,114,3,0),COLORFF00AF;
STICKLINE(拉,106,114,3,0),COLORRED;
STICKLINE(派,106,114,3,0),COLORGREEN;
STICKLINE(落,106,114,3,0),COLORWHITE;
DRAWTEXT(ISLASTBAR=1,IF(XLPL>=0,109,109),STRCAT(' XLPL=',STRCAT(CON2STR(XLPL,2),' '))),COLORYELLOW;
{第二条块线:}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),NODRAW,COLORWHITE;
STICKLINE(CCI>100,94,102,3,0),COLORRED;
STICKLINE(CCI<100,94,102,3,0),COLORGREEN;
STICKLINE(CCI<-100,94,102,3,0),COLORWHITE;
DRAWTEXT(ISLASTBAR=1,IF(CCI>=0,97,97),STRCAT(' CCI=',STRCAT(CON2STR(CCI,2),' '))),COLORWHITE;
{第三条块线:}
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,NODRAW,COLORYELLOW;
STICKLINE(C>BBI,82,90,3,0),COLORRED;
STICKLINE(C<BBI,82,90,3,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(BBI>=0,85,85),STRCAT(' BBI=',STRCAT(CON2STR(BBI,2),' '))),COLORYELLOW;
{KDJ图像显示最上层:}
RSVA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KA:SMA(RSVA,3,1),COLORYELLOW,LINETHICK2;
DA:SMA(KA,3,1),COLORFF66CC,LINETHICK2;
JA:3*KA-2*DA,COLORFFDDAA,LINETHICK2;

通达信综合531指标公式

 

相关文章