在线检测未来函数

通达信牛股三绝主图指标公式

来源:Internet,编辑:股旁网,2017-01-16

DRAWGBK(O>0,RGB(41,36,33),RGB(0,0,0),0,'02',0);
DRAWKLINE(H,O,L,C);
倍量不穿:V>=REF(V,1)*1.9 AND C>=O,COLORYELLOW NODRAW;
DRAWTEXT(倍量不穿,LOW*0.99,'↖倍')COLORYELLOW;
K1:=SUMBARS(倍量不穿,1);
STICKLINE(K1,REF(O,K1-1),REF(O,K1-1),5,0) COLORYELLOW;
STICKLINE(倍量不穿,O,C,0.5,0),COLORYELLOW;
VAR2:=1*AMOUNT;
月天量:=VAR2=HHV(VAR2,20);
季天量:=VAR2=HHV(VAR2,60);
百天量:=VAR2=HHV(VAR2,100);
年天量:=VAR2=HHV(VAR2,240);
高量不破:(季天量 OR 百天量 OR 年天量)COLORRED NODRAW;
DRAWTEXT(高量不破,LOW*1.05,'↙高')COLORRED;
STICKLINE(高量不破,O,C,1.2,0),COLORRED;
K11:=SUMBARS(高量不破,1);
STICKLINE(K11,REF(O,K11-1),REF(O,K11-1),5,0) COLORRED;
缺口不补:L>REF(H,1)COLORWHITE,NODRAW;
DRAWTEXT(缺口不补,LOW*0.98,'↖缺')COLORWHITE;
STICKLINE(缺口不补,O,C,0.5,0),COLORWHITE;
K111:=SUMBARS(缺口不补,1);
STICKLINE(K111,REF(O,K111-1),REF(O,K111-1),4,1) COLORWHITE;
STICKLINE(C>O,(C+O)/2,(C+O)/2,2,1),COLORYELLOW;
STICKLINE(C>O,(C+O)/2,(C+O)/2,2,1),COLORLIGRAY;
昨二一位:(REF(O,1)+REF(C,1))/2,COLORYELLOW,NODRAW;
今二一位: (O+C)/2,COLORYELLOW,NODRAW;
上三分之一位:(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),NODRAW;
下三分之一位:(MAX(O,C)-MIN(O,C))/3+MIN(O,C),NODRAW;
指数:=C>500;
CC:=IF(指数,H,MAX(C,O));OO:=IF(指数,L,MIN(C,O));
顶底:=IF(C>O,OO,CC);{阳线显底,阴线显顶}
大K线:=CC/OO>=(1+IF(指数,2,4.92)/100);{指数2%}
关键价柱:=大K线 OR 倍量不穿 OR 高量不破;
T:=BARSLAST(关键价柱);
开盘: REF(顶底,T),NODRAW,COLORYELLOW;{黄色}{阳线显底,阴线显顶};

通达信牛股三绝主图指标公式

 

相关文章