在线检测未来函数

通达信彩蛋KDJ指标公式

来源:Internet,编辑:股旁网,2017-01-16

HJ_1:=IF(DATE<1451130,1,0);
DIF:IF(HJ_1=1,MACD.DIF,0),LINETHICK2;
DEA:IF(HJ_1=1,MACD.DEA,0);
DRAWTEXT_FIX(HJ_1=0,0,0.01,0,27),COLORMAGENTA;
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,DIF*1.1,2),COLORGREEN;
DRAWICON(CROSS(DEA,DIF) AND DIF>0,DIF,37),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;
DRAWICON(CROSS(DIF,DEA) AND DIF<0,DIF,36),COLORRED;
HJ_2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
HJ_3:=LLVBARS(MACD,HJ_2+20);
HJ_4:=IF(HJ_3>HJ_2,REF(MACD,HJ_3),0);
HJ_5:=MACD<0 AND MACD>HJ_4 AND LOW=LLV(LOW,HJ_2+20) AND HJ_4<0;
HJ_6:=REF(HJ_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_3)<0 AND MACD<0;
低背:DRAWLINE(HJ_4=HJ_3,MACD,HJ_6,MACD,0),COLORRED,LINETHICK2;
DRAWICON(HJ_6,MACD*1.2,26);
HJ_7:=HHVBARS(MACD,HJ_2+20);
HJ_8:=IF(HJ_7>HJ_2,REF(MACD,HJ_7),0);
HJ_9:=MACD>0 AND MACD<HJ_8 AND HIGH=HHV(HIGH,HJ_2+20) AND HJ_8>0;
HJ_10:=REF(HJ_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_7)>0;
顶背:DRAWLINE(HJ_8=HJ_7,MACD,HJ_10,MACD,0),COLORGREEN,LINETHICK2;
DRAWICON(HJ_10,MACD*1.2,15);
HJ_11:=CLOSE/MA(CLOSE,40)*100<78;
HJ_12:=CLOSE/MA(CLOSE,60)*100<74;
HJ_13:=HIGH>LOW*1.051;
HJ_14:=HJ_13 AND COUNT(HJ_13,5)>1;
HJ_15:=IF(HJ_14 AND (HJ_11 OR HJ_12),2,0);
HJ_16:=CLOSE/REF(CLOSE,25)<=1.1;
HJ_17:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
HJ_18:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
HJ_19:=SMA(HJ_18,2,1);
HJ_20:=SMA(HJ_19,2,1);
HJ_21:=IF(HJ_19>REF(HJ_19,1) AND REF(HJ_19,1)<REF(HJ_19,2) AND HJ_19<23,1.5,0);
抄底:HJ_16 AND HJ_15 AND HJ_17 AND HJ_21 AND HJ_1=1,COLORWHITE;
HJ_22:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
HJ_23:=MA(CLOSE,5);
HJ_24:=IF(CLOSE>SAR(10,2,20),1,0);
HJ_25:=IF(CLOSE<SAR(10,2,20),(-1),0);
HJ_26:=ATAN((HJ_23/REF(HJ_23,1)-1)*100)*180/3.1416;
HJ_27:=IF(HJ_26>30,1,0);
HJ_28:=IF(HJ_26<(-30),(-1),0);
HJ_29:=HJ_24+HJ_27+HJ_25+HJ_28;
IF(HJ_29<(-1) OR HJ_22<25.01,DIF,DRAWNULL),COLORGREEN,LINETHICK2;
IF(HJ_22>74.989998 OR HJ_29>0,DIF,DRAWNULL),COLORRED,LINETHICK2;
DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORF00FF0;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCYAN;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFF:DIF1,COLOR33FF33;
DEA3:DEA1,COLORYELLOW;
MACD3:MACD1,NODRAW,COLORMAGENTA;
强:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;
低位金叉:= CROSS(DIFF,DEA) AND DIFF<(-0.1);
STICKLINE(低位金叉,0,-0.3,1,0),COLOR00FFFF;
DRAWTEXT(低位金叉,-0.3,' 低位金叉'),COLOR00FFFF;
JCCOUNT:= COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:= CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.15,1,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.04,1),COLOR0000FF;
DRAWTEXT(二次金叉,-0.15,' 二次金叉'),COLORFF00FF;
A1:= BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:= REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.15,1,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),LINETHICK3,COLORWHITE;
DRAWTEXT(底背离,0.15,' 底背离'),COLOR00FF00;
A2:= BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:= REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),LINETHICK3,COLORBLUE;
AA:=C>REF(C,4);
NT:=BARSLASTCOUNT(AA);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
B1:=C;
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
DRAWICON(CROSS(DEA1,DIF1),DEA1,2);
N:=9; P1:=3; P2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*2;
K:SMA(RSV,P1,1);
D:SMA(K,P2,1);
J:3*K-2*D;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK3;
DRAWICON(CROSS(J,1),J,1);
DRAWICON(K>80 AND D>80 AND CROSS(D,K),D,2);
IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(J>1.8,J,DRAWNULL),COLORWHITE,LINETHICK3;
IF(K>1.8,K,DRAWNULL),COLOR0000FF,LINETHICK2;
IF(D>1.9,D,DRAWNULL),COLORFFFF11,LINETHICK2;
VAR1:=(2*CLOSE+HIGH+LOW)/3;
VAR2:=EMA(EMA(EMA(VAR1,3),3),3);
J1: (VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
D1: MA(J1,2);
K1: MA(J1,1),COLORRED;
DRAWTEXT(FILTER(CROSS(D1,K1)AND J1>0.2,5),D1+0.05,'S'),COLORRED;
DRAWTEXT(CROSS(K1,D1)AND J1<=-0.2,K1-0.05,'B'),COLORRED;

通达信彩蛋KDJ指标公式

 

相关文章