在线检测未来函数

同花顺趋势轨迹指标公式

来源:Internet,编辑:股旁网,2017-01-19

SHORT:=12;
LONG:=26;
M:=9;
DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA_:= EMA(DIFF,M);
MACD_ := 2*(DIFF-DEA_),COLORSTICK;
MACD:MACD_,colorwhite;
DIF:DIFF,colorwhite;
DEA:DEA_,coloryellow;
A1:=BARSLAST(REF(CROSS(DIFF,DEA_),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA_);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA_,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA_,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:IF(B1>0,-0.1,0),colorred,POINTDOT;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),coloryellow,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),colorwhite,POINTDOT;
STICKLINE(MACD_>REF(MACD_,1) AND MACD_>0,0,MACD_,0,0),colorred;
STICKLINE(MACD_<=REF(MACD_,1) AND MACD_>0,0,MACD_,0,0),coloryellow;
STICKLINE(MACD_<REF(MACD_,1) AND MACD_<0,0,MACD_,0,0),colorcyan;
STICKLINE(MACD_>=REF(MACD_,1) AND MACD_<0,0,MACD_,0,0),colormagenta;
STICKLINE(C>0,0,0,50,1),colorblue;
PARTLINE(DIFF,DIFF>MA(DIFF,2),colorred,DIFF<MA(DIFF,2),colorwhite);
PARTLINE(DEA_,DEA_>MA(DEA_,2),colormagenta,DEA_<MA(DEA_,2),coloryellow);
A:=REF(DIFF,1)<REF(DIFF,2) AND REF(DIFF,2)<REF(DIFF,3) AND DIFF>REF(DIFF,1);
B:=REF(DIFF,1)>REF(DIFF,2) AND REF(DIFF,2)>REF(DIFF,3) AND DIFF<REF(DIFF,1);
买:IF(CROSS(DIFF,DEA_),DIFF,NULL),CIRCLEDOT,colorred;
卖:IF(CROSS(DEA_,DIFF),DIFF,NULL),CIRCLEDOT,colorgreen;

同花顺趋势轨迹指标公式

 

相关文章