在线检测未来函数

通达信小黑马波段指标公式

来源:Internet,编辑:股旁网,2017-01-19

N:=10;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
生命线:EMA(VARD,N), COLORFF00FF,LINETHICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:=EMA(B1,5);
STICKLINE(B1-B2>0,B1,B2,4,0),COLORFFFFFF;
STICKLINE(B1-B2<0,B1,B2,4,0),COLORFFFF52;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
黑马:IF(ZDHM OR ZHM,50,0),COLORYELLOW,POINTDOT;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
小黑马:IF(CROSS(D1,K1),45,0),COLORFFCC66,POINTDOT;
STICKLINE(大黑马>0,0,大黑马*1.1,1,0),COLORWHITE;
STICKLINE(大黑马>0 AND 大黑马<52,30,大黑马,1,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.8,4,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.4,8,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.2,10,0),COLORYELLOW;
STICKLINE(大黑马>0,0,大黑马*0.1,10,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*1.1,1,0),COLORWHITE;
STICKLINE(小黑马>0 AND 小黑马<52,30,小黑马,1,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.8,4,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.4,8,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.2,10,0),COLORFF00FF;

通达信小黑马波段指标公式

 

相关文章