在线检测未来函数

通达信雪豹突击主图指标公式

来源:Internet,编辑:股旁网,2017-01-18

N:=1,100,20;
M:=1,100,32;
P1:=1,100,80;
P2:=1,100,100;
VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;
买线:=EMA(C,4);
卖线:=EMA(SLOPE(C,20)*10+C,35);
DRAWTEXT(CROSS(买线,卖线),LOW*0.98,'买'),COLORRED;
DRAWTEXT(CROSS(卖线,买线),HIGH*1.02,'卖')COLORGREEN;
DRAWTEXT(HIGH>REF(HIGH,1) AND REF(HIGH,2)>REF(HIGH,1) AND LOW>REF(LOW,1)AND REF(LOW,2)>REF(LOW,1) AND MA(CLOSE,5)<MA(CLOSE,10) , LOW, '▲') ,COLORYELLOW;
DRAWTEXT(HIGH<REF(HIGH,1) AND LOW<REF(LOW,1) AND REF(HIGH,2)<REF(HIGH,1) AND REF(LOW,2)<REF(LOW,1) AND MA(CLOSE,5)>MA(CLOSE,10), HIGH,'拐点' ) ,COLORWHITE;
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.04,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.04,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.12,0,'出千概念:')COLORFF88FF;
DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0.00,0.16,0,'愚民主题概念:'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.09,0.16,0,EXTERNSTR(0,4)),COLOR00FFFF;

通达信雪豹突击主图指标公式

 

相关文章