在线检测未来函数

通达信大牛抄底指标公式

来源:Internet,编辑:股旁网,2017-01-18

DRAWGBK(CLOSE>1,RGB(0,0,0),RGB(0,0,80),0,0,0);
Y1: -2;
B: 99;
T: 79;
X1:25;
VAR1:=REF(CLOSE,1);
标尺: SMA(MAX(CLOSE-VAR1,0),5,1)/SMA(ABS(CLOSE-VAR1),5,1)*100,COLORYELLOW;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VAR3:=SMA(VAR2,5,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1);
浪:3*VAR4-2*VAR5, COLORCYAN;
波:VAR4, COLORGREEN;
段:VAR5, COLORRED;
VAR6:=CROSS(VAR3,VAR4) AND VAR4<25;
STICKLINE(VAR6,0,VAR4+5,1,1), COLORGREEN;
VAR7:=CROSS(VAR4,VAR5) AND VAR4<25;
VAR8:=VAR7 AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
STICKLINE(VAR7,0,VAR4+35,1.3,1),COLORFFFF00;
DRAWTEXT(VAR7 AND COUNT(VAR7,10)=1,VAR4+35,'抄底'), COLORRED;
STICKLINE(VAR8,0,VAR4+5,1,1),COLORGREEN;
DRAWTEXT(VAR8 AND COUNT(VAR8,10)=1,VAR4+5,'放量');
VAR9:=CROSS(VAR3,VAR4) AND VAR4>80 AND VAR4>VAR5;
STICKLINE(VAR9 AND COUNT(VAR9,5)=1,VAR4-5,100,1,1),COLORYELLOW;
VARA:=CROSS(VAR5,VAR4) AND VAR4>80;
STICKLINE(VARA,VAR4-5,100,1,1), COLORRED;
DRAWTEXT(VARA AND COUNT(VARA,10)=1,VAR4-15,'逃顶'), COLORRED;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
DIFF := EMA(CLOSE,10) - EMA(CLOSE,22);
DEA := EMA(DIFF,5);
MACD :=2*(DIFF-DEA);
MID :=MA(CLOSE,26);
UPPER:=MID + 2*STD(CLOSE,26);
LOWER:=MID-2*STD(CLOSE,26);
XP:=COUNT(C<LOWER*1.005,10)>0;
PC:=(2*C+H+L+AMOUNT/VOL/100)/5;
JC9:=(FORCAST(PC,5)+WMA(PC,5)+EMA(PC,3)+MA(PC,3))/4;
LPC:= REF(JC9,1);
R收:=EMA(SMA(MAX(JC9-LPC,0),6,1)/SMA(ABS(JC9-LPC),6,1)*100,3);
TT:=BARSCOUNT(C);CC:=CLOSE;
ZZ:=SUM(AMOUNT,TT)/SUM(VOL*100,TT);
ZZ1:=BETWEEN(C/ZZ,1.05,0.95);
分时均线:=IF(ZZ1=0,MA(C,TT),ZZ);
乖离:=(C-分时均线)/分时均线*100;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
捡金币:=FILTER(CROSS(RSI,20),7);
牛:=CROSS(J,REF(J+0.01,1)) AND X AND XP AND J<20 AND R收<25 AND 乖离<-16;
STICKLINE(牛,0,75,1,1),COLORFF66AA;
DRAWTEXT(牛 AND COUNT(牛,10)=1,75,'牛抄底'), COLORRED;
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
M3:=MA(CLOSE,20);
M4:=MA(CLOSE,60);
XA1:=M1>M4 AND M2>M4 AND M3>M4;
XA2:=REF(C,1)/REF(M1,1)<1;
XA:=C/REF(C,1)>1.09 AND XA1 AND XA2 AND C>M1;
STICKLINE(XA,0,100,0.5,1),COLOR0066BB;
DRAWTEXT(XA AND COUNT(XA,10)=1,90,'聚宝盆'), COLOR0066BB;

通达信大牛抄底指标公式

 

相关文章