在线检测未来函数

通达信CCI和DPO融合指标公式

来源:Internet,编辑:股旁网,2017-01-25

DPO:=CLOSE-REF(MA(CLOSE,20),20/2+1);
RIFF:= EMA(DPO,12) - EMA(DPO,26);
REA:= EMA(RIFF,9);
X:=CROSS(RIFF,REA);
Y:=CROSS(REA,RIFF);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13));
STICKLINE(CCI<0,0,CCI,1,0),COLORWHITE;
STICKLINE(CCI>=0,0,CCI,1,0),COLORYELLOW;
STICKLINE(CCI>REF(CCI,1) AND CCI<0 AND CCI>-100,0,CCI,1,0),COLORGREEN;
STICKLINE(CCI>REF(CCI,1) AND CCI>100,0,CCI,1,0),COLORRED;
趋势线:EXPMA(CCI,5),COLORMAGENTA,LINETHICK2;
IF(趋势线>=REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(X,趋势线,13);
DRAWICON(Y,趋势线,14);

通达信CCI和DPO融合指标公式

 

相关文章