在线检测未来函数

涨停板后横盘整理的选股公式

来源:Internet,编辑:股旁网,2017-01-12

编写要求:

条件如下: 1 涨停板; 2 随后连续三天无涨停和跌停的横盘整理; 3 如果可能的话,这随后的三天能否改为可以调节的 (N) 参数,即涨停板后可选或一天 或两天,或三天整理; 4 随后三天的最低收盘价高于涨停板前一天的收盘价。

股旁网解答:

N:=3;{N自定义}
涨停:=C>REF(C,1)*1.095 AND C=H;
跌停:=C<REF(C,1)*0.905 AND C=L;
涨停天数:=BARSLAST(涨停);
收盘价:=LLV(C,涨停天数)>REF(C,涨停天数+1);
N天内出现:COUNT(NOT(跌停),N)=N AND (涨停天数=N) AND 收盘价;

相关文章