在线检测未来函数

通达信漫步主图指标公式

来源:Internet,编辑:股旁网,2017-02-09

板MA5:(REF(C,1)*1.1+REF(C,1)+REF(C,2)+REF(C,3)+REF(C,4))/5,NODRAW;
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市天数));
{}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW,;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.08,0,股本市值),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.16,0,当前业绩),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.24,0,财务系数),COLORGREEN;
TX:=V=HHV(V,120) ;
TX1:=BARSLAST(TX AND REF(C,TX)>REF(C,TX+1) AND REF(V,TX)>REF(V,TX+1));
TX2:=REF(C,TX1);
TX3:=C=LLV(C,TX1);
TXA:=BARSLAST(TX3);
TX4:=REF(C,TXA);
TX5:=(TX2-TX4)*2+TX2;
TX6:=V=HHV(V,30) AND C>REF(C,1) AND V>REF(V,1);
TX7:=BARSLAST(TX6);
TX8:=REF(C,TX7);
TX9:=C=LLV(C,TX8);
TX10:=REF(C,TX9+10);
TX11:=(TX8-TX10)*2+TX2;
目标价:{IF((TX<TX3),TX11,TX5)}TX5,NODRAW,COLOR00FFFF;
均价:=AMOUNT/V/100;
ZTT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停}
N:=30;{此数值可视需要调整}
BL:=V=HHV(V,N) AND V>REF(V,1)*2;
XGA:=ZTT AND BL;
TS:=BARSLAST(XGA);
NOTEXTEE:IF(TS<=9,DRAWLINE(XGA,均价,REF(XGA,1),REF(均价,1),1),DRAWNULL),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,NOTEXTEE,NOTEXTEE),COLORYELLOW;
NOTEXT2:IF(TS<=9,REF(C,TS),DRAWNULL),COLORGRAY;
NOTEXT3:IF(TS<=9,REF(L,TS),DRAWNULL),COLORGRAY;
ED:DRAWNUMBER(BETWEEN(TS,1,9),REF(L,TS),TS),COLORLIGRAY;
已调:HHV(C,10)/L,NODRAW;
庄线A:=(3*CLOSE+OPEN+LOW+HIGH)/6;
庄线B:(19*庄线A+19*REF(庄线A,1)+18*REF(庄线A,2)+17*REF(庄线A,3)+16*REF(庄线A,4)+15*REF
(庄线A,5)+14*REF(庄线A,6)
+13*REF(庄线A,7)+12*REF(庄线A,8)+11*REF(庄线A,9)+10*REF(庄线A,10)+9*REF(庄线A,11)+8*REF
(庄线A,12)
+7*REF(庄线A,13)+6*REF(庄线A,14)+5*REF(庄线A,15)+4*REF(庄线A,16)+3*REF(庄线A,17)+2*REF
(庄线A,20)+
REF(庄线A,19))/210,COLOR000000;
庄线支撑:MA(庄线B,5),COLORRED;
STICKLINE(庄线支撑>C,H,L,0,1),COLORGREEN;
STICKLINE(庄线支撑>C,C,O,2,1),COLORGREEN;
STICKLINE(C>庄线支撑,H,L,0,1),COLORRED;
STICKLINE(C>庄线支撑,C,O,2,1),COLORRED;
ZT:=(C/REF(C,1)-1)*100>9.5;
ZT1:=BARSLAST((C/REF(C,1)-1)*100>9.5);
最后涨停距今数:ZT1,NODRAW,COLORWHITE;
ZT2:=BARSLAST(ZT);
ZT3:=REF(H,ZT2)-REF(L,ZT2);
STICKLINE(C,(REF(L,ZT2)+ZT3*0.5),(REF(L,ZT2)+ZT3*0.5),7,0),COLORRED;
阻力位:(REF(L,ZT2)+ZT3*0.5),NODRAW,COLORFFFFFF;
STICKLINE(C,REF(L,ZT2),REF(L,ZT2),2,0),COLORFFFFFF;
压力支撑位:REF(L,ZT2),NODRAW,COLORFFFFFF;
BA:STICKLINE(ZTT,OPEN,CLOSE,0.1,0),COLORYELLOW;
MB:=L<庄线B AND C>庄线支撑 ;
DRAWICON(MB,L,7);

通达信漫步主图指标公式

 

相关文章