在线检测未来函数

通达信暴涨牛股主图指标公式

来源:Internet,编辑:股旁网,2017-02-07

N:=5;
P1:=32;
P2:=100;
P3:=20;
P4:=80;
K:=0;
K2:=30;
K3:=90;
AAK:=REF(H,N)=HHV(H,2*N+1);
HAN:=DATE<1301230;
QY:=BACKSET(AAK,N+1);
CC:=FILTER(QY,N) AND H=HHV(H,N+1);
DDD:=BARSLAST(CC),NODRAW;
GDTS:=IF(CC,CURRBARSCOUNT,0),NODRAW;
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS),NODRAW;
GDCS1:=CONST(DINGBUTS),NODRAW;
GDCS13:=CONST(REF(HIGH,GDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1),NODRAW;
GDCS2:=CONST(DINGBUTS1);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));
XG1:=BACKSET(ISLASTBAR,GDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1)*HAN ,COLORBLUE,LINETHICK1;
AA1:=REF(L,N)=LLV(L,2*N+1);
QY1:=BACKSET(AA1,N+1);
CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
DDCS13:=CONST(REF(L,DDCS1-1));
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
DDCS23:=CONST(REF(L,DDTS2-1));
XD1:=BACKSET(ISLASTBAR,DDCS1);
XD2:=BACKSET(ISLASTBAR,DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1)*HAN,COLORBLUE,LINETHICK1;
DRAWBAND(高点压力,RGB(00,00,100),低点支撑,RGB(00,00,00));
M:=INTPART(3*N/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0),NODRAW;
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS),NODRAW;
GDCS11:=CONST(DINGBUTSS),NODRAW;
DINGBUTS11:=REF(DINGBUTSS,DDDD+1),NODRAW;
GDCS22:=CONST(DINGBUTS11);
压力:DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1)*HAN,COLORRED,LINETHICK1;
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
支撑:DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1) COLORRED,LINETHICK1;
STICKLINE(XG2,GDCS23,GDCS23,0.5,1)*HAN,COLORWHITE,LINETHICK3;
STICKLINE(XG1,GDCS13,GDCS13,0.5,1)*HAN,COLORYELLOW,LINETHICK3;
STICKLINE(XD2,DDCS23,DDCS23,0.5,1)*HAN,COLORMAGENTA,LINETHICK3;
STICKLINE(XD1,DDCS13,DDCS13,0.5,1)*HAN,COLORCYAN,LINETHICK3;
DRAWKLINE(H,O,L,C);
刀:EMA(CLOSE,5)*HAN,LINETHICK1,COLORYELLOW;
多:IF(刀>REF(刀,1),刀,DRAWNULL)*HAN,COLORRED,LINETHICK1;
空:IF(刀<REF(刀,1),刀,DRAWNULL)*HAN,COLORGREEN,LINETHICK1;
A0:=(L+H+C*2)/4;
A1:=EMA(A0,14)COLORBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*HAN,DRAWNULL)
*HAN,POINTDOT,COLORMAGENTA;
看空:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))*HAN,DRAWNULL)
*HAN,POINTDOT,COLORLIBLUE;
VARPP1:=(C+H+O+L)/4;
看空1:=EMA(CLOSE,15);
【暴涨】:EMA(看空1,5)*0.9,COLORYELLOW,LINETHICK3;
牛股】:IF(【暴涨】>REF(【暴涨】,1),【暴涨】,DRAWNULL)*HAN,COLORRED,LINETHICK2;
抛:XMA(VARPP1,P3)*(1+P4/1000)*HAN,POINTDOT,LINETHICK2;
C3:=REF(C,1);
涨大于5:=IF((C-C3)/C3>0.04,1,0);
跌大于5:=IF((C3-C)/C3>=0.04,3,0);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
{红}
STICKLINE(涨大于5,CLOSE,OPEN,3.2,0)*HAN,COLOR000555;
STICKLINE(涨大于5,CLOSE,OPEN,2.4,0)*HAN,COLOR000777;
STICKLINE(涨大于5,CLOSE,OPEN,1.7,0)*HAN,COLOR000999;
STICKLINE(涨大于5,CLOSE,OPEN,0.9,0)*HAN,COLOR000BBB;
STICKLINE(涨大于5,CLOSE,OPEN,0.3,0)*HAN,COLOR000DDD;
{绿}
STICKLINE(跌大于5,CLOSE,OPEN,3.2,0)*HAN,COLOR005500;
STICKLINE(跌大于5,CLOSE,OPEN,2.7,0)*HAN,COLOR007700;
STICKLINE(跌大于5,CLOSE,OPEN,2.1,0)*HAN,COLOR009900;
STICKLINE(跌大于5,CLOSE,OPEN,1.5,0)*HAN,COLOR00BB00;
STICKLINE(跌大于5,CLOSE,OPEN,0.9,0)*HAN,COLOR00DD00;
STICKLINE(跌大于5,CLOSE,OPEN,0.3,0)*HAN,COLOR00FF00;
{蓝}
STICKLINE(跌停,CLOSE,OPEN,3.2,0)*HAN,COLORFF3300;
STICKLINE(跌停,CLOSE,OPEN,2.7,0)*HAN,COLORFF5500;
STICKLINE(跌停,CLOSE,OPEN,2.1,0)*HAN,COLORFF7700;
STICKLINE(跌停,CLOSE,OPEN,1.5,0)*HAN,COLORFF9900;
STICKLINE(跌停,CLOSE,OPEN,0.9,0)*HAN,COLORFFBB00;
STICKLINE(跌停,CLOSE,OPEN,0.3,0)*HAN,COLORFFDD00;
STICKLINE(涨停,CLOSE,OPEN,3.2,0)*HAN,COLOR0077FF;
STICKLINE(涨停,CLOSE,OPEN,2.5,0)*HAN,COLOR0099FF;
STICKLINE(涨停,CLOSE,OPEN,1.9,0)*HAN,COLOR00BBFF;
STICKLINE(涨停,CLOSE,OPEN,1.2,0)*HAN,COLOR00DDFF;
STICKLINE(涨停,CLOSE,OPEN,0.3,0)*HAN,COLOR00FFFF;
STICKLINE(C=REF(C,1),CLOSE,OPEN,3.2,0)*HAN,COLOR999999;
STICKLINE(C=REF(C,1),CLOSE,OPEN,2.1,0)*HAN,COLORBBBBBB;
STICKLINE(C=REF(C,1),CLOSE,OPEN,1.4,0),COLORFFFFFF;
【提刀夜行】:IF(【暴涨】< REF(【暴涨】,1),【暴涨】,DRAWNULL)*HAN,COLORGREEN,LINETHICK2;
TT:=240/FROMOPEN;
比:=TT;
促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 -
10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1*HAN >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1*HAN < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1*HAN > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1*HAN <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX*HAN,1) > 0)) AND (YYV1 >= YYV2)),1,0));
DRAWTEXT(情况1=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'量能理想,明显走强,仓位在2/3左右
')*HAN,COLORWHITE;
DRAWTEXT(情况2=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03)*HAN,'走势趋强,量能不足,短线进场,仓位
在1/2左右')*HAN,COLORWHITE;
DRAWTEXT(情况3=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03)*HAN,'量价良好,并没有明显走强,短线进
场,仓位1/2左右。 ')*HAN,COLORWHITE;
DRAWTEXT(情况4=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03)*HAN,'形态尚可,量能不足,未完全走强,短
线参与,仓位1/3左右')*HAN,COLORWHITE;
DRAWTEXT(情况9=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03)*HAN,'该股形态良好,强势明显,量能充足
,可以继续持有。 ')*HAN,COLOR00FFFF;
DRAWTEXT(情况10=1 AND (CLOSE < 200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03)*HAN,'该股上行趋势不变,强势依然,但
量能开始转弱,注意风险 ')*HAN,COLOR00FFFF;

通达信暴涨牛股主图指标公式

 

相关文章