在线检测未来函数

通达信分享自用多年的主图指标公式

来源:Internet,编辑:股旁网,2017-02-08

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA20:=MA(CLOSE,20);
FL:HHV(MA20,10);
FS:MA20-(FL-MA20);
MA120:MA(CLOSE,120),LINETHICK2,COLORFF00FF;
MA250:MA(CLOSE,250),LINETHICK3,COLORFFFF00;
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
TT1:=CROSS(MA20,MA120) AND CROSS(MA20,MA250) AND V>REF(V,1);
TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);
STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT1,L-0.13,'金叉'),COLORYELLOW;
STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,3,0),COLORYELLOW;
DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.25,'并线开花'),COLORYELLOW;
STICKLINE(TT2,L-0.02,L-0.09,3,0),COLORYELLOW;
DRAWTEXT(TT2,L-0.18,'买点1'),COLORYELLOW;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),COLOR00FF00;
STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;
DRAWTEXT(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,'牛象'),COLORFFCC66;
STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.04,L-0.09,3,0),COLORFF00FF;
DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,'买点2'),COLORFF00FF;
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
DRAWTEXT(FILTER(((((((((OPEN > MA120) AND (MA20 < MA120)) AND (LOW <= MA120)) AND ((MA20 - REF(MA20,1)) > 0)) AND (CLOSE > OPEN)) AND ((MA120 - REF(MA120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= MA120)),15),LOW,'★120跳马');
{DRAWTEXT(C>REF(C,1) AND MA(C,5)>MA(C,10) AND MA(C,20)>MA(C,60)
AND REF(MA(C,20),1)>REF(MA(C,60),1) AND MA(C,60)>REF(MA(C,60),1) AND FL>MA(C,60)
AND FS>MA(C,60) AND FL=FS AND REF(FL,1)>REF(FS,1) ,FS,'买入' ),COLORYELLOW;}
RSV2:=(CLOSE-LLV(LOW,120))/(HHV(HIGH,120)-LLV(LOW,120))*100;
K2:=SMA(RSV2,12,1);
D2:=SMA(K2,12,1);
E2:=EMA(D2,6);
AA1:=E2>REF(E2,1);
XG:=REF(AA1,1)=0 AND AA1;
DRAWICON(XG,L*0.95,11);
现价线:DYNAINFO(7),DOTLINE,COLORYELLOW;
AA:=VOL>=2*REF(VOL,1);
STICKLINE(AA AND C>O,(C-O)/2+O,O,2.8,0),COLORLIMAGENTA;
STICKLINE(AA AND C<O,C,O,2.5,0),COLORLICYAN;
STICKLINE(C>REF(C,1)*1.098,C,C-(C-O)/2,2.8,0),COLOR00AAAA;
STICKLINE(C>REF(C,1)*1.098,C,C-(C-O)/2,1.5,0),COLOR00BBBB;
STICKLINE(C>REF(C,1)*1.098,C,C-(C-O)/2,1.5,0),COLOR00CCCC;
STICKLINE(C>REF(C,1)*1.098,C,C-(C-O)/2,1,0),COLOR00DDDD;
STICKLINE(C>REF(C,1)*1.098,C,C-(C-O)/2,0.5,0),COLOR00EEEE;
STICKLINE(C>REF(C,1)*1.098,H,C-(C-O)/2,0,0),COLOR00FFFF;
AAA1:=STRCAT('沪深总上涨家数:',CON2STR(DYNAINFO(60),0));
AAA2:=STRCAT('沪深总下跌家数:',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,AAA1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,AAA2),COLORGREEN;
总上涨家数:="SH999999$ADVANCE"+"SZ399001$ADVANCE";
总下跌家数:="SH999999$DECLINE"+"SZ399001$DECLINE";
涨跌比:总上涨家数/总下跌家数,COLORCYAN,NODRAW;
总涨跌比:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,STRCAT('总涨跌比: ',CON2STR(总涨跌比,2))),COLORCYAN;
M:=MOD(DAY,7);
W:=IF(M<=WEEKDAY+1,INTPART((DAY)/7)+1,INTPART((DAY-WEEKDAY)/7)+2);
周几排序:=IF(DAY<=((W-1)*7),W-1,W);
期指交割日:=周几排序=3 AND WEEKDAY=5;
DRAWTEXT(期指交割日,H+0.35,'↙期指交割日'),COLORCYAN;

通达信分享自用多年的主图指标公式

 

相关文章