在线检测未来函数

通达信多指标共振指标公式

来源:Internet,编辑:股旁网,2017-02-13

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI: DMP*100/MTR,LINETHICK3,NODRAW;
MDI: DMM*100/MTR,LINETHICK3,NODRAW;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),NODRAW;
ADXR:EXPMEMA(ADX,6),NODRAW;
IF(ADX>=ADXR,70,DRAWNULL),COLORMAGENTA,LINETHICK9;
IF(ADX<ADXR,70,DRAWNULL),COLORCYAN,LINETHICK8;
DRAWTEXT(ISLASTBAR=1,IF(ADX>=ADXR,70,70),' ADX金'),COLORWHITE;
IF(PDI>=MDI,65,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(PDI<MDI,65,DRAWNULL),COLORGREEN ,LINETHICK6;
DRAWTEXT(ISLASTBAR=1,IF(PDI>=MDI,65,65),' PDI金'),COLORWHITE;
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,NODRAW;
IF(RSI1>=50,60,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(RSI1<50,60,DRAWNULL),COLORGREEN ,LINETHICK6;
DRAWTEXT(ISLASTBAR=1,IF(RSI1>=50,60,60),' RSI'),COLORWHITE;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DEA:EMA(DIF,9),NODRAW;
IF(DIF>=DEA,55,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(DIF<DEA,55,DRAWNULL),COLORGREEN ,LINETHICK6;
DRAWTEXT(ISLASTBAR=1,IF(DIF>=DEA,55,55),' MACD'),COLORWHITE;
主力筹码集中度:WINNER(C)*100,NODRAW;
散户筹码集中度:(WINNER(C*1.1)-WINNER(C*0.9))*100,NODRAW;
IF(主力筹码集中度>=散户筹码集中度,45,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(主力筹码集中度<散户筹码集中度,45,DRAWNULL),COLORGREEN ,LINETHICK6;
DRAWTEXT(ISLASTBAR=1,IF(主力筹码集中度>=散户筹码集中度,45,45),' 获利纵横'),COLORWHITE;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),NODRAW;
D:SMA(K,3,1),NODRAW;
J:3*K-2*D,NODRAW;
IF(J>=K,50,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(J<K,50,DRAWNULL),COLORGREEN ,LINETHICK6;
DRAWTEXT(ISLASTBAR=1,IF(J>=K,50,50),' KDJ'),COLORWHITE;
十天主力持仓:10*WINNER(CLOSE*0.9)*8, COLORCYAN,DOTLINE;
VAR100:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(10);
增减力度:VAR100*6,COLOR0000FF,LINETHICK3;
IF(增减力度<0,增减力度,DRAWNULL),LINETHICK3,COLOR00FFFF;
IF(增减力度,增减力度<10,DRAWNULL),LINETHICK3,COLORFFFF00;
换手:VOL*10000/FINANCE(7),NODRAW;
五日换手:SUM(换手,5),COLORFFFF00,NODRAW;
十日换手:SUM(换手,10),NODRAW;

通达信多指标共振指标公式

 

相关文章