在线检测未来函数

通达信多空黑马指标公式

来源:Internet,编辑:股旁网,2017-02-14

VAR8:=VOL>2*MA(VOL,30);
VAR9:="DMI.ADX"(12,6);
VARA:="DMI.ADXR"(12,6);
VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARF:=TROUGHBARS(3,15,1)<4;
VARF1:=PEAKBARS(3,15,1)<4;
VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
VAR11:=IF(VARF=1,50,0);
多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
IF(多空>0,多空,DRAWNULL),LINETHICK3,COLORRED;
IF(多空<0,多空,DRAWNULL),LINETHICK3,COLORGREEN;
IF((多空<0 AND 多空>REF(多空,1)),多空,DRAWNULL),LINETHICK3,COLORLIMAGENTA;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,31,0,6,0),COLORRED;
STICKLINE(FILTER(VARF=1,5),28,0,4,0),COLORYELLOW;
STICKLINE(FILTER(VARF1=1,5) AND 多空>10,31,0,5,0),COLORMAGENTA;
STICKLINE(FILTER(VARF1=1,5),28,0,4,0),COLORGREEN;
DRAWTEXT(FILTER(VARF=1,3),25,'大黑马'),COLORRED;
DRAWTEXT(FILTER(VARF1=1,3),25,'大黑驴'),COLORLIMAGENTA;
STICKLINE(多空<-10,0,多空,1.1,0),COLORYELLOW;
STICKLINE(多空>10,0,多空,0.9,0),COLORRED;
STICKLINE(多空>0,0,0.1,5,0),COLORRED;
STICKLINE(多空<0,0,0.1,5,0),COLORGREEN;
STICKLINE (VARF=1,0,VARF,8,0),COLORMAGENTA;
STICKLINE (VARF1=1,0,VARF1,8,0),COLORWHITE;

通达信多空黑马指标公式

 

相关文章