在线检测未来函数

同花顺小游资宝塔线主图指标公式

来源:Internet,编辑:股旁网,2017-02-17

x:=(3*C+L+O+H)/6;
宝塔多空线:(20*x+19*REF(x,1)+18*REF(x,2)+17*REF(x,3)+16*REF(x,4)+15*REF(x,5)+14*REF(x,6)
+13*REF(x,7)+12*REF(x,8)+11*REF(x,9)+10*REF(x,10)+9*REF(x,11)+8*REF(x,12)
+7*REF(x,13)+6*REF(x,14)+5*REF(x,15)+4*REF(x,16)+3*REF(x,17)+2*REF(x,18)+
REF(x,20))/210,colorwhite ,linethick1;
STICKLINE(REF(宝塔多空线,1)<宝塔多空线,宝塔多空线,REF(宝塔多空线,1),3,1),colorred;
STICKLINE(REF(宝塔多空线,1)>宝塔多空线,宝塔多空线,REF(宝塔多空线,1),3,1),colorcyan;
var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
var2:=REF(var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var3:=REF(var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var4:=REF(var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var5:=REF(var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var6:=REF(var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var7:=REF(var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var8:=REF(var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var9:=REF(var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varA:=REF(var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
varB:=REF(varA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varC:=REF(varB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR
var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),6,1),colorred;
varD: =CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
varE: =REF(varD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varF: =REF(varE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var10:=REF(varF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var11:=REF(var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var12:=REF(var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var13:=REF(var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var14:=REF(var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var15:=REF(var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var16:=REF(var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var17:=REF(var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var18:=REF(var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR
var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),6,0),COLOR00FF00;
var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR
var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),6,1),coloryellow;
var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR
var8 OR var9 OR varA OR varB OR varC,1) AND varD;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),6,2),Color00ff00, LINETHICK5;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00ffff, LINETHICK5;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),6,0),COLOR00c8ff, LINETHICK5;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR10ecff, LINETHICK5;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ffff, LINETHICK5;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10f0ff, LINETHICK5;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORff50ff, LINETHICK5;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),6,0),COLORff50ff, LINETHICK5;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLORff50ff, LINETHICK5;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORff50ff, LINETHICK5;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLORff50ff, LINETHICK5;
N:=5;
攻击线:MA(C,5),colorlired,LINETHICK3;
动能衰减:IF(C<攻击线,攻击线,DRAWNULL),colorligreen,LINETHICK3;
L1:=TROUGH(2,N,1);
L2:=TROUGH(2,N,2);
T1:=TROUGHBARS(2,N,1);
T2:=TROUGHBARS(2,N,2);
TJ1:=RANGE(L1/攻击线,0.98,1.02);
TJ2:=RANGE(REF(L1,T2)/REF(攻击线,T2),0.98,1.02);
TJ:= TJ1 AND TJ2 ;
TJA:=REF(T1,1)=0 AND REF(L1>L2,1) ;
XG:=TJA AND TJ;
STICKLINE(XG,C,O,1.5,0),coloryellow;
STICKLINE(XG,H,L,0,0),coloryellow;

同花顺小游资宝塔线主图指标公式

 

相关文章