在线检测未来函数

通达信金叉选股指标公式

来源:Internet,编辑:股旁网,2017-02-21

W:=111;
MA5:=MA(C,5);
MA7:=MA(C,7);
MA10:=MA(C,10);
MA14:=MA(C,14);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
{MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
DM比值:=DIF/MACD;
{KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
JX1:=L<MA5 OR L<MA7;
JX2:= MA5>REF(MA5,1) AND MA10>REF(MA10,1)AND MA14>REF(MA14,1)AND MA20>REF(MA20,1);
JX:=JX1 AND JX2;
CJL:=V>MA(V,5) AND V>MA(V,10);
CJL2:=V<MA(V,5)*1.65 AND V<MA(V,10)*1.65;
六十:=(ATAN((MA(C,60)/REF(MA(C,60),1)-1)*100)*180/3.1416);
金叉六十2个点:=J>D AND REF(J,1)<REF(D,1) AND L>MA(C,60)*1.05 AND CJL
AND REF(D,2)<REF(D,3) AND HSL>2 AND HSL<8 AND COUNT(MA60>REF(MA60,1),7)=7 AND J<80
AND C>O AND COUNT(V>MA(V,5)*2,7)=0 AND MA7>MA14 AND J/D>1.1 AND C<REF(C,1)*1.08
AND COUNT(V>MA(V,10)*2,7)=0 AND 六十>36 AND REF(C,1)<REF(C,2)*1.065
AND D<70 AND C<H*0.99 AND MA7>MA10 AND CJL2 AND JX AND V<HHV(V,60)
;
{金叉回踩}
HTCJ:=V>MA(V,5) OR V>MA(V,10);
五日:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.1416);
JC:=J>D AND REF(J,1)<REF(D,1) AND C>O AND COUNT(C>REF(C,1)*1.098,10)=0 AND V<HHV(V,30)
AND L>MA60 AND HTCJ AND REF(D,2)<REF(D,3) AND 五日<45 AND V<MA(V,5)*2 AND V<MA(V,10)*2;
HT:=REF(JC,1) AND C<=O AND J>D AND V<REF(V,1) AND D<75 AND L>MA60 AND COUNT(MA60>REF(MA60,1),7)=7
AND V<MA(V,5) AND V<MA(V,10) {AND JX} AND MA10>REF(MA10,1) AND MACD>0.13 AND O<H
AND J/D>1.08 AND 五日>5 AND O/MA5<1.05 AND J<90 ;
YJ:=金叉六十2个点 OR HT;
ZZ:COUNT(YJ,W)>=1;

通达信金叉选股指标公式

 

相关文章