在线检测未来函数

通达信爆涨主图指标公式

来源:Internet,编辑:股旁网,2017-02-21

MA2:MA(CLOSE,2);
MA9:=MA(CLOSE,9);
MA21:MA(CLOSE,21);
MA30:MA(CLOSE,30);
MA72:MA(CLOSE,72);
{MA200:MA(CLOSE,M5);
MA240:MA(CLOSE,M6);}
YBW:=CROSS(MA2,MA72);
DRAWTEXT(YBW,LOW-0.5,'追'),COLORYELLOW;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
DRAWTEXT(REF(COUNT(MA(C,5)<MA(C,10),5)=5,1) AND CCI>REF(CCI,1) AND
CROSS(CCI,-150),L*0.9,'C背');
{LC:=REF(CLOSE,1);}
{RSI:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;}
{A:REF(RSI,3)=LLV(RSI,2*3+1);}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠仓'),COLOR4080FF;
A:=CLOSE>OPEN;
B:=A&&CLOSE>MA(CLOSE,20)&&CLOSE>MA(CLOSE,40)&&CLOSE>MA(CLOSE,60);
CC:=B&&OPEN<MA(CLOSE,40)&&OPEN<MA(CLOSE,60);
CSFRO:=CC&&(CLOSE-OPEN)>0.0618*CLOSE;
DRAWTEXT(CSFRO,LOW-1.5,'出水芙蓉'),COLORMAGENTA;
C2A:=REF(C,1);
非ST涨停:=IF((C-C2A)*100/C2>=(10-0.01*100/C2A),1,0);
涨停A:=非ST涨停;
STICKLINE(涨停A,OPEN,CLOSE,2,0),COLOR00FFFF;
STICKLINE(涨停A,H,L,0,0),COLOR00FFFF;
非ST跌停:=IF((C2A-C)*100/C2A>=(10-0.01*100/C2A),1,0);
跌停A:=非ST跌停;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
半涨1:=IF((C-C2A)*100/C2A>=(5-0.01*100/C2A),1,0);
半涨2:=IF((C-C2A)*100/C2<(10-0.01*100/C2A),1,0);
JRS:=半涨1 AND 半涨2 AND FINANCE(33)>0;
NUMBER:=COUNT(非ST涨停,BARSSINCE(非ST涨停)+1);
DRAWNUMBER(非ST涨停,HIGH*1.04,NUMBER),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.77,0.01,0,NUMBER),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.67,0.01,0,'上市以来共涨停:'),COLORYELLOW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL20:=MA(VOL,20),COLORFF00FF ;
量托:=VOL5>=VOL20 AND CROSS(VOL10,VOL20) AND REF(VOL10,1)<REF(VOL20,1);
DRAWTEXT(量托,L-0.12,'←量托'),COLORWHITE;
STICKLINE(量托,H,L,0.4,1),COLORWHITE;
STICKLINE(量托,O,C,6,1),LINETHICK2,COLORWHITE;
龙王:= SMA(CLOSE,2,1),LINETHICK2;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,24)*20+C,42);
BU:=CROSS(买线,REF(买线,1)*1.027);
SEL:=CROSS(卖线,买线);
DRAWTEXT(BU,LOW,'牛暴发'),COLORFFFFFF,LINETHICK3;
DRAWTEXT(CROSS(买线,卖线*1.008) AND 龙王>REF(龙王,1)*1.017,HIGH*1.017,'爆牛'),
COLOR00FFFF;{,LINETHICK3;};
卖线A:=EMA(SLOPE(C,21)*20+C,42);
BUA:=CROSS(买线,卖线A);
SELA:=CROSS(卖线A,买线);
DRAWICON(BUA,LOW*0.898,7);
DRAWTEXT(BUA,LOW*0.898,'←益盟'),COLORYELLOW;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),
RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),
RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进>0),
RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出>0),
RGB(23,125,255),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.015,1,0,'主力进出'),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.107,1,0,'散户进出'),COLORCYAN;

通达信爆涨主图指标公式

 

相关文章