在线检测未来函数

通达信先胜通道线主图指标公式

来源:Internet,编辑:股旁网,2017-02-21

AZ:=HHV(H,20),COLORCCFFFF,LINETHICK2;
AX:=LLV(L,20),COLORYELLOW,LINETHICK2;
STICKLINE(C>0,AX-0.5,AZ+0.5,1000000000000,0),COLOR335500;
DRAWTEXT_FIX(1,0.001,0.10,0,'操作说明:通道平稳趋势向上,主线出绿一路持股!主线出“笑脸”或股价站上虚线买,主线变蓝卖!')COLOR0000FF;
涨幅周期:=350;
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
地区:=STRCAT(' 地区:',DYBLOCK),COLOR99CC32;
行业:=STRCAT(' 行业:',HYBLOCK),COLORGREEN;
概念:=STRCAT(' 概念:',GNBLOCK),COLORFF00FF;
Z1:=STRCAT(STKNAME,' ');
Z2:=STRCAT(Z1,CODE);
Z3:=STRCAT(Z2,' ');
Z4:=STRCAT(Z3,FGBLOCK);
Z5:=STRCAT(Z4,地区);
Z6:=STRCAT(Z5,行业);
Z7:=STRCAT(Z6,概念);
DRAWTEXT_FIX(1,0.001,0.01,0,STRCAT(Z7,' ')),COLORCYAN;
{========================股本市值==========================}
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
日期:=CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42))))+19000000;
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV(日期,0),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
每股净资产:=STRCAT(' 每股净资产: ',CON2STR(FINANCE(34),4));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),每股净资产),上市日期));
DRAWTEXT_FIX(ISLASTBAR,0.001,0.06,0,股本市值),COLORGREEN;
{========================底部出击==========================}
CB底:=STRCAT('底部出击: ',CON2STR(COST(0.33),2));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.131,0.160,0,CB底),COLORGREEN;
CB高:=STRCAT('顶部位置: ',CON2STR(COST(99),2));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.221,0.160,0,CB高),COLORRED;
{========================莸利比例==========================}
DRAWTEXT_FIX(1,0.001,0.160,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.055,0.160,0,CONST(WINNER(C )*100)),COLORYELLOW;
赢利%:=WINNER(CLOSE)*100,NODRAW,COLORWHITE;
DRAWTEXT_FIX(赢利%>=95 AND ISLASTBAR,0.095,0.160,0,'高危'),COLORRED;
DRAWTEXT_FIX(赢利%>=80 AND 赢利%<95 AND ISLASTBAR,0.095,0.160,0,'风险'),COLORF00FF0;
DRAWTEXT_FIX(赢利%>=50 AND 赢利%<80 AND ISLASTBAR,0.095,0.160,0,''),COLORYELLOW;
DRAWTEXT_FIX(赢利%<50 AND ISLASTBAR,0.095,0.160,0,'空头'),COLORGREEN;
通道中轨:=MA(CLOSE,30);
通道下轨:通道中轨*0.88,COLOR6C6CFF;
通道上上轨:通道中轨*1.18,COLORGREEN LINETHICK3;
通道下下轨:通道中轨*0.82, COLORGREEN LINETHICK3;
DRAWBAND(通道下下轨,RGB(50,0,0),通道上上轨,RGB(0,50,0))COLOR00CC00;
DRAWICON(CROSS(H,通道上上轨) OR CROSS(C,通道上上轨),H*1.03,4);
通道上轨:通道中轨*1.12,COLORFF6600;
DRAWICON(CROSS(H,通道上轨) OR CROSS(C,通道上轨),H*1.03,2);
AA1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
加仓:=IF(CROSS(AA1,REF(AA1+0.01,1)) AND LLV(AA1,2)=LLV(AA1,8) AND BETWEEN(AA1,20,60),1,0);
波段底:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) -
(2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWTEXT(CROSS(波段底,3),L*0.97,'底');
PM:MA(C,10),COLORWHITE,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),COLORGREEN,LINETHICK5;
IF(PM=REF(PM,1),PM,DRAWNULL);
IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;
AA8:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
BB:=MA(CLOSE,18)+MA(CLOSE,18)-REF(MA(CLOSE,18),1);
分水岭:=IF(MA(CLOSE,18)<BB,BB,MA(CLOSE,8)),COLORFF00FF,LINETHICK1;
操作线:=分水岭-(EMA(C,3)-PM),COLOR00FFFF,LINETHICK1;
生命线60:MA(CLOSE,60)LINETHICK1,COLORMAGENTA;
DRAWICON(生命线60>REF(生命线60,1),生命线60,17);
DRAWICON(CROSS(PM,操作线),L*0.96,5);
ZT:=BARSLAST(C/REF(C,1)-1>=0.1-0.01/REF(C,1) AND C=H);
AQ:=EVERY(C>=REF(L,ZT),ZT);
BQ:=IF(REF(AQ,ZT+1) AND REF(ZT,ZT+1)<13,REF(ZT,ZT+1)+ZT+1,ZT);
DRAWTEXT(ZT<=10 AND AQ,REF(L,ZT)*0.96,VAR2STR(ZT,0)),COLORGREEN;
DRAWTEXT(ZT>=6 AND ZT<=8 AND AQ,REF(L,ZT)*0.96,VAR2STR(ZT,0)),COLORRED;
DRAWTEXT(BQ>0 AND BQ<=10 AND BQ!=AQ,REF(L,BQ)*0.96,VAR2STR(BQ,0)),COLORGREEN;
DRAWTEXT(BQ>=6 AND BQ<=8 AND BQ!=AQ,REF(L,BQ)*0.96,VAR2STR(BQ,0)),COLORRED;
STICKLINE(C>=O AND O>0,HIGH,LOW,0.5,0),COLOR0000CD;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,3,0),COLOR070084;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,2.5,0),COLOR0000A3;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,2,0),COLOR0000B7;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,1.5,0),COLOR0000CD;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,1,0),COLOR0000E9;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,0.5,0),COLOR0754E9;
STICKLINE(C>=O AND O>0,CLOSE,OPEN,0.5,0),COLOR68B8FF;
STICKLINE(C<O AND O>0,HIGH,LOW,0.5,0),COLORFFBE00;
STICKLINE(CLOSE<OPEN AND OPEN>0,HIGH,LOW,0.5,0),COLORFFBE00;
STICKLINE(CLOSE<OPEN AND OPEN>0,CLOSE,OPEN,3,0),COLORCA6500;
STICKLINE(CLOSE<OPEN AND OPEN>0,CLOSE,OPEN,2.5,0),COLORE17100;
STICKLINE(C>1.099*REF(C,1),O,C,2,0),COLORYELLOW;
STICKLINE(C>1.099*REF(C,1),O,C,2,0),COLORYELLOW;
LC:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-LC,0),5.5,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VARA00:=((AMOUNT)/(VOL))/(100);
VARAB00:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARAC00:=((SUM(AMOUNT,7))/(VARA00))/(100);
VARD0:=DMA(VARAB00,(VOL)/(VARAC00));
VARDE0:=((CLOSE-VARD0)/(VARD0))*(100);
VARDE0F:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARDE0JF:=MA(VARDE0,20)+STD(VARDE0,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARDE0F,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARDE0JF,VARDE0) AND (AA>79);
DRAWTEXT(CROSS(84,RSI) AND CROSS(76,VAR28),H*1.01,'卖出'),LINETHICK4,COLORGREEN;
VAR23:=REF(LOW,1);
VAR33:=SMA(ABS(LOW-VAR23),3,1)/SMA(MAX(LOW-VAR23,0),3,1)*100;
VAR44:=EMA(IF(CLOSE*1.3,VAR33*10,VAR33/10),3);
VAR556:=LLV(LOW,13);
VAR667:=HHV(VAR44,13);
VAR777:=IF(MA(CLOSE,34),1,0);
VAR888:=EMA(IF(LOW<=VAR556,(VAR44+VAR667*2)/2,0),3)/618*VAR777;
VAR999:=IF(VAR888>100,100,VAR888);
吸筹:=VAR999,LINETHICK2,COLORRED;
DRAWICON(CROSS(吸筹,80),L*0.95,26);
T11:=CONST(LLVBARS(L,10));
T11H:=CONST(REF(H,T11));
CC:=CONST(CURRBARSCOUNT);
T12:=CONST(BARSLAST(CURRBARSCOUNT>CC+T11 AND H>T11H));
T12H:=CONST(REF(H,T12));
T13:=CONST(BARSLAST(CURRBARSCOUNT>CC+T12 AND H>T12H));
T13H:=CONST(REF(H,T13));
上线买1:DRAWLINE(CURRBARSCOUNT=T13+1,T13H,ISLASTBAR,T13H,1) DOTLINE,COLOR0000FF;
DRAWTEXT(ISLASTBAR,T13H,' 虚线上买!')LINETHICK1,COLOR0000FF;

通达信先胜通道线主图指标公式

 

相关文章