在线检测未来函数

通达信小周箱体趋势主图指标公式

来源:Internet,编辑:股旁网,2017-03-01

AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/
(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA:=EMA(AB,5);
A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);
B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);
D{中}:=((A1)+(B1))/2;
箱顶:IF(AB>0 AND AB-BA<=0,A1,A1),LINETHICK3,COLOR00FF00;
箱腰:IF(AB>0 AND AB-BA<=0,D,D),LINETHICK3,COLOR00FF00;
箱低:IF(AB>0 AND AB-BA<=0,B1,B1),LINETHICK3,COLOR00FF00;
五:IF(CURRBARSCOUNT=6,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORWHITE,LINETHICK3;{五日转点}
十:IF(CURRBARSCOUNT=11,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{十日转点}
二十:IF(CURRBARSCOUNT=21,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORRED,LINETHICK3;{二十日转点};
三十:IF(CURRBARSCOUNT=31,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORCYAN,LINETHICK3;{三十日转点};
六十:IF(CURRBARSCOUNT=61,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{六十日转点};
九十:IF(CURRBARSCOUNT=91,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{九十日转点};
高1:IF(AB>0 AND AB-BA>0,A1,DRAWNULL),LINETHICK3,COLORRED;
中1:IF(AB>0 AND AB-BA>0,D,DRAWNULL),LINETHICK3,COLORRED;
低1:IF(AB>0 AND AB-BA>0,B1,DRAWNULL),LINETHICK3,COLORRED;

通达信小周箱体趋势主图指标公式

 

相关文章