在线检测未来函数

通达信多合一指标公式

来源:Internet,编辑:股旁网,2017-03-02

N:=10;
M:=5;
COHL:=XMA((OPEN+HIGH+LOW+CLOSE)/4,2);
DIFF:=EMA(COHL,12) - EMA(COHL,26);
DEA:=EMA(DIFF,9);
MACD0:=2*(DIFF-DEA),COLORSTICK;
MACD:(100*MACD0/HHV(ABS(MACD0),120)+100)/2;
KDJ:(COHL-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
LC:=REF(COHL,1);
RSI:SMA(MAX(COHL-LC,0),N,1)/SMA(ABS(COHL-LC),N,1)*100;
CCI0:=(COHL-MA(COHL,N))/(0.015*AVEDEV(COHL,N));
CCI:(CCI0+200)/4;
ROC:2*(100*(COHL-REF(COHL,N))/REF(COHL,N)+20);
BIAS:(COHL-MA(COHL,N))/MA(COHL,N)*100+50;
PSY:COUNT(COHL>REF(COHL,1),N)/N*100;
全能0:=(MACD+KDJ+RSI+CCI+ROC+BIAS+PSY)/7,COLORRED;
全能:FORCAST(全能0,5),COLORRED,LINETHICK2;
{买卖信号}
买:=LLV(全能,2)=LLV(全能,7) AND {COUNT(全能<50,2) AND} CROSS(全能,MA(全能,2));
DRAWICON(FILTER(买=1,5),5,1),COLORRED;{买信号}
卖:=HHV(全能,2)=HHV(全能,7) AND {COUNT(全能>50,2) AND} CROSS(MA(全能,2),全能);
DRAWICON(FILTER(卖=1,5),95,2),COLORGREEN;{卖信号};
中位线:50;

通达信多合一指标公式

 

相关文章