在线检测未来函数

通达信龙上山指标公式

来源:Internet,编辑:股旁网,2017-03-03

STICKLINE(C>0,0,120,15,0),COLORBLUE;
RSV:=(CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
FASTK:=SMA(RSV,3,1);
龙:SMA(FASTK,2,1);
龙D:=SMA(龙,5,1);
DRAWBAND(龙D,RGB(0,104,154),龙,RGB(255,0,0));
STICKLINE(龙>=龙D,龙D,龙,3,0),COLOR000085;
STICKLINE(龙<龙D,龙D,龙,3,0),COLOR324800;
DRAWTEXT(CROSS(龙D,龙) AND 龙>70,50,'卖'),COLORGREEN;
L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*200-60;
凤:SMA(L1,3,1),COLORYELLOW;
凤D:=SMA(凤,3,1),COLORRED;
DRAWBAND(凤D,RGB(0,128,0),凤,RGB(255,97,0));
DRAWTEXT(CROSS(凤D,凤)AND 凤>78,凤,'←快卖');
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=1000* (2*(DIFF-DEA))/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
VAR1:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
VAR2:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND VAR1<20,5);
VAR3:=CROSS(VAR1,90);
准备:IF(VAR1<3.5,15,0),COLORCYAN,LINETHICK2;
DRAWTEXT(VAR1<3.5,7,'准备'),COLORCYAN;
钱进:IF(VAR2,20,0),COLORMAGENTA,LINETHICK3;
DRAWTEXT(VAR2,10,'“钱”进'),COLORRED;
{DRAWTEXT(VAR3,70,'凤舞ラ小心'),COLORCYAN;}
VAR4:=LLV(LOW,10);
VAR5:=HHV(H,25);
VAR6:=EMA((C-VAR4)/(VAR5-VAR4)*4,4);
DRAWTEXT(CROSS(3.5,VAR6),110,'急卖');
恭喜:STICKLINE(CROSS(VAR6,0.3),-50,-30,3,0), COLOR00AAFF,LINETHICK1;
STICKLINE(CROSS(VAR6,0.3),-40,-30,3,0),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(VAR6,0.3),-45,'恭喜'),COLORMAGENTA;
发财:STICKLINE(CROSS(3.5,VAR6),100,120,2,0), COLORRED,LINETHICK2;
STICKLINE(CROSS(3.5,VAR6),110,120,2,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(3.5,VAR6),90,'发财'),COLORYELLOW;
龙行凤影:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
龙飞:IF(龙行凤影<=10,-20,-40),COLOR0000FF,LINETHICK2;
{DRAWTEXT(龙行凤影<=10,-25,'龙飞'),COLORYELLOW;}
DRAWTEXT(CROSS( 0,MACD)AND VAR1>75,110,'☆高空'),COLORFFFFFF;
红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
花开:IF(CROSS(红红的天,2),70,-50),COLORLIMAGENTA,LINETHICK2;
DRAWTEXT(CROSS(红红的天,2),75,'花开了'),COLORMAGENTA;
IF(CROSS(红红的天,2),70,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
IF(CROSS(红红的天,2),70,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
RSV1:=(((CLOSE - LLV(LOW,29)) / (HHV(HIGH,29) - LLV(LOW,29))) * 100);
K1:=MA(RSV1,5);
D1:=MA(K1,2);
J1:=((3 * K1) - (2 * D1));
明天涨:IF((J1 < 5),25,0),COLORRED,LINETHICK2;
DRAWTEXT((J1 < 5),30,'明天涨'),COLORYELLOW;
R:=RSI;
MAR:=MA(R,3);
F:=100*(C-REF(C,1))/REF(C,1);
HHH:=EMA(R,25)+6,COLORBLUE;
GAODIAN:=REF(R,1)>REF(R,2) AND REF(R,1)>R;
DIDIAN:=(REF(R,1)<REF(R,2) AND REF(R,1)<R) OR (REF(R,1)=REF(R,2) AND REF(R,1)<R AND REF(R,2)<REF(R,3));
BIAOJI:=CROSS(HHH,R);
JIN:STICKLINE(REF(R,2)>REF(R,3) AND REF(R,2)>REF(R,1) AND R>REF(R,1)
AND MAR>REF(MAR,1)+1 AND REF(MAR,2)-REF(MAR,1)>-1
AND REF(R,1)<REF(MAR,1) AND REF(R,2)-REF(MAR,2)>-3
AND REF(R,1)<38 AND R<HHH AND F<8,100,120,2,0),COLORRED;
DRAWTEXT(JIN,110,'RSI买'),COLORYELLOW;
VAR7:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
VAR8:=EMA(VAR7,5), LINETHICK2,COLOR6600FF;
VAR9:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),LINETHICK2;
STICKLINE(CROSS(VAR8,VAR9),0,20,2,0);
DRAWTEXT(CROSS(VAR8,VAR9),20,'追涨');
VOLUME:=VOL/10000,VOLSTICK;
MAVOL1:=MA(VOLUME,5)/10000;
MAVOL2:=MA(VOLUME,35)/10000;
MAVOL3:=MA(VOLUME,135)/10000;
地量:IF(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),-25,-50),COLORMAGENTA,LINETHICK3;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),-29,' 地量'),COLORRED;
DRAWTEXT(LAST(MA(C,5)<MA(C,10),5,0) AND "CCI.CCI">REF("CCI.CCI",1) AND CROSS("CCI.CCI",-100),-45,'CCI买点'),COLORYELLOW;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
LC:=REF(CLOSE,1);
RSI2:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
出局:IF(CROSS(88,RSI2),100,120),COLORLIGREEN,LINETHICK3;
DRAWTEXT(CROSS(88,RSI2),100,'虎'),COLORGREEN;
RSV3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV3,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
进场:IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,0,-20),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,-10,'龙'),COLORYELLOW;
WZ:=150=CURRBARSCOUNT;
{DRAWTEXT(WZ=1,50,'【选准股票,认定指标,信号出现,坚决执行,波段操作,必有收益】'),COLORYELLOW;}
DRAWTEXT_FIX(1,0.3,1,0,'【选准股票,认定指标,信号出现,坚决执行,波段操作,必有收益】 ')COLORYELLOW;

通达信龙上山指标公式

 

相关文章