在线检测未来函数

通达信强势股狙击点指标公式

来源:Internet,编辑:股旁网,2017-03-08

A1:=(((2 * CLOSE) + HIGH) + LOW) / 4;
A2:=LLV(LOW,34);
A3:=HHV(HIGH,34);
A4:=EMA((((A1 - A2) / (A3 - A2)) * 100),13);
A5:=EMA(((0.667 * (REF(A4,1))) + (0.333 * A4)),2);
A6:=(HHV(HIGH,9)) - (LLV(LOW,9));
A7:=(HHV(HIGH,9)) - CLOSE;
A8:=CLOSE - (LLV(LOW,9));
A9:=((A7 / A6) * 100) - 70;
A10:=((CLOSE - (LLV(LOW,60))) / ((HHV(HIGH,60)) - (LLV(LOW,60)))) * 100;
A11:=SMA(((A8 / A6) * 100),3,1);
A12:=(SMA(A11,3,1)) - (SMA(A9,9,1));
A13:=IF((A12 > 100),(A12 - 100),0);
快线:EMA((((A1 - A2) / (A3 - A2)) * 100),5),COLORWHITE,LINETHICK1;
慢线:EMA(快线,13),COLORGREEN,LINETHICK1;
红柱:IF((快线 - 慢线) > 0,(快线 - 慢线),0),LINETHICK0;
蓝柱:IF((快线 - 慢线) < 0,(ABS(快线 - 慢线)),0),LINETHICK0;
STICKLINE(((快线 - 慢线) > 0),快线,慢线,0.05,-1),COLORRED;
STICKLINE(((快线 - 慢线) < 0),快线,慢线,0.05,-1),COLORFFCC00;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
VAR3:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR4:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR3>0, 91, 0);
短线买入:FILTER(VAR4>1,5),COLOR0099FF,POINTDOT;
STICKLINE(CROSS(VAR3,VAR4),55,0,4,0),COLOR0099FF;
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:FILTER(MR,10);

通达信强势股狙击点指标公式

 

相关文章