在线检测未来函数

通达信牛熊抓牛神器指标公式

来源:Internet,编辑:股旁网,2017-03-15

上升线:EMA(CLOSE,3),COLORRED;
下降线:EMA(CLOSE,5),COLORGREEN;
中间线:EMA(下降线,5),COLORWHITE;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(CLOSE-VAR2,6,1)/SMA(ABS(CLOSE-VAR2),6,1)*100;
VAR4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VAR5:=EMA(0.667*REF(VAR4,1)+0.333*VAR4,5);
VAR6:=IF(VOL>=1.3*MA(VOL,5) AND COUNT(VAR4>=VAR5 AND VAR4<(-17),3) AND REF(LOW,1)=LLV(LOW,120),1,0);
VAR7:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR8:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
VAR9:=IF(COUNT(VAR8<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWICON(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,2);
DRAWTEXT(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,1),COLORYELLOW;
DRAWTEXT(FILTER(VAR9 OR VAR6,5),LOW*0.98,2),COLORRED;
DRAWICON(FILTER(CROSS(上升线,下降线) AND 中间线>=REF(中间线,1) AND VAR3<50,5),上升线,1);
DRAWTEXT(FILTER(CROSS(上升线,下降线) AND 中间线>=REF(中间线,1) AND VAR3<50,5),LOW*0.98,2),COLORLIGRAY;
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA30:MA(CLOSE,30),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORRED;
MA120:MA(CLOSE,120),COLORCYAN;
DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(SLOPE(CLOSE,21)*20+CLOSE,42)),LOW*0.98,3),COLORF00FF0,LINETHICK3;
DRAWTEXT(CROSS(EMA(SLOPE(CLOSE,21)*20+CLOSE,42),EMA(CLOSE,2)),HIGH*1.02,4),COLORWHITE,LINETHICK3;
STICKLINE(EMA(CLOSE,2)>=EMA(SLOPE(CLOSE,21)*20+CLOSE,42),LOW,HIGH,0,0),COLORRED;
STICKLINE(EMA(CLOSE,2)>=EMA(SLOPE(CLOSE,21)*20+CLOSE,42),CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE(EMA(CLOSE,2)>=EMA(SLOPE(CLOSE,21)*20+CLOSE,42),CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE(EMA(CLOSE,2)<EMA(SLOPE(CLOSE,21)*20+CLOSE,42),CLOSE,OPEN,2,0),COLORCCCC00;
STICKLINE(EMA(CLOSE,2)<EMA(SLOPE(CLOSE,21)*20+CLOSE,42),CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE(EMA(CLOSE,2)<EMA(SLOPE(CLOSE,21)*20+CLOSE,42),LOW,HIGH,0,0),COLORCYAN;
STICKLINE(CROSS(EMA(CLOSE,2),EMA(SLOPE(CLOSE,21)*20+CLOSE,42)) OR CROSS(EMA(SLOPE(CLOSE,21)*20+CLOSE,42),EMA(CLOSE,2)),LOW,HIGH,0,0),COLORYELLOW;
STICKLINE(CROSS(EMA(CLOSE,2),EMA(SLOPE(CLOSE,21)*20+CLOSE,42)) OR CROSS(EMA(SLOPE(CLOSE,21)*20+CLOSE,42),EMA(CLOSE,2)),OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE(CROSS(EMA(CLOSE,2),EMA(SLOPE(CLOSE,21)*20+CLOSE,42)) OR CROSS(EMA(SLOPE(CLOSE,21)*20+CLOSE,42),EMA(CLOSE,2)),OPEN,CLOSE,2,0),COLOR00CCCC;

通达信牛熊抓牛神器指标公式

 

相关文章