在线检测未来函数

通达信胡乱拼凑的一个主图指标公式

来源:Internet,编辑:股旁网,2017-03-16

DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW,NODRAW;
MA20:MA(CLOSE,20) COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN,NODRAW;
MA120:MA(CLOSE,120),NODRAW,COLORLIGRAY;
MA240:MA(CLOSE,240) COLORLIBLUE LINETHICK1;
假阳:=OPEN<CLOSE AND CLOSE<REF(CLOSE,1);
STICKLINE(假阳,OPEN,CLOSE,0.5,0),COLORLIBLUE;
假阴:=OPEN>CLOSE AND CLOSE>REF(OPEN,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(假阴,OPEN,CLOSE,0.5,0),COLORRED;
AA:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB:=REF(COUNT(C<MA60,AA)=AA,1);
CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC,COLOR00FF00;
STICKLINE(芙蓉出水,O,C,4,0),LINETHICK2,COLORFF00FF;
一穿三:=MA5>O AND MA10>O AND MA5<C AND MA10<C AND CLOSE>OPEN ;
STICKLINE(一穿三,O,C,2,0),COLORRED;
实体中位:IF(CLOSE>=OPEN,OPEN+(CLOSE-OPEN)/2,CLOSE+(OPEN-CLOSE)/2),COLORRED,NODRAW;
JJ:=(H+L+C)/3;
涨幅:=(MAX(H,L)-MIN(H,L))/REF(JJ,1)>=0.02;
STICKLINE( 涨幅,JJ,JJ,4,2),LINETHICK2,COLORYELLOW;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
DRAWICON(CROSS(MA5,MA10),MA5,1);
{STICKLINE( C<MA60,H,L,0,0),COLOR777777;
STICKLINE( C<MA60,O,C,2.7,1),COLOR777777;};
STICKLINE( 涨幅,JJ,JJ,4,2),LINETHICK2,COLORYELLOW;
LHH:MA5*1.20,COLOR996633;
LHD:MA5*1.10,COLOR996633;
VAR4:=EXPMA(CLOSE,9);
LDD:EXPMA(VAR4*0.86,5),COLOR4F4F4F;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLORgray;
DRAWTEXT_FIX(1,0.00,0,0,DYBLOCK)COLORgray;

通达信胡乱拼凑的一个主图指标公式

 

相关文章