在线检测未来函数

同花顺抓大势指标公式

来源:Internet,编辑:股旁网,2017-03-17

Var3:=LLV(HIGH,240);
Var4:=100*(CLOSE-Var3)/Var3;
Var5:=REF(LLV(CLOSE,480),1);
Var6:=REF(HHV(CLOSE,480),1);
Var7:=100*(CLOSE-Var5)/(Var6-Var5);
Var8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
Var9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VarA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VarB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VarC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VarD:=IF(VarC>23.16,VarC,0);
VarE:=VarC<1;
VarF:=VarD;
Var10:=Var4<0 AND Var7<0;
Var11:=1;
Var12:=(HIGH+LOW+CLOSE*2)/4*Var11;
Var13:=EMA(Var12,21);
Var14:=STD(Var12,21);
Var15:=((Var12-Var13)/Var14*100+200)/4*Var11;
Var16:=(EMA(Var15,89)-25)*1.56*Var11;
Var17:=EMA(Var16,5)*1.22*Var11;
Var18:=EMA(Var17,3)*Var11;
Var19:=3*Var17-2*Var18*Var11;
Var1A:=IF(CROSS(Var19,Var17) AND CROSS(Var19,Var18) AND CROSS(Var17,Var18),1,0);
Var1B:=IF(CROSS(Var17,Var19) AND CROSS(Var18,Var19) AND CROSS(Var18,Var17),1,0);
买点:IF(FILTER(Var8=0 AND VarE AND Var10 AND Var1A,5)=1,10,0), colorred;
卖点:IF(FILTER(Var8=100 AND VarF AND Var1B,5)=1,10,0), colorgreen;
Var1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
Var1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
Var1E:=EMA(Var1D,30);
Var1F:=2*(Var1D-Var1E)*10;
Var20:=POW(Var1F,3)*0.1+POW(Var1F,2);
Var21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var22:=EMA(Var21*0.97,3);
Var23:=(HIGH+LOW+CLOSE)/3;
Var24:=(Var23-MA(Var23,14))/(0.015*AVEDEV(Var23,14));
Var25:=IF(YEAR<2008 AND Var1F>0.015,Var20,0)/45;
庄拉线: Var25,coloryellow ;
Var26:=EMA(CLOSE,2)-EMA(CLOSE,150);
Var27:=EMA(Var26,100);
Var28:=2*(Var26-Var27);
Var29:=POW(Var28,3)*0.1+POW(Var28,1);
Var2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var2B:=EMA(Var2A*0.97,3);
Var2C:=(HIGH+LOW+CLOSE)/3;
Var2D:=(Var2C-MA(Var2C,14))/(0.015*AVEDEV(Var2C,14));
黑马线:IF( Var28>0.1,Var29,0)*5, colorcyan;
量价线:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100, colorwhite;
Var2E:=IF(FILTER(量价线>0 AND 量价线<3,5)=1,12,0);
涨幅前兆: IF(FILTER(庄拉线>0 AND 庄拉线<0.5 AND Var2E AND Var1C<3,10)=1,10,0), colorred;
选股利器: IF(FILTER(Var2E>0 AND Var1C<2 AND 庄拉线>0 AND 庄拉线<1
AND 黑马线>0 AND 黑马线<1.5 AND Var2E>0,5)=1,10,0),colorff1166;
DRAWTEXT(买点>0,10,'买'),colorred;
DRAWTEXT(卖点>0,10,'卖'),colorgreen;
DRAWTEXT(涨幅前兆>0,10,'前兆'),colorred;
DRAWTEXT(选股利器>0,10,'选股利器'),Colorff1166;

飞狐抓大势指标公式

 

相关文章