在线检测未来函数

通达信MA带动态读盘主图指标公式

来源:Internet,编辑:股旁网,2017-03-20

M1:=5;
M2:=10;
M3:=20;
M4:=60;
日线:MA(CLOSE,5),;
十日线:MA(CLOSE,10),COLORRED;
二十日线:MA(CLOSE,20),LINETHICK2,COLORGREEN;
三十日线:MA(CLOSE,30),LINETHICK2,COLORMAGENTA;
季度线:MA(CLOSE,60),LINETHICK2,COLORCYAN;
半年线:MA(CLOSE,120),LINETHICK2,COLORYELLOW;
年度线:MA(CLOSE,250),LINETHICK2,COLORWHITE;
DRAWTEXT_FIX(1,0,0.01,0, '【动态读盘】'),COLORWHITE;
DRAWTEXT_FIX(1,0.06,0.01,0,'当日买卖量 ='),COLORWHITE;
DRAWTEXT_FIX(1,0.19,0.01,0,'日主动买量 ='),COLORWHITE;
DRAWTEXT_FIX(1,0.32,0.01,0,'日主动卖量 ='),COLORWHITE;
DRAWTEXT_FIX(1,0.45,0.01,0,'当日买卖比 ='),COLORWHITE;
DRAWTEXT_FIX(1,0.55,0.01,0,'买入累计万元: '),COLORWHITE;
DRAWTEXT_FIX(1,0.68,0.01,0,'卖出累计万元: '),COLORWHITE;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,AA*(HIGH-LOW),VOL/2));
买卖比:=主动买盘/主动卖盘;
WJ:=(HIGH+LOW+CLOSE)/3;
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
VD6:=(VD1*VD5);
VD7:=(VD2*VD5);
VD8:=(VD3*VD5);
VD9:=(VD4*VD5);
买入量:=(VD9+VD8);
卖出量:=(VD6+VD7);
买入资金:=买入量*CLOSE/100;
卖出资金:=卖出量*CLOSE/100;
DRAWNUMBER_FIX(1,0.12,0.01,0,CONST(VOL)),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.25,0.01,0,CONST(主动买盘)),COLORFF00FF;
DRAWNUMBER_FIX(1,0.38,0.01,0,CONST(主动卖盘)),COLORFFFFFF;
DRAWNUMBER_FIX(1,0.51,0.01,0,CONST(买卖比)),COLOR00FF00;
DRAWNUMBER_FIX(1,0.62,0.01,0,CONST(买入资金)),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.75,0.01,0,CONST(卖出资金)),COLORRED;

通达信MA带动态读盘主图指标公式

 

相关文章