在线检测未来函数

通达信终极买入升级版指标公式

来源:Internet,编辑:股旁网,2017-03-21

VAR1AA:=5;
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2
*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
准备启爆点:IF(CROSS(趋势,VAR1AA),0,-50);
R4:=(2*C+H+L)/4;
R5:=LLV(L,94);
R6:=HHV(H,89);
快:EMA((C-R5)/(R6-R5)*100,8),COLORWHITE;
慢:EMA(0.667*REF(快,1)+0.333*快,10),COLORCYAN;
DF:=3;
N1:=12;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
RSV2:EMA((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100,2),COLORRED;
RSV1:EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3),COLORYELLOW;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
KK:=SMA(RSV,3,1);
DD:=SMA(K,3,1);
N:=KK+DD;
关注区:STICKLINE(N<50,N,50,2,0),COLORRED;
风险区:STICKLINE(N>160,N,160,2,0),COLORGREEN;
成本区:50,COLORYELLOW,LINETHICK2;
GWGD:=N<REF(N,1) AND REF(N,1)>=160 AND REF(N,1)>=REF(N,2);
获利区:160,COLOR007700,LINETHICK2;
操盘线:N,COLORFF00FF,LINETHICK1;
买:DRAWICON(CROSS(N,50),50,26),COLORRED;
卖:DRAWICON(CROSS(160,N),160,15),COLORGREEN;
AA:=(C+O+L+H)/4;{以下含未来,不喜删除};
{金前瞻豪版}
A1:=IF(DATE>=11908015,0,1);{这是时间限制}
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2))*A1;
庄家轨迹:=(EMA(A7,A2))*A1,;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8))*A1;
A17:=(EMA(A16,5))*A1;
A18:=(EMA(CLOSE,2))*A1;
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42))*A1;
A20:=(HHV((MA(HIGH,13)),13))*A1;
A21:=(LLV((MA(HIGH,13)),1))*A1;
A22:=(EMA(CLOSE,4))*A1;
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
金前瞻豪版XG:(A28 OR A31),NODRAW;
DRAWICON(金前瞻豪版XG,50,23),COLORRED;
VAR1:=C>MA(C,22) AND CROSS(MA(C,5),MA(C,11));
VAR2:=MACD.DIF>MACD.DEA;
VAR3:=MACD.DIF>0 AND MACD.DEA>0;
XG大胆:VAR1 AND VAR2 AND VAR3,NODRAW;
DRAWICON(XG大胆,90,11),COLORRED;
短DIFF1:=EMA(CLOSE,3)-EMA(CLOSE,6);
短DEA1:=EMA(短DIFF1,4);
短MACD1:=2*(短DIFF1-短DEA1);
短MACD2:=EMA(短MACD1,5);
短低位金叉:=CROSS(短DIFF1,短DEA1) AND 短DIFF1<-0.1;
短JCCOUNT:=COUNT(CROSS(短DIFF1,短DEA1),BARSLAST(短DEA1>=0));
二次金叉:=CROSS(短DIFF1,短DEA1) AND 短DEA1<0 AND COUNT(短JCCOUNT=2,21)=1;
短A111:=BARSLAST(REF(CROSS(短DIFF1,短DEA1),1));
短底背离:=REF(CLOSE,短A111+1)>CLOSE AND 短DIFF1>REF(短DIFF1,短A111+1) AND CROSS(短DIFF1,短DEA1);
短三:短低位金叉 AND 短二次金叉 AND 短底背离,NODRAW;
STICKLINE(短三,100,80,3,0),COLORMAGENTA;
DRAWICON(短三,100,26);
中DIFF1:=EMA(CLOSE,6)-EMA(CLOSE,13);
中DEA1:=EMA(中DIFF1,5);
中MACD1:=2*(中DIFF1-中DEA1);
中MACD2:=EMA(中MACD1,5);
中低位金叉:=CROSS(中DIFF1,中DEA1) AND 中DIFF1<-0.1;
中JCCOUNT:=COUNT(CROSS(中DIFF1,中DEA1),BARSLAST(中DEA1>=0));
中二次金叉:=CROSS(中DIFF1,中DEA1) AND 中DEA1<0 AND COUNT(中JCCOUNT=2,21)=1;
中A111:=BARSLAST(REF(CROSS(中DIFF1,中DEA1),1));
中底背离:=REF(CLOSE,中A111+1)>CLOSE AND 中DIFF1>REF(中DIFF1,中A111+1) AND CROSS(中DIFF1,中DEA1);
{DRAWBMP(中低位金叉 AND 中二次金叉 AND 中底背离,0,'02');}
STICKLINE(中低位金叉 AND 中二次金叉 AND 中底背离,120,100,3,0),COLORYELLOW;
DRAWICON(中低位金叉 AND 中二次金叉 AND 中底背离,120,9);
长DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
长DEA1:=EMA(长DIFF1,9);
长MACD1:=2*(长DIFF1-长DEA1);
长MACD2:=EMA(长MACD1,9);
长低位金叉:=CROSS(长DIFF1,长DEA1) AND 长DIFF1<-0.1;
长JCCOUNT:=COUNT(CROSS(长DIFF1,长DEA1),BARSLAST(长DEA1>=0));
长二次金叉:=CROSS(长DIFF1,长DEA1) AND 长DEA1<0 AND COUNT(长JCCOUNT=2,21)=1;
长A111:=BARSLAST(REF(CROSS(长DIFF1,长DEA1),1));
长底背离:=REF(CLOSE,长A111+1)>CLOSE AND 长DIFF1>REF(长DIFF1,长A111+1) AND CROSS(长DIFF1,长DEA1);
{DRAWBMP(长低位金叉 AND 长二次金叉 AND 长底背离,0,'02');}
STICKLINE(长低位金叉 AND 长二次金叉 AND 长底背离,140,120,3,0),COLORRED;
DRAWICON(长低位金叉 AND 长二次金叉 AND 长底背离,140,24);
LS:=C/REF(C,1)>1.01 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升:FILTER(LS,1),NODRAW;
DRAWICON(拉升,160,25);
{强势股反杀3}
HJ_1:=CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH;
HJ_2:=REF(CLOSE,1)/REF(CLOSE,2)<=0.96 OR REF(OPEN,1)/REF(CLOSE,1)>=1.05;
HJ_3:=HIGH/REF(CLOSE,1)>1.041 AND CLOSE>REF(CLOSE,1);
HJ_4:=HJ_2 AND HJ_3;
HJ_5:=REF(CLOSE,2)/REF(CLOSE,3)<1.099;
HJ_6:=HJ_4 AND HJ_5;
HJ_7:=COUNT(REF(HJ_1,3),8) AND HJ_6;
HJ_8:=MA(CLOSE,20);
HJ_9:=CLOSE>MA(CLOSE,5);
HJ_10:=MA(CLOSE,5)>MA(CLOSE,10);
HJ_11:=CLOSE>MA(CLOSE,10);
HJ_12:=MA(CLOSE,5)>MA(CLOSE,20);
HJ_13:=CLOSE>MA(CLOSE,20);
HJ_14:=REF(HJ_8,1);
HJ_15:=HJ_8>HJ_14;
HJ_16:=IF(HJ_9,10,0-10)+IF(HJ_10,10,0-10)+IF(HJ_11,10,0-10)+IF(HJ_12,10,0-10)+IF(HJ_13,10,0-10)+IF(HJ_15,10,0-10);
HJ_17:=REF(HJ_16,1)<=0 AND HJ_16>0;
HJ_18:=HJ_16>10 AND HJ_16>=REF(HJ_16,1) AND HJ_16>=REF(HJ_16,2);
HJ_19:=HJ_16=60;
HJ_20:=HJ_17 OR HJ_18 OR HJ_19;
HJ_21:=BARSLAST(NOT(HJ_19));
强势股反杀3:HJ_7 AND HJ_19=1 AND HJ_21=1,NODRAW;
DRAWICON(强势股反杀3,130,13);
{CCI}
INDEX:=CCI(14);
CCI:=CROSS(INDEX,-100);
STICKLINE(CCI AND N<50,50,80,2,0),COLORYELLOW;
STICKLINE(CCI AND N<50 AND N>REF(N,1),50,65,3,0),COLORMAGENTA;
STICKLINE(CCI AND N<50 AND CROSS(RSV2,RSV1),75,80,4,0),COLORRED;
STICKLINE(CCI AND N>50,60,80,1,0),COLORBLUE;
卖线:=EMA(SLOPE(C,24)*20+C,42);
力1:=EMA(SLOPE(C,9)*20+C,50);
力:=EMA(SLOPE(C,9)*20+C,21);
花1:=MA(CLOSE, 1);
女1:=MA(CLOSE, 3);
STICKLINE(卖线>REF(卖线,1) AND 力1>REF(力1,1) AND 力>REF(力,1) AND 花1>REF(花1,1)
AND 女1>REF(女1,1) AND 快>REF(快,1) AND 慢>REF(慢,1)
AND RSV2>REF(RSV2,1) AND RSV1>REF(RSV1,1) AND N>REF(N,1),150,160,3,0),COLORRED;

通达信终极买入升级版指标公式

 

相关文章