在线检测未来函数

通达信MACD参考指标公式

来源:Internet,编辑:股旁网,2017-03-21

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV,30),COLORYELLOW;
AAA:=C>REF(C,1)*1.09 AND C=H;
AQ:=MAX(MAX(MA(CLOSE,7),MA(CLOSE,13)),MA(CLOSE,34));
BQ:=MIN(MIN(MA(CLOSE,7),MA(CLOSE,13)),MA(CLOSE,34));
T2:=REF(MA(C,21),2)<REF(MA(C,21),1)<MA(C,21) AND REF(MA(C,13),2)<REF(MA(C,13),1)<MA(C,13);
T3:=REF(MA(C,34),2)<REF(MA(C,34),1)<MA(C,34) AND REF(MA(C,55),2)<REF(MA(C,55),1)<MA(C,55);
D1:=T2 AND T3 ;
AA:=VOL>REF(V,1)*1.9;
BB:=C>MA(C,5);
三线粘合:=IF(RANGE(100*(AQ-BQ)/BQ,0,5),100*(AQ-BQ)/BQ,DRAWNULL);
MA1:=MA(C,8);
MA2:=MA(C,13);
MA3:=MA(C,21);
MA4:=MA(C,34);
MA5:=MA(C,55);
P1:=ABS(MA1-MA2)+ABS(MA2-MA3)+ABS(MA1-MA4)+ABS(MA2-MA4)+ABS(MA3-MA4)+ABS(MA1-MA3)+ABS(MA1-MA5)+ABS(MA2-MA5)+ABS(MA3-MA5)+ABS(MA4-MA5);
五线粘合:=IF(P1/C<10/100 AND MA1>REF(MA1,1) AND MA2>REF(MA2,1),888,0)COLORRED,LINETHICK3;
P2:=ABS(MA1-MA2)+ABS(MA2-MA3)+ABS(MA1-MA4)+ABS(MA2-MA4)+ABS(MA3-MA4)+ABS(MA1-MA3);
四线粘合:=IF(P2/C<8/100 AND MA1>REF(MA1,1) AND MA2>REF(MA2,1),666,0)COLORYELLOW,LINETHICK3;
P3:=ABS(MA2-MA3)+ABS(MA3-MA4)+ABS(MA2-MA5)+ABS(MA3-MA5)+ABS(MA4-MA5)+ABS(MA2-MA3);
四线粘合2:=IF(P3/C<8/100 AND MA1>REF(MA1,1) AND MA2>REF(MA2,1),777,0)COLORLIRED,LINETHICK3;
粘合IN:=五线粘合 OR 四线粘合 OR 四线粘合2;
资金:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
JXTJ1:=COUNT(粘合IN,10)>=2 AND COUNT(REF(AAA,2),179)>0 AND C>O AND 资金>=80;
DSX1:=C>MA(C,10) AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND C>MA(C,89);
DSX2:=C>MA(C,5) AND MA(C,5)>=MA(C,20) AND MA(C,10)>=MA(C,20) AND C>MA(C,89);
LTP:=C<38 AND FINANCE(7)/100000000<15 AND IF(NAMELIKE('*'),0,1) AND IF(NAMELIKE('S'),0,1);
HC22:=(NDAY(MA(C,21),REF(MA(C,21),1),4) AND BETWEEN(L/MA(C,30),1.001,1.005)) OR (NDAY(MA(C,21),REF(MA(C,21),1),4) AND L<MA(C,30) AND C>MA(C,30)) OR (NDAY(MA(C,21),REF(MA(C,21),1),4) AND ABS((L-MA(C,30)))/MA(C,30)*100<=0.8 AND C>MA(C,30));
HC11:=(NDAY(MA(C,30),REF(MA(C,30),1),4) AND BETWEEN(L/MA(C,30),1.001,1.005)) OR (NDAY(MA(C,30),REF(MA(C,30),1),4) AND L<MA(C,30) AND C>MA(C,30)) OR (NDAY(MA(C,30),REF(MA(C,30),1),4) AND ABS((L-MA(C,30)))/MA(C,30)*100<=0.8 AND C>MA(C,30));
DIFF:=(EMA(C,12)-EMA(C,26))*20;
DEA1:=EMA(DIFF,9);
MACD1:=2*(DIFF-DEA1);
MACD2:=EMA((3*MACD1+2*REF(MACD1,1)+REF(MACD1,2))/6,1);
HC33:=MACD1>MACD2 AND MACD1<0;
DSX:=三线粘合<5 AND C>=MA(C,89) AND D1 AND DSX2;
MDTJ1:=IF(DIF>=DEA,DIF>=DEA,HC33);
MQ1:=REF(MACD,1)>0 AND MACD<=REF(MACD,1) AND MACD>-0.01;
ZSXG:=(MACD>-0.2 AND (DIFF>=0 AND DEA1>=0 AND (MDTJ1 OR MQ1))) AND JXTJ1 AND LTP AND (DSX OR DSX1);
GL1:=(MA(C,5)-MA(C,20))/MA(C,20)*100<10;
GL3:=(MA(C,20)-MA(C,60))/MA(C,60)*100<5;
V5:=MA(VOL,5);
V10:=MA(VOL,13);
V35:=MA(VOL,35);
V60:=MA(VOL,60);
M5:=MA(CLOSE,5);
M10:=MA(CLOSE,10);
M20:=MA(CLOSE,20);
M60:=MA(CLOSE,60);
M120:=MA(CLOSE,120);
G8:=MA(C,8);
G13:=MA(C,13);
G89:=MA(C,89);
NEWTJ1:=MA(C,5)>=MA(C,10) AND (MA(C,10)>=MA(C,20) OR CROSS(MA(C,10),MA(C,20))) AND MA(C,20)>=MA(C,30) AND MA(C,10)>MA(C,60) AND MA(C,10)>=MA(C,250) AND (MA(C,20)>=MA(C,250) OR GL1);
NEWTJ2:=MA(C,5)>=MA(C,10) AND (MA(C,10)>=MA(C,30) OR CROSS(MA(C,10),MA(C,20))) AND MA(C,20)>=MA(C,30) AND MA(C,10)>=MA(C,60) AND GL3;
JXGTJ:=M5>M60 AND M5>G89 AND M5>M120 AND G13>M60 AND G13>G89 AND G13>M120 AND G8>M60 AND G8>G89 AND G8>M120;
JGTJ1:=REF(C,1)/REF(C,2)<1.08 AND C/REF(C,1)>=1.01 AND REF(C,1)>REF(MA(C,250),1) AND C>REF(MA(C,120),1) AND C>MA(C,250) AND C>MA(C,120);
GX:=(MA(C,21)-M60)/M60*100<8.5;
GJTJA:=C>MA(C,5) AND C>MA(C,250) AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,30) AND C>MA(C,120) AND C>REF(C,1);
TJ11:=V5>=V10 AND V5>V60 AND (V10>=V60 OR V10>=V35);
TJ21:=M5>=M10 AND M5>=M20 AND M10>=M20 AND C>M10 AND C>M20 AND C>M60 AND C>M120;
TJ1:=REF(V,1)<REF(V5,1) AND REF(V,1)<REF(V10,1) AND REF(V,1)<REF(V60,1) AND (V5>=V10 OR V5>=V60 OR V5>=V35);
TJ2:=V5>V35 AND V10>=V60 AND V10>=V35;
TJ3:=V5>=V10 AND V5>V60 AND (V10>=V60 OR V10>=V35);
AQB:=MAX(MAX(MA1,MA2),MA3);
B:=MIN(MIN(MA1,MA2),MA3);
DSXN:=RANGE(100*(AQB-B)/B,0,5),100*(AQB-B)/B<12;
M6:=MA(CLOSE,60);
M7:=MA(CLOSE,89);
M8:=MA(CLOSE,120);
LD:=MAX(MAX(M6,M7),M8);
LX:=MIN(MIN(M6,M7),M8);
JXZQ:=RANGE(100*(LD-LX)/LX,0,5),100*(LD-LX)/LX<15;
NGTJG:=ZSXG AND OBV>MAOBV AND GL3 AND GL1 AND JXZQ AND DSXN AND (TJ1 OR TJ2 OR TJ3) AND GJTJA AND JGTJ1 AND JXGTJ AND NEWTJ2;
DRAWICON(FILTER(NGTJG,10),DIF+0.03,13);
DRAWTEXT(FILTER(NGTJG,10),DIF+0.06,'大牛股');
JX5:=MA(CLOSE,5);
JX10:=MA(CLOSE,10);
JX20:=MA(CLOSE,20);
JX30:=MA(CLOSE,30);
JX60:=MA(CLOSE,60);
JX120:=MA(CLOSE,120);
JX250:=MA(CLOSE,250);
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,13);
M3:=MA(CLOSE,21);
AQQ:=MAX(MAX(M1,M2),M3);
BQQ:=MIN(MIN(M1,M2),M3);
DSXNQ:=RANGE(100*(AQQ-BQQ)/BQQ,0,5),100*(AQQ-BQQ)/BQQ<12;
JXDT:=JX5>JX60 AND JX10>JX60 AND JX20>=JX60 AND (JX60>JX120 OR JX60>JX250);
GPSX:=(L-MA(C,5))/MA(C,5)*100<8.5 AND C>JX5 AND C>JX20 AND C>JX60 AND (C>JX250 OR C>JX120);
GJBS:=(MA(C,20)-JX60)/JX60*100<20;
BLZ:=(V/REF(V,1)>=1.90 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.90);
BLBJ:=COUNT(BLZ,8)>=1 OR COUNT(C/REF(C,1)>1.095,7)>=1;
LTPQ:=FINANCE(7)/100000000<5.5 AND IF(NAMELIKE('*'),0,1) AND IF(NAMELIKE('S'),0,1) AND C<58;
GOTO:=DSXNQ AND JXZQ AND JXDT AND GPSX AND GJBS AND BLBJ AND LTPQ;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(控盘,0);
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<0,MACD,0,1,0),COLORCYAN;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,MACD,0,1,0),COLORFF00FF;
主力控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,MACD,0,1,0),COLOR00FF00;
GLZ:=(MA(C,20)-MA(C,250))/MA(C,250)*100<0.5;
GLZ2:=(MA(C,20)-MA(C,30))/MA(C,30)*100<3;
GLZ3:=(MA(C,20)-MA(C,60))/MA(C,60)*100<4;
NEWTJQ:=MA(C,5)>=MA(C,10) AND (MA(C,10)>=MA(C,20) OR CROSS(MA(C,10),MA(C,20))) AND (MA(C,20)>=MA(C,30) OR GLZ2) AND MA(C,10)>MA(C,60) AND MA(C,10)>=MA(C,250) AND (MA(C,20)>=MA(C,250) OR GLZ);
NEWTJQ2:=MA(C,5)>=MA(C,10) AND (MA(C,10)>=MA(C,30) OR CROSS(MA(C,10),MA(C,20))) AND (MA(C,20)>=MA(C,30) OR GLZ2) AND MA(C,10)>=MA(C,60) AND GLZ3;
JGTJ:=REF(C,1)/REF(C,2)<1.09 AND C/REF(C,1)>=1.01;
ZT:=C>REF(C,1)*1.09 AND C=H;
ZTTJ:=COUNT(REF(ZT,3),179)>0;
MA10:=MA(CLOSE,10);
MA54:=MA(CLOSE,54);
PL1:=(((CLOSE - MA54) / MA54) < 0.1);
PL2:=(((CLOSE - MA10) / MA10) < 0.3);
PP:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
TY:=((((PP = 0) AND (REF(PP,1) = 0.2)) AND (REF((COUNT((PP = 0.2),10) = 10),1) = 1)) * 1);
GDXG:=TY AND (TJ1 OR TJ2 OR TJ3) AND DSXN AND ZTTJ AND JXZQ AND GX AND JGTJ;
NGO1:=GDXG AND NEWTJQ AND JXGTJ AND JGTJ1;
NGO2:=GDXG AND NEWTJQ2;
NGIN:=COUNT(NGO2,6)>0 AND CROSS(C,MA(C,250));
GO:=FILTER((NGO1 OR NGIN) AND GJTJA AND LTP,5);
HLC:=REF(MA((HIGH+LOW+CLOSE)/3,10),1);
HV:=EMA(HHV(HIGH,10),3);
LV:=EMA(LLV(LOW,10),3);
S1:=EXPMA(CLOSE,12);
S2:=EXPMA(CLOSE,50);
ZD:=ATAN((S1/REF(S1,1)-1)*100)*180/3.1416;
QN:=S1>S2 AND S1>REF(S1,1) AND S2>REF(S2,1) AND C>S1 AND ZD>50 AND C>REF(C,1) AND C>MA(C,5) AND C>MA(C,20) AND MA(C,5)>MA(C,20) AND C>REF(C,1) AND C>REF(H,2)COLORWHITE,NODRAW;
DRAWICON(QN,0,5);
DRAWICON(GO,MACD+0.04,25);

通达信MACD参考指标公式

 

相关文章