在线检测未来函数

通达信上升通道主图及选股指标公式

来源:Internet,编辑:股旁网,2017-03-27

T1:=FINDLOWBARS(L,0,60,1);
T2:=FINDLOWBARS(L,T1,120,1);
DRAWLINE(CURRBARSCOUNT=CONST(T2)+1,L,CURRBARSCOUNT=CONST(T1)+1,L,1),COLORGREEN,DOTLINE;
T3:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T4:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
D1:=REF(L,T3);
D2:=REF(L,T4);
T5:=FINDHIGHBARS(H,20,60,1);
T6:=FINDHIGHBARS(H,T1,120,1);
SG:DRAWLINE(CURRBARSCOUNT=CONST(T6)+1,H,CURRBARSCOUNT=CONST(T5)+1,H,1),COLORRED,DOTLINE;
T7:=BARSLAST(CURRBARSCOUNT=CONST(T5)+1);
T8:=BARSLAST(CURRBARSCOUNT=CONST(T6)+1);
G1:REF(H,T7),COLORRED;
G2:REF(H,T8),COLORRED;
IF(CURRBARSCOUNT=CONST(T1)+1,L,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK3;
IF(CURRBARSCOUNT=CONST(T2)+1,L,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK3;
IF(CURRBARSCOUNT=CONST(T5)+1,H,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK3;
IF(CURRBARSCOUNT=CONST(T6)+1,H,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK3;
XG:=((COUNT(C>G1,T7)=1 AND C>G1 OR CROSS(C,G1)) OR (COUNT(C>SG,T7)=1 AND C>SG OR CROSS(C,SG))) AND D1>D2 AND G1>G2 AND REF(C,T7)/REF(C,T4+1)<1.4;
DRAWICON(XG AND BARSCOUNT(C)>200,L,1);

{
选股公式:

T1:=FINDLOWBARS(L,0,60,1);
T2:=FINDLOWBARS(L,T1,250,1);
T3:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T4:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
D1:=REF(L,T3);
D2:=REF(L,T4);
T5:=FINDHIGHBARS(H,20,60,1);
T6:=FINDHIGHBARS(H,T1,120,1);
SG:=DRAWLINE(CURRBARSCOUNT=CONST(T6)+1,H,CURRBARSCOUNT=CONST(T5)+1,H,1);
T7:=BARSLAST(CURRBARSCOUNT=CONST(T5)+1);
T8:=BARSLAST(CURRBARSCOUNT=CONST(T6)+1);
G1:=REF(H,T7);
G2:=REF(H,T8);
XG:=((COUNT(C>G1,T7)=1 AND C>G1 OR CROSS(C,G1)) OR (COUNT(C>SG,T7)=1 AND C>SG OR CROSS(C,SG))) AND D1>D2 AND G1>G2 AND REF(C,T7)/REF(C,T4+1)<1.4;
COUNT(XG AND BARSCOUNT(C)>200,5);
}

通达信上升通道主图及选股指标公式

 

相关文章