在线检测未来函数

通达信过顶回踩主图及选股指标公式

来源:Internet,编辑:股旁网,2017-03-27

N:=30;
T1:=FINDLOWBARS(L,0,N,1);
T2:=FINDHIGHBARS(H,T1+1,N,1);
T3:=FINDLOWBARS(L,T2+1,N,1);
T4:=FINDHIGHBARS(H,T3+1,N,1);
T5:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T6:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
T7:=BARSLAST(CURRBARSCOUNT=CONST(T3)+1);
T8:=BARSLAST(CURRBARSCOUNT=CONST(T4)+1);
D1:REF(L,T5),COLORGREEN;
G1:REF(H,T6),COLORRED;
D2:=REF(L,T7);
G2:REF(H,T8),COLORRED;
IF(CURRBARSCOUNT=CONST(T1)+1,L,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK3;
IF(CURRBARSCOUNT=CONST(T2)+1,H,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK3;
IF(CURRBARSCOUNT=CONST(T4)+1,H,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK3;
XG:=(COUNT(C>G1,T6)=1 AND C>G1 OR CROSS(C,G1)) AND G1>=G2 AND BETWEEN(D1/G2,0.98,1.05)AND REF(C,T5)/REF(C,T7+1)<1.3;
DRAWICON(XG AND BARSCOUNT(C)>200,L,1);

{
选股公式:

N:=30;
T1:=FINDLOWBARS(L,0,N,1);
T2:=FINDHIGHBARS(H,T1+1,N,1);
T3:=FINDLOWBARS(L,T2+1,N,1);
T4:=FINDHIGHBARS(H,T3+1,N,1);
T5:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T6:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
T7:=BARSLAST(CURRBARSCOUNT=CONST(T3)+1);
T8:=BARSLAST(CURRBARSCOUNT=CONST(T4)+1);
D1:=REF(L,T5);
G1:=REF(H,T6);
D2:=REF(L,T7);
G2:=REF(H,T8);
XG:=(COUNT(C>G1,T6)=1 AND C>G1 OR CROSS(C,G1)) AND G1>=G2
AND BETWEEN(D1/G2,0.98,1.05) AND REF(C,T5)/REF(C,T7+1)<1.3;
COUNT(XG AND BARSCOUNT(C)>200,5);
}

通达信过顶回踩主图及选股指标公式

 

相关文章