在线检测未来函数

通达信带阻力支撑的均线主图指标公式

来源:Internet,编辑:股旁网,2017-03-28

MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORYELLOW;
MA20:MA(C,20),COLORFF00FF;
MA60:MA(CLOSE,60),COLORGREEN;
MA120:MA(C,120),COLORRED;
MA240:MA(C,240),COLORBLUE;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;
VAR100:=IF(DATE<1530730 AND DATE>900101,1,0);
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
{}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLORRED ;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLORYELLOW;
{ 原文链接:HTTP://WWW.GOODGUPIAO.COM/GUPIAOGONGSHI/20692.HTML };
N:=5;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X12:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS
(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X21:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS
(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
短期压力:DRAWLINE(S2,H,S1,H,1),COLORRED;
短期支撑:DRAWLINE(U2,L,U1,L,1),COLORGREEN;
HH1:=IF(S2,H,REF(H,BARSLAST(S2)));
HH2:=IF(S1,H,REF(H,BARSLAST(S1)));
LL1:=IF(U2,L,REF(L,BARSLAST(U2)));
LL2:=IF(U1,L,REF(L,BARSLAST(U1)));
上线:=HH1+(HH2-HH1)*BARSLAST(S2)/(BARSLAST(S2)-BARSLAST(S1));
下线:=LL1+(LL2-LL1)*BARSLAST(U2)/(BARSLAST(U2)-BARSLAST(U1));
XG:=COUNT(CROSS(C,上线),3) AND C/REF(C,1)>1.035 AND C/O>1.045;
选股:=XG AND COUNT(XG,10)=1;
DRAWICON(选股,L,1);
A11:=REF(H,5)=HHV(H,2*5+1);
B11:=FILTER(A11,10);
C11:=BACKSET(B11,5+1);
HDD:=FILTER(C11,10);
前期高位:=REF(H,BARSLAST(HDD));
STICKLINE(H,前期高位,前期高位+0.015,15,0),COLOR0000AA,LINETHICK4;
A111:=REF(L,5)=LLV(L,2*5+1);
B111:=FILTER(A111,10);
C111:=BACKSET(B111,5+1);
HDD1:=FILTER(C111,10);
前期低位:REF(L,BARSLAST(HDD1)),LINETHICK0;
STICKLINE(L,前期低位,前期低位-0.015,15,0),COLOR00AA00,LINETHICK4;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KC:=SMA(RSVC,2,1);
DC:=SMA(KC,2,1);
JC:=3*KC-2*DC;
GX:=CROSS(JC,0);
T1Z:=GX=1;
M:=10;
CCZ:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CCZ);
上轨通道1:=(1+M/100)*DD, COLORBLUE;
下轨通道2:=(1-M/100)*DD,COLORGREEN;
XGV:=(C>下轨通道2) AND (REF(C,1)<REF(下轨通道2,1));
T2Z:=XGV=1;
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)));
买AA:=黄金 AND RSVV<VARB2-2;
短牛:=买AA>0;
T3Z:=短牛=1;
黄金V:=T1Z AND T2Z AND T3Z;{选股要把等号去掉}
DRAWTEXT(黄金V,L*0.94,'↖黄金'),COLORRED;{把这句去掉可以选股};

通达信带阻力支撑的均线主图指标公式

 

相关文章