在线检测未来函数

通达信均线量线角度指标公式

来源:Internet,编辑:股旁网,2017-03-30

MA5:=MA(C,5);
MA7:=MA(C,7);
MA13:=MA(C,13);
MA20:=MA(C,20);
MA34:=MA(C,34);
MA55:=MA(C,55);
MA120:=MA(C,120);
V20:=MA(V,20);
V5:=MA(V,5);
V10:=MA(V,10);
V34:=MA(V,40);
V60:=MA(V,60);
V90:=MA(V,90);
V135:=MA(V,135);
{量倍数: VOL/REF(V,1),COLOR00FFFF,NODRAW;}
PM:=((O-C)/O)*10 ;
V0:=MA(C,5)>REF(MA(C,10),1) AND MA(C,10)>REF(MA(C,21),1)
AND MA(C,21)>REF(MA(C,21),1) ;
角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA7:=ATAN((MA7/REF(MA7,2)-1)*100)*180/3.1416;
角度MA13:=ATAN((MA13/REF(MA13,4)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,4)-1)*100)*180/3.1416 ;
角度MA34:=ATAN((MA34/REF(MA34,3)-1)*100)*180/3.1416 ;
角度MA55:=ATAN((MA55/REF(MA55,2)-1)*100)*180/3.1416 ;
角度MA120:=ATAN((MA120/REF(MA120,3)-1)*100)*180/3.1416 ;
角度10日均量:=ATAN((V10/REF(V10,2)-1)*100)*180/3.1416 ;
角度20日均量:=ATAN((V20/REF(V20,2)-1)*100)*180/3.1416 ;
角度34日均量:=ATAN((V34/REF(V34,2)-1)*100)*180/3.1416 ;
角度60日均量:=ATAN((V60/REF(V60,3)-1)*100)*180/3.1416 ;
角度90日均量:=ATAN((V90/REF(V90,3)-1)*100)*180/3.1416 ;
选股:= 角度MA13>=20 AND 角度MA20>=15 AND 角度MA34>=-10 AND MA(C,13)>MA(C,20) AND MA(C,20)>REF(MA(C,20),1);
选股2:= 角度MA13>=45 AND 角度MA20>=10 AND 角度MA20<40 AND 角度MA34>=-10;
选股3:= 角度MA13<0 AND 角度MA20<0 ;
选股55:= 角度MA55<30 AND 角度MA55>=15;
角度7日: 角度MA7,COLORYELLOW,NODRAW;
角度13日: 角度MA13,COLORGREEN,NODRAW;
角度20日: 角度MA20,COLORYELLOW,NODRAW;
角度34日: 角度MA34,COLORMAGENTA,NODRAW;
角度55日: 角度MA55,COLORGREEN,NODRAW;
角度10均量: 角度10日均量,COLORGREEN,NODRAW;
角度20均量: 角度20日均量,COLORGREEN,NODRAW;
角度34均量: 角度34日均量,COLORGREEN,NODRAW;
角度60均量: 角度60日均量,COLORGREEN,NODRAW;
角度90均量: 角度90日均量,COLORGREEN,NODRAW;
多头1:=MA5>=MA7*0.98 AND MA7>=MA13 AND MA13>=MA20*0.978 ;
多头2:=(MA20>=MA34*0.98 AND 角度MA34>=30 ) OR ( MA20>=MA55*0.98 AND 角度MA55>=30 ) OR (MA20>=MA120*0.978 AND 角度MA120>=30 ) ;
均线多头:=多头1 AND 多头2 AND C>=MA20 AND O>=MA20;
均量角度1:=角度10日均量>=80 AND 角度20日均量>=80;
均量角度2:=角度20日均量>=80 AND 角度34日均量>=80;
均量角度3:=角度10日均量>=80 AND 角度34日均量>=80;
均量角度:=均量角度1 OR 均量角度2 OR 均量角度3;
量多头1:= V5>=V10*0.94 AND V10>=V20 AND V20>=V60*0.94 AND V60>=V90*0.93 ;
量多头2:= V5>=V10*0.94 AND V10>=V20*0.94 AND 均量角度 ;
量多头:=量多头1 OR 量多头2;
涨停1:= ((C-REF(C,1))/REF(C,1))>=0.095;
今日量:=涨停1 OR V>=V10 ;
涨幅 := ((C-REF(C,1))/REF(C,1)>=0.023 OR (C-O)/O)>=0.023;
堆量1:=(V+REF(V,1)+REF(V,2))/3;
堆量11:=(V+REF(V,1)+REF(V,2)+REF(V,3))/4;
堆量2:=(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
堆量3:=(REF(V,9)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
堆量4:=(REF(V,9)+REF(V,10)+REF(V,6)+REF(V,7)+REF(V,8))/5;
堆量:=堆量1/堆量2>=1.9 OR 堆量1/堆量3>=1.9 OR 堆量1/堆量4>=1.9 OR 堆量11/堆量2>=1.9 OR 堆量11/堆量3>=1.9 OR 堆量11/堆量4>=1.9;
堆量0:= 堆量 AND 涨幅 AND C>=MA7 AND C>=MA20 AND C>O;
{(角度MA7>=角度MA13 AND 角度MA13>=角度MA20 AND 角度MA20>=角度MA34) OR STICKLINE(V10>=V20 AND V10>=V90 AND V10>=V135 AND V10>=V60 AND V20>=V60 AND V20>=V90 AND V20>=V135,0,1,4,0), COLORRED,LINETHICK1;}
STICKLINE(量多头 AND 今日量,0,0.9,3,0),COLORMAGENTA,LINETHICK1;
STICKLINE(均线多头, 2.3,3,3,0),COLORLIMAGENTA,LINETHICK1;
STICKLINE(C>REF(HHV(C,100),1), 1,2,3,0),COLOR00FFFF,LINETHICK1;
STICKLINE(堆量0 , 1.7,2.3,3,0),COLORGREEN,LINETHICK1;
STICKLINE(V>REF(HHV(V,60)*0.96,1), 0,0.5,3,0),COLOR00FFFF,LINETHICK1;
V65:=MA(V,5);
我的量:=V>=V65*2;

通达信均线量线角度指标公式

 

相关文章