在线检测未来函数

通达信黄金支解主图指标公式

来源:Internet,编辑:股旁网,2017-03-30

N:=88;DQ:=5;CQ:=14; P:=10;
P1:=(CROSS(MA(CLOSE,3),MA(CLOSE,13))&&MA(CLOSE,13)>REF(MA(CLOSE,13),1));
启动本钱:=REF(LOW,P1),COLORMAGENTA;
VAR1:=LLV(LOW,0);
VAR2:=HHV(HIGH,0);
VAR3:=VAR2-VAR1;
低:= VAR1;
H1:= VAR3*0.191+VAR1;
H2:= VAR3*0.382+VAR1;
H3:= VAR3*0.5+VAR1;
H4:= VAR3*0.618+VAR1;
H5:= VAR3*0.809+VAR1;
高:= VAR2;
极点:REFDATE(高,DATE),COLORWHITE,LINETHICK1,POINTDOT;
一:REFDATE(H1,DATE),COLOR00F662,LINETHICK1,POINTDOT;
二:REFDATE(H2,DATE),COLORFF00FF,LINETHICK1,POINTDOT;
三:REFDATE(H3,DATE),,COLORYELLOW,LINETHICK1,POINTDOT;
四:REFDATE(H4,DATE),,COLORFF00FF,LINETHICK1,POINTDOT;
五:REFDATE(H5,DATE),,COLOR00F662,LINETHICK1,POINTDOT;
低点:REFDATE(低,DATE),COLORWHITE,LINETHICK1,POINTDOT;
TT3:=(CURRBARSCOUNT=P);
TT4:=(CURRBARSCOUNT=P+5);
DRAWNUMBER(ISLASTBAR,极点,极点),COLOR999900;
DRAWTEXT(TT4 AND 极点,极点,'极点:'),COLOR208FFF;
DRAWNUMBER(ISLASTBAR,一,CONST(一)),COLOR999999;
DRAWTEXT(TT4 AND 一,一,'191:'),COLOR208FFF;
DRAWNUMBER(ISLASTBAR,二,CONST(二)),COLORFF00FF;
DRAWTEXT(TT4 AND 二,二,'382:'),COLORFF00FF;
DRAWNUMBER(ISLASTBAR,三,CONST(三)),COLORYELLOW;
DRAWTEXT(TT4 AND 三,三,'1/2:'),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,四,CONST(四)),COLORFF00FF;
DRAWTEXT(TT4 AND 四,四,'618:'),COLORFF00FF;
DRAWNUMBER(ISLASTBAR,五,CONST(五)),COLOR999999;
DRAWTEXT(TT4 AND 五,五,'809:'),COLOR208FFF;
DRAWNUMBER(ISLASTBAR,低点*1.015,CONST(低点)),COLOR999900;
DRAWTEXT(TT4 AND 低点,低点*1.015,'低点:'),COLOR208FFF;
A1:=REF(H,DQ)=HHV(H,2*DQ+1);
B1:=FILTER(A1,DQ);
C1:=BACKSET(B1,DQ+1);
D1:=FILTER(C1,DQ);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN;
A2:=REF(L,DQ)=LLV(L,2*DQ+1);
B2:=FILTER(A2,DQ);
C2:=BACKSET(B2,DQ+1);
D2:=FILTER(C2,DQ);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED;
AA1:=REF(H,CQ)=HHV(H,2*CQ+1);
BB1:=FILTER(AA1,CQ);
CC1:=BACKSET(BB1,CQ+1);
DD1:=FILTER(CC1,CQ);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORBLUE, LINETHICK2;
AA2:=REF(L,CQ)=LLV(L,2*CQ+1);
BB2:=FILTER(AA2,CQ);
CC2:=BACKSET(BB2,CQ+1);
DD2:=FILTER(CC2,CQ);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORCYAN, LINETHICK2;

通达信黄金支解主图指标公式

 

相关文章