在线检测未来函数

通达信好用MACD指标公式

来源:Internet,编辑:股旁网,2017-04-04

DIFF9:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA9:=EMA(DIFF9,9),COLORRED,LINETHICK1;
MACD:2*(DIFF9-DEA9), COLORSTICK,LINETHICK1;
A1:=BARSLAST(REF(CROSS(DIFF9,DEA9),1));
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORFF99AA;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.5,0),COLORBLUE;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0.5,0),COLORGRAY;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORMAGENTA;
DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA : EMA(DIFF9,9),COLORRED,LINETHICK1;
IF(DIFF9<REF(DIFF9,1),DIFF9,DRAWNULL),COLORGREEN;
IF(DEA9<REF(DEA9,1),DEA9,DRAWNULL),COLORGREEN,LINETHICK1;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,2,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.2,' 低金'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,2,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.15,' 二金叉'),COLORYELLOW;
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,2,0),COLOR00FF00;
DRAWTEXT(底背离,-0.19,' 底背'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
STICKLINE(顶背离,0,0.03,2,0),COLORWHITE;
DRAWTEXT(顶背离,0.12,' 顶背'),COLORFF00FF;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.19,'三全项'),COLOR0000FF,LINETHICK2;

通达信好用MACD指标公式

 

相关文章