在线检测未来函数

通达信股市大肥羊主图指标公式

来源:Internet,编辑:股旁网,2017-04-07

P:=14;
M7:MA(C,7),LINETHICK2,COLORYELLOW;
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
黄线上牛股起:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,LINETHICK2,COLORYELLOW;
DRAWBAND(M7,RGB(150,10,10),黄线上牛股起,RGB(0,120,0));
STICKLINE(C>O,O,C,3,1)COLORRED;
STICKLINE(O>C,O,C,3,0)COLORCYAN;
红线上熊出没:=MA(黄线上牛股起,6),COLORRED,LINETHICK2;
DRAWTEXT_FIX(1,0.02,0.05,0,'★黄金坑后,趋势上升。★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.02,0.10,0,'★洋红柱,注意逃顶。★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.02,0.15,0,'★红箭头买,绿箭头卖。★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.02,0.20,0,'★长线大肥羊主图;附图均可。法师9430制作★'),COLORYELLOW;
趋势线:=MA(CLOSE,55),COLORYELLOW,NODRAW;
BBB:=趋势线+2*STD(CLOSE,120),COLORLIBLUE;
CCC:=趋势线-2*STD(CLOSE,60),COLORRED;
VAR1:=HHV(HIGH,55);
VAR3:=HHV(L,55);
顶:VAR1*0.95,COLORBLUE,LINETHICK2;
底:VAR3*0.88,COLORWHITE,LINETHICK2;
操作:(LLV(HIGH,55)+HHV(LOW,55))/2,COLORLIRED,DOTLINE,LINETHICK1;
操作2:(C*4+L*3+H*2+O)/10,COLORGREEN,DOTLINE,LINETHICK1;
STICKLINE(操作<操作2,操作,操作2,0,-1),COLORRED,LINETHICK2;
STICKLINE(操作>操作2,操作,操作2,0,-1),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(操作2 ,M7) AND 操作2<=底,L,1);
DRAWRECTREL(600,125,920,125,80)COLORBLUE;
DRAWRECTREL(600,250,925,250,80)COLORBLUE;
DRAWRECTREL(600,375,925,375,80)COLORBLUE;
DRAWRECTREL(600,500,925,500,80)COLORBLUE;
DRAWRECTREL(600,625,925,625,80)COLORBLUE;
DRAWRECTREL(600,750,925,750,80)COLORBLUE;
DRAWRECTREL(600,875,925,875,80)COLORBLUE;
DRAWTEXT_FIX(1,0.6,0.875,1,'第一防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.75,1,'第二防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.625,1,'第三防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.5,1,'第四防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.375,1,'第五防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.25,1,'第六防线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.125,1,'第七防线'),COLORYELLOW;
DRAWICON(CROSS(顶,操作2),H,2);
OBV:=操作2;
A1:=REF(OBV,P)=HHV(OBV,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(OBV,P)=LLV(OBV,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;
下:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;
ZUYI:=CROSS(操作2,顶);
STICKLINE(ZUYI OR REF(ZUYI,1) OR REF(ZUYI,2) OR REF(ZUYI,3) OR REF(ZUYI,4)
OR REF(ZUYI,5) OR REF(ZUYI,6) AND 操作2>顶,O,C,1,0),COLORMAGENTA;
STICKLINE(下=操作2 OR 下=REF(操作2,1) OR 下=REF(操作2,2) OR 下=REF(操作2,4)
OR 下=REF(操作2,3) AND 操作2<底 AND 操作2<M7,O,C,1,0),COLORYELLOW;
DRAWTEXT(CROSS(M7,黄线上牛股起) AND M7<底,L-0.15,'↖加仓');
MW:=10;
MW1:=CONST(LLVBARS(V,MW));
MW0:IF(CURRBARSCOUNT<=MW+7,CONST(IF(MW1=0,O,REF(O,MW1))),DRAWNULL);
MW2:=IF(CURRBARSCOUNT=MW1+1,MW0,DRAWNULL),CIRCLEDOT;
DRAWTEXT(ISLASTBAR,MW0,' 地量量能平台');
MT1:=IF(ISLASTBAR,REF((C*2-REF(C,3)),1),DRAWNULL);
MT2:=IF(ISLASTBAR,REF((C*2-REF(C,3)),2),DRAWNULL);
MT3:=IF(ISLASTBAR,C*2-REF(C,3),DRAWNULL);
DRAWTEXT(ISLASTBAR,MT2,' ●'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,MT1,' ●'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,MT3,' ●'),COLORMAGENTA,LINETHICK2;

通达信股市大肥羊主图指标公式

 

相关文章