在线检测未来函数

同花顺BIAS资金抄底指标公式

来源:Internet,编辑:股旁网,2017-04-18

VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VAR6:=STICKLINE(VAR5<-4 AND VAR5>-6,-17,-30,5,0);
VAR7:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100+50;
VAR8:=EMA(VAR7,9);
VAR9:=2*(VAR7-VAR8);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(VARA,3,1),coloryellow;
VARB:=SMA(K,3,1);
J:3*K-2*VARB,colorgreen;
试探介入: IF(CROSS(J,VARB) AND COUNT(VAR5<-9,4)>=1,65,-15),LINETHICK2,COLOR6ACCFF;
果断介入: IF(CROSS(J,VARB) AND COUNT(VAR5<-12,3)>=1,95,1),colormagenta;
主力介入: IF(CROSS(J,VARB) AND COUNT(VAR5<-16,4)>=1,40,-15),colorwhite;
VARC:=DRAWICON(CROSS(J,1),1,1);
98;
乖离36: STICKLINE(VAR5<-36,125,110,6,0),COLOR95FBDD;
乖离28: STICKLINE(VAR5<-28 AND VAR5>-36,115,100,6,0),colormagenta ;
乖离24: STICKLINE(VAR5<-24 AND VAR5>-28,105,85,6,0),coloryellow;
乖离20: STICKLINE(VAR5<-20 AND VAR5>-24,95,65,6,0),colorred;
乖离18: STICKLINE(VAR5<-18 AND VAR5>-20,85,55,6,0),COLORDDAA78 ;
乖离16: STICKLINE(VAR5<-16 AND VAR5>-18,75,45,6,0),COLORFFE0C0;
乖离14: STICKLINE(VAR5<-14 AND VAR5>-16,65,35,6,0);
乖离12: STICKLINE(VAR5<-12 AND VAR5>-14,50,20,5,0),colorgreen;
乖离9: STICKLINE(VAR5<-9 AND VAR5>-12,35,5,5,0),COLORAAAE5D;
IF(PERIODNAME<>"日线")
{
统计:"该指标只在日线周期下有效。";
RETURN;
}
//大单净量
r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
//相对强弱
LC := REF(CLOSE,1);//前一日收盘价;
RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
机会区:20,POINTDOT,colorred;
风险区:80,POINTDOT,colorgreen;
风险系数:0.5*相对强弱+0.5*短线波段,coloryellow;
//买入条件;
CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
DRAWICON(X,机会区,"buy");

同花顺BIAS资金抄底指标公式

 

相关文章