在线检测未来函数

通达信阴线淘金之量价齐升主图及选股指标公式

来源:Internet,编辑:股旁网,2017-05-02

AT:=FINDHIGHBARS(REF(C,1)/C,2,60,1);
BT:=FINDHIGHBARS(REF(C,1)/C,2,60,2);
TJ:=BACKSET(BT>AT AND ISLASTBAR,BT+1);
W1:=(CONST(AT)+1=CURRBARSCOUNT)*TJ;
W2:=(CONST(BT)+1=CURRBARSCOUNT)*TJ;
O1:=REF(O,BARSLAST(W1));
H1:=REF(H,BARSLAST(W1));
L1:=REF(L,BARSLAST(W1));
L2:=REF(L,BARSLAST(W2));
H2:=REF(H,BARSLAST(W2));
V1:=REF(V,BARSLAST(W1));
V2:=REF(V,BARSLAST(W2));
A:IF(V1>V2 AND BARSLAST(W2)-BARSLAST(W1)<15 AND H1>=L2 AND L1<L2,O1,DRAWNULL),COLORRED,LINETHICK2;
STICKLINE(BARSLAST(W1)=0,C,O,2,0),COLORGREEN;
STICKLINE(BARSLAST(W2)=0,C,O,2,0),COLORGREEN;
红进:IF(C>A,A,DRAWNULL),COLORRED,LINETHICK2;
绿出:IF(C<A,A,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(BARSLAST(W1)=0,H,'量价齐跌'),DRAWABOVE;
DRAWICON((COUNT(C>A,A)=1 AND C>A OR CROSS(C,A)) AND BARSLAST(W1)<15,L,1);

{
选股公式:

AT:=FINDHIGHBARS(REF(C,1)/C,2,60,1);
BT:=FINDHIGHBARS(REF(C,1)/C,2,60,2);
TJ:=BACKSET(BT>AT AND ISLASTBAR,BT+1);
W1:=(CONST(AT)+1=CURRBARSCOUNT)*TJ;
W2:=(CONST(BT)+1=CURRBARSCOUNT)*TJ;
O1:=REF(O,BARSLAST(W1));
H1:=REF(H,BARSLAST(W1));
L1:=REF(L,BARSLAST(W1));
L2:=REF(L,BARSLAST(W2));
H2:=REF(H,BARSLAST(W2));
V1:=REF(V,BARSLAST(W1));
V2:=REF(V,BARSLAST(W2));
A:=IF(V1>V2 AND BARSLAST(W2)-BARSLAST(W1)<15 AND H1>=L2 AND L1<L2,O1,DRAWNULL);
XG:=(COUNT(C>A,A)=1 AND C>A OR CROSS(C,A)) AND BARSLAST(W1)<15;
COUNT(XG,5);
}

通达信阴线淘金之量价齐升主图及选股指标公式

 

相关文章