在线检测未来函数

通达信板块强者恒强指标公式

来源:Internet,编辑:股旁网,2017-05-03

显强势板块1:=1;
X_1:=30;
个股强弱:(CLOSE-MA(CLOSE,X_1))/MA(CLOSE,X_1)*100,COLORWHITE;
行业强弱:(HY_INDEXC-MA(HY_INDEXC,X_1))/MA(HY_INDEXC,X_1)*100,COLORYELLOW,LINETHICK2;
大盘强弱:(INDEXC-MA(INDEXC,X_1))/MA(INDEXC,X_1)*100,COLORRED,LINETHICK4;
DRAWTEXT(CURRBARSCOUNT=6,行业强弱,HYBLOCK),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=3,大盘强弱,ZSBLOCK),COLORRED;
{======显示位置的数据自己根据需要进行上下左右调整======}
四排位置:=0.028;
横向左右位置:=0.005;
{============}
煤炭A:=("880301$C"-REF("880301$C",1))/REF("880301$C",1)*100;
电力A:=("880305$C"-REF("880305$C",1))/REF("880305$C",1)*100;
石油A:=("880310$C"-REF("880310$C",1))/REF("880310$C",1)*100;
钢铁A:=("880318$C"-REF("880318$C",1))/REF("880318$C",1)*100;
有色A:=("880324$C"-REF("880324$C",1))/REF("880324$C",1)*100;
化纤A:=("880330$C"-REF("880330$C",1))/REF("880330$C",1)*100;
化工A:=("880335$C"-REF("880335$C",1))/REF("880335$C",1)*100;
建材A:=("880344$C"-REF("880344$C",1))/REF("880344$C",1)*100;
造纸A:=("880350$C"-REF("880350$C",1))/REF("880350$C",1)*100;
矿物制品A:=("880351$C"-REF("880351$C",1))/REF("880351$C",1)*100;
日用化工A:=("880355$C"-REF("880355$C",1))/REF("880355$C",1)*100;
农林牧渔A:=("880360$C"-REF("880360$C",1))/REF("880360$C",1)*100;
纺织服饰A:=("880367$C"-REF("880367$C",1))/REF("880367$C",1)*100;
食品饮料A:=("880372$C"-REF("880372$C",1))/REF("880372$C",1)*100;
酿酒A:=("880380$C"-REF("880380$C",1))/REF("880380$C",1)*100;
家用电器A:=("880387$C"-REF("880387$C",1))/REF("880387$C",1)*100;
汽车类A:=("880390$C"-REF("880390$C",1))/REF("880390$C",1)*100;
医疗保健A:=("880398$C"-REF("880398$C",1))/REF("880398$C",1)*100;
家居用品A:=("880399$C"-REF("880399$C",1))/REF("880399$C",1)*100;
医药A:=("880400$C"-REF("880400$C",1))/REF("880400$C",1)*100;
商业连锁A:=("880406$C"-REF("880406$C",1))/REF("880406$C",1)*100;
商贸代理A:=("880414$C"-REF("880414$C",1))/REF("880414$C",1)*100;
传媒娱乐A:=("880418$C"-REF("880418$C",1))/REF("880418$C",1)*100;
广告包装A:=("880421$C"-REF("880421$C",1))/REF("880421$C",1)*100;
文教休闲A:=("880422$C"-REF("880422$C",1))/REF("880422$C",1)*100;
酒店餐饮A:=("880423$C"-REF("880423$C",1))/REF("880423$C",1)*100;
旅游A:=("880424$C"-REF("880424$C",1))/REF("880424$C",1)*100;
航空航天A:=("880430$C"-REF("880430$C",1))/REF("880430$C",1)*100;
船舶A:=("880431$C"-REF("880431$C",1))/REF("880431$C",1)*100;
运输设备A:=("880432$C"-REF("880432$C",1))/REF("880432$C",1)*100;
通用机械A:=("880437$C"-REF("880437$C",1))/REF("880437$C",1)*100;
工业机械A:=("880440$C"-REF("880440$C",1))/REF("880440$C",1)*100;
电气设备A:=("880446$C"-REF("880446$C",1))/REF("880446$C",1)*100;
工程机械A:=("880447$C"-REF("880447$C",1))/REF("880447$C",1)*100;
电器仪表A:=("880448$C"-REF("880448$C",1))/REF("880448$C",1)*100;
电信运营A:=("880452$C"-REF("880452$C",1))/REF("880452$C",1)*100;
公共交通A:=("880453$C"-REF("880453$C",1))/REF("880453$C",1)*100;
水务A:=("880454$C"-REF("880454$C",1))/REF("880454$C",1)*100;
供气供热A:=("880455$C"-REF("880455$C",1))/REF("880455$C",1)*100;
环境保护A:=("880456$C"-REF("880456$C",1))/REF("880456$C",1)*100;
运输服务A:=("880459$C"-REF("880459$C",1))/REF("880459$C",1)*100;
仓储物流A:=("880464$C"-REF("880464$C",1))/REF("880464$C",1)*100;
交通设施A:=("880465$C"-REF("880465$C",1))/REF("880465$C",1)*100;
银行类A:=("880471$C"-REF("880471$C",1))/REF("880471$C",1)*100;
证券类A:=("880472$C"-REF("880472$C",1))/REF("880472$C",1)*100;
保险类A:=("880473$C"-REF("880473$C",1))/REF("880473$C",1)*100;
多元金融A:=("880474$C"-REF("880474$C",1))/REF("880474$C",1)*100;
建筑A:=("880476$C"-REF("880476$C",1))/REF("880476$C",1)*100;
房地产A:=("880482$C"-REF("880482$C",1))/REF("880482$C",1)*100;
电脑设备A:=("880489$C"-REF("880489$C",1))/REF("880489$C",1)*100;
通信设备A:=("880490$C"-REF("880490$C",1))/REF("880490$C",1)*100;
半导体A:=("880491$C"-REF("880491$C",1))/REF("880491$C",1)*100;
元器件A:=("880492$C"-REF("880492$C",1))/REF("880492$C",1)*100;
软件服务A:=("880493$C"-REF("880493$C",1))/REF("880493$C",1)*100;
互联网A:=("880494$C"-REF("880494$C",1))/REF("880494$C",1)*100;
综合类A:=("880497$C"-REF("880497$C",1))/REF("880497$C",1)*100;
最大值1A:=MAX(煤炭A,MAX(电力A,MAX(石油A,MAX(钢铁A,MAX(有色A,MAX(化纤A,MAX(化工A,MAX(建材A,MAX(造纸A,MAX(矿物制品A,日用化工A))))))))));
最大值2A:=MAX(农林牧渔A,MAX(纺织服饰A,MAX(食品饮料A,MAX(酿酒A,MAX(家用电器A,MAX(汽车类A,MAX(医疗保健A,MAX(家居用品A,MAX(医药A,MAX(商业连锁A,商贸代理A))))))))));
最大值3A:=MAX(传媒娱乐A,MAX(广告包装A,MAX(文教休闲A,MAX(酒店餐饮A,MAX(旅游A,MAX(航空航天A,MAX(船舶A,MAX(运输设备A,MAX(通用机械A,MAX(工业机械A,电气设备A))))))))));
最大值4A:=MAX(工程机械A,MAX(电器仪表A,MAX(电信运营A,MAX(公共交通A,MAX(水务A,MAX(供气供热A,MAX(环境保护A,MAX(运输服务A,MAX(仓储物流A,MAX(交通设施A,银行类A))))))))));
最大值5A:=MAX(证券类A,MAX(保险类A,MAX(多元金融A,MAX(建筑A,MAX(房地产A,MAX(电脑设备A,MAX(通信设备A,MAX(半导体A,MAX(元器件A,MAX(软件服务A,MAX(互联网A,综合类A)))))))))));
ZZDZ:=CONST(MAX(最大值1A,MAX(最大值2A,MAX(最大值3A,MAX(最大值4A,最大值5A)))));
DRAWTEXT_FIX(显强势板块1=1,横向左右位置,四排位置,0,' ████████████████'),COLORRED;
XSWZ1:=CONST(IF(ZZDZ-煤炭A=0 OR ZZDZ-电力A=0 OR ZZDZ-石油A=0 OR ZZDZ-钢铁A=0 OR ZZDZ-有色A=0 OR ZZDZ-化纤A=0 OR ZZDZ-化工A=0 OR ZZDZ-建材A=0 OR ZZDZ-造纸A=0 OR ZZDZ-旅游A=0 OR ZZDZ-船舶A=0 OR ZZDZ-水务A=0 OR ZZDZ-建筑A=0 OR ZZDZ-医药A=0,614,IF(ZZDZ-汽车类A=0 OR ZZDZ-银行类A=0 OR ZZDZ-证券类A=0 OR ZZDZ-保险类A=0 OR ZZDZ-房地产A=0 OR ZZDZ-半导体A=0 OR ZZDZ-元器件A=0 OR ZZDZ-互联网A=0 OR ZZDZ-综合类A=0,627,643)));
DRAWTEXT_FIX(ISLASTBAR AND 显强势板块1=1,横向左右位置,四排位置,0,IF(ZZDZ-煤炭A=0,'【今强势板块】:煤炭行业',IF(ZZDZ-电力A=0,'【今强势板块】:电力行业',IF(ZZDZ-石油A=0,'【今强势板块】:石油行业',IF(ZZDZ-钢铁A=0,'【今强势板块】:钢铁行业',IF(ZZDZ-有色A=0,'【今强势板块】:有色行业',IF(ZZDZ-化纤A=0,'【今强势板块】:化纤行业',IF(ZZDZ-化工A=0,'【今强势板块】:化工行业',IF(ZZDZ-建材A=0,'【今强势板块】:建材行业',IF(ZZDZ-造纸A=0,'【今强势板块】:造纸行业',IF(ZZDZ-矿物制品A=0,'【今强势板块】:矿物制品',IF(ZZDZ-日用化工A=0,'【今强势板块】:日用化工',
IF(ZZDZ-农林牧渔A=0,'【今强势板块】:农林牧渔',IF(ZZDZ-纺织服饰A=0,'【今强势板块】:纺织服饰',IF(ZZDZ-食品饮料A=0,'【今强势板块】:食品饮料',IF(ZZDZ-酿酒A=0,'【今强势板块】:酿酒行业',IF(ZZDZ-家用电器A=0,'【今强势板块】:家用电器',IF(ZZDZ-汽车类A=0,'【今强势板块】:汽车行业',IF(ZZDZ-医疗保健A=0,'【今强势板块】:医疗保健',IF(ZZDZ-家居用品A=0,'【今强势板块】:家居用品',IF(ZZDZ-医药A=0,'【今强势板块】:医药行业',IF(ZZDZ-商业连锁A=0,'【今强势板块】:商业连锁',IF(ZZDZ-商贸代理A=0,'【今强势板块】:商贸代理',DRAWNULL))))))))))))))))))))))),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND 显强势板块1=1,横向左右位置,四排位置,0,IF(ZZDZ-传媒娱乐A=0,'【今强势板块】:传媒娱乐',IF(ZZDZ-广告包装A=0,'【今强势板块】:广告包装',IF(ZZDZ-文教休闲A=0,'【今强势板块】:文教休闲',IF(ZZDZ-酒店餐饮A=0,'【今强势板块】:酒店餐饮',IF(ZZDZ-旅游A=0,'【今强势板块】:旅游行业',IF(ZZDZ-航空航天A=0,'【今强势板块】:航空航天',IF(ZZDZ-船舶A=0,'【今强势板块】:船舶行业',IF(ZZDZ-运输设备A=0,'【今强势板块】:运输设备',IF(ZZDZ-通用机械A=0,'【今强势板块】:通用机械',IF(ZZDZ-工业机械A=0,'【今强势板块】:工业机械',IF(ZZDZ-电气设备A=0,'【今强势板块】:电气设备',
IF(ZZDZ-工程机械A=0,'【今强势板块】:工程机械',IF(ZZDZ-电器仪表A=0,'【今强势板块】:电器仪表',IF(ZZDZ-电信运营A=0,'【今强势板块】:电信运营',IF(ZZDZ-公共交通A=0,'【今强势板块】:公共交通',IF(ZZDZ-水务A=0,'【今强势板块】:水务行业',IF(ZZDZ-供气供热A=0,'【今强势板块】:供气供热',IF(ZZDZ-环境保护A=0,'【今强势板块】:环境保护',IF(ZZDZ-运输服务A=0,'【今强势板块】:运输服务',IF(ZZDZ-仓储物流A=0,'【今强势板块】:仓储物流',IF(ZZDZ-交通设施A=0,'【今强势板块】:交通设施',
IF(ZZDZ-银行类A=0,'【今强势板块】:银行板块',IF(ZZDZ-证券类A=0,'【今强势板块】:证券板块',IF(ZZDZ-保险类A=0,'【今强势板块】:保险板块',IF(ZZDZ-多元金融A=0,'【今强势板块】:多元金融',IF(ZZDZ-建筑A=0,'【今强势板块】:建筑行业',IF(ZZDZ-房地产A=0,'【今强势板块】:房产板块',IF(ZZDZ-电脑设备A=0,'【今强势板块】:电脑设备',IF(ZZDZ-通信设备A=0,'【今强势板块】:通信设备',IF(ZZDZ-半导体A=0,'【今强势板块】:半导体类',IF(ZZDZ-元器件A=0,'【今强势板块】:元器件类',IF(ZZDZ-软件服务A=0,'【今强势板块】:软件服务',IF(ZZDZ-互联网A=0,'【今强势板块】:互联网类',IF(ZZDZ-综合类A=0,'【今强势板块】:综合板块',DRAWNULL))))))))))))))))))))))))))))))))))),COLORWHITE;
个股排名:=CONST(INSORT(HYBLOCK,'涨幅',1,0));
HYPM1:=STRCAT('【该股在 (',HYBLOCK);
HYPM2:=STRCAT(HYPM1,') 行业涨幅排名:第');
HYPM3:=STRCAT(HYPM2,VAR2STR(个股排名,0));
HYPM4:=STRCAT(HYPM3,'名】 (板块涨停');
涨停数1:=CONST(INSUM(HYBLOCK,'涨幅',2,0));
涨停数2:=CONST(INSUM(HYBLOCK,'涨幅',3,0));
涨停数:=涨停数1+涨停数2;
HYPM5:=STRCAT(HYPM4,VAR2STR(涨停数,0));
HYPM6:=STRCAT(HYPM5,'支)');
HYPM4A:=STRCAT(HYPM3,'名】 (板块内无个股涨停)');
HYPM4B:=IF(涨停数<10,STRCAT(HYPM3,'名】 █████████'),STRCAT(HYPM3,'名】 ██████████'));
DRAWTEXT_FIX(ISLASTBAR,IF(显强势板块1=0,0.25,横向左右位置+0.32),四排位置,0,IF(涨停数<1,DRAWNULL,HYPM4B)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,IF(显强势板块1=0,0.25,横向左右位置+0.32),四排位置,0,IF(涨停数>=1,HYPM6,HYPM4A)),COLORWHITE;

通达信板块强者恒强指标公式

 

相关文章