在线检测未来函数

通达信中期趋势指标公式

来源:Internet,编辑:股旁网,2017-05-03

DIF55:(EMA(CLOSE,30)-EMA(CLOSE,90))*0.55;
DEA55:(EMA(DIF55,26));
MACD周:(DIF55-DEA55)*2, COLORSTICK;
DRAWBAND(DEA55,RGB(135,200,0),DIF55,RGB(255,0,0));
YUWEI:=MA(CLOSE,1)-MA(CLOSE,6);
线上:=YUWEI>0;
线下:=YUWEI<0;
线下绿柱:=YUWEI<0 AND YUWEI<REF(YUWEI,1);
线下红柱:=YUWEI<0 AND YUWEI>REF(YUWEI,1);
资金买:=CROSS(YUWEI,0);
{上证资金额亿}
上证YUWEI:=MA("999999$CLOSE",1)-MA("999999$CLOSE",6);
上证线上:=上证YUWEI>0;
上证线下:=上证YUWEI<0;
上证线下绿柱:=上证YUWEI<0 AND 上证YUWEI<REF(上证YUWEI,1);
上证线下红柱:=上证YUWEI<0 AND 上证YUWEI>REF(上证YUWEI,1);
上证资金买:=CROSS(上证YUWEI,0);
资金逆市进入值:=COUNT(线上,8)-COUNT(上证线上,8);
助推资金进入:资金逆市进入值>=4 AND CLOSE>OPEN;
N:=18;
M1:=3;
M2:=3;
RSV:=(CLOSE - LLV(LOW,N))/(HHV(HIGH,N) - LLV(LOW,N))*100;
K:=EMA(RSV,M1);
D:=EMA(K,M2);
J:=(3*K-2*D);
KDJ1:=REF(COUNT(J<REF(J,1),5)>=3,1) AND REF(J,1)<20;
KDJ2:=J>REF(J,1);
VAR22:=REF(LOW,1);
VAR33:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR44:=EMA(IF(CLOSE*1.3,VAR33*10,VAR33/10),3);
VAR55:=LLV(LOW,13);
VAR66:=HHV(VAR44,13);
VAR77:=IF(MA(CLOSE,34),1,0);
VAR888:=EMA(IF(LOW<=VAR55,(VAR44+VAR66*2)/2,0),3)/618*VAR77;
VAR999:=IF(VAR888>100,100,VAR888);
吸筹:=VAR999,LINETHICK1,COLORCD7F32 ;
吸筹下:=吸筹 < REF(吸筹,1);
趋势线:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORFF6666,LINETHICK2;
趋势线上:=趋势线 > REF(趋势线,1);
抄底资金进入:吸筹下 AND 趋势线上 AND CROSS(趋势线,吸筹) COLORYELLOW;
QUAN:(CLOSE-DMA(CLOSE,VOL/SUM(VOL,13)))/DMA(CLOSE,VOL/SUM(VOL,13))*100<=-28 AND (CLOSE-DMA(CLOSE,VOL/SUM(VOL,34)))/DMA(CLOSE,VOL/SUM(VOL,34))*100<=-19
AND C/REF(C,25)<=1.1 AND IF((((HIGH > (LOW * 1.051)) AND (COUNT((HIGH > (LOW * 1.051)),5) > 1)) AND ((((CLOSE / MA(CLOSE,40)) * 100) < 78) OR
(((CLOSE / MA(CLOSE,60)) * 100) < 74))),2,0) AND
(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15 AND IF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)>REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)
AND REF(SMA((CLOSE-LLV(LOW,8))/
(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)<REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),2)
AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)<23 ,1.5,0) AND FILTER((C/MA(C,48))<0.75 AND (C/MA(C,70))<0.70 AND
((C-L)/C>0.02 OR C>REF(C,1)*1.01) AND V<REF(V,1)*2.8 AND (COUNT(C<O*0.93,2)=2 OR COUNT(H/L>1.1,5)>3),3) ;

通达信中期趋势指标公式

 

相关文章