在线检测未来函数

通达信差价等着你指标公式

来源:Internet,编辑:股旁网,2017-05-05

N10:=10;
N:=34;
M1:=12;
M2:=10;
N1:=18;
N2:=6;
P1:=-6;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
卖线:= 99;
阶卖:= 90;
趋:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部:= 10;
买信:= IF(CROSS(趋,底部),48,0),COLOR1010FF,LINETHICK1;
庄影:= STICKLINE(VAR8,0,VAR8,6,1) , COLORFFAAFF;
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
VA3:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VA4:=SMA(SMA(VA3,3,1),3,1);
VA5:=EMA(VA4,5);
VA6:=VA5;
VA7:=3*VA4-2*VA5;
VA8:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VA8,3,1);
D:= SMA(K,3,1);
VA9:=3*K-2*D;
VAA:=LLV(LOW,36);
VAB:=HHV(HIGH,30);
VAC:=EMA((CLOSE-VAA)/(VAB-VAA)*4,4)*25;
趋势:= VAC;
VAD:=87.5;
VAE:=(VAC-LLV(VAC,4))/(HHV(VAC,4)-LLV(VAC,4))*4*25;
短买:= IF(CROSS(趋势,10) AND 趋势>10,50,0), , COLORRED,LINETHICK3;
VAF:=SMA(VA3,20,1);
VA10:=SMA(VAF,15,1);
VA11:=(3*VAF+2*VA10)/4;
VA12:=REF(VA11,1);
VA13:=SMA(MAX(VA11-VA12,0),2,1)/SMA(ABS(VA11-VA12),2,1)*100;
VA14:=MA(VA13,10);
VA15:=IF(CROSS(VA14,90),25,0);
VA16:=(CLOSE+LOW+HIGH)/3;
VA17:=SUM((VA16-REF(LOW,1)-(HIGH-VA16))*VOL/100000/(HIGH-LOW),0);
VA18:=EMA(VA17,1);
VA19:=MA(VA18,12);
VA1A:=MA(VA18,26);
VA1B:=(VA18-VA19)*10;
VA1C:=CAPITAL/EMA(VOL,5)/30*1.1;
VA1D:=IF(CROSS(VA1B,VA1C),1,0);
VA1E:=FILTER(VA1D,7);
VA1F:=DRAWICON(VA1E=1,20,1);
VA20:=EMA(CLOSE,12)-EMA(CLOSE,26);
VA21:=(CLOSE*2+HIGH+LOW)/4;
VA22:=EMA(VA21,12)-EMA(VA21,26);
VA23:=EMA(VA22,2);
VA24:=2*(VA22-VA23)*5.8;
VA25:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VA26:=66.6;
VR1:=(HIGH+LOW+CLOSE+OPEN)/4;
VR2:=(VR1-MA(VR1,14))/(0.015*AVEDEV(VR1,14));
VR3:=(VR1-MA(VR1,70))/(0.015*AVEDEV(VR1,70));
VR4:=IF(VR2>=150 AND VR2<200 AND VR3>=150 AND VR3<200,15,0);
VR5:=IF(VR2<=-150 AND VR2>-200 AND VR3<=-150 AND VR3>-200,-15,VR4);
祈祷:(IF(VR3>=200 AND VR2>=150,25,IF(VR3<=-200 AND VR2<=-150,-25,VR5))+50),COLORCC9900 ,LINETHICK2 ;
势:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,COLORCCFFFF;
价线:=(势-0.5)/5*EMA(C,20)/3,COLORYELLOW,LINETHICK2;
量线:=(C*VOL-LLV(L,20)*VOL)/(HHV(H,20)*VOL-LLV(L,20)*VOL)*100,COLORFF00FF,LINETHICK2;
底线:=20,COLORWHITE;
VAR1:=4*SMA((CLOSE-LLV(LOW,N10))/(HHV(HIGH,N10)-LLV(LOW,N10))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N10))/(HHV(HIGH,N10)-LLV(LOW,N10))*100,5,1),3.2,1),COLORYELLOW,LINETHICK2;
VA2:=8,COLORGREEN,LINETHICK0;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K1:=SMA(RSV,M1,1),COLORWHITE;
D1:SMA(K1,M2,1),COLORYELLOW;
J:3*K1-2*D1,COLORFF00FF;
LC := REF(C,4);
RMI:= SMA(MAX(C-LC,0),7,1)/SMA(ABS(C-LC),7,1)*100,COLORFF00FF;
RMIMA:= SMA(RMI,3,1),COLOR009C00,LINETHICK3;
差价等着你:IF(RMIMA<5 ,30.00,0),COLOR00FF00,LINETHICK1;
CC:=CLOSE;
CCH:=HHV(C,240);
CCL:=LLV(C,240);
CCJ:=(CCH-CCL);
V3:=CC<CCL+CCJ*20 AND LLV(CC,10)=CCL AND HHV(CC,120)<CCH;
V4:=CC>CCL*1.1 AND FINANCE(33)>0;
V5:=V4 AND COUNT(V4,2)=1 AND CC<MA(C,240)*0.75;
价格趋势:=(CC-CCL)/CCJ,COLORYELLOW;
中线买进:=(V3 AND V5),STICK,COLORYELLOW,LINETHICK2;
DRAWTEXT(中线买进=0.5,0.5,'8'),COLORYELLOW;
头:IF(COUNT(价格趋势=1.0,2)=2,30,0),COLORYELLOW,LINETHICK1;
DRAWTEXT(COUNT(价格趋势=1.0,2)=2,25,'头'),COLORYELLOW;
底:IF(COUNT(价格趋势=0,2)=2,20,0),COLORLIRED,LINETHICK4;
DRAWTEXT(底=0.5,20,'底'),COLORRED;
{参数:P1:最小:-10,最大:10,默认-6}
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1+2*BIAS2+3*BIAS3)/6;
股价趋势:MA(MM,3),COLORBLUE;
买入信号:EMA(股价趋势,2);
DRAWTEXT(股价趋势<P1 ,60,'买'),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(股价趋势,买入信号) AND COUNT(买入信号<P1,2)>1,70,'必买'),COLORGREEN,LINETHICK1;

通达信差价等着你指标公式

 

相关文章